aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-12-17 13:10:02 +0000
committerSteve Wills <swills@FreeBSD.org>2013-12-17 13:10:02 +0000
commit042a5028e8ead2f04f7f83838beb06b6d31cfe45 (patch)
tree9be3d7db4872aaf507feff70aa18816cb9a52915 /net-p2p
parentadfcb65b1bf148d5a2f5ed1392b87fd20a447899 (diff)
downloadports-042a5028e8ead2f04f7f83838beb06b6d31cfe45.tar.gz
ports-042a5028e8ead2f04f7f83838beb06b6d31cfe45.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/litecoin/Makefile10
-rw-r--r--net-p2p/litecoin/distinfo4
-rw-r--r--net-p2p/litecoin/files/extra-patch-endian47
-rw-r--r--net-p2p/litecoin/files/patch-src__serialize.h22
4 files changed, 56 insertions, 27 deletions
diff --git a/net-p2p/litecoin/Makefile b/net-p2p/litecoin/Makefile
index 45e7dcaf1c40..e5e691ad4b56 100644
--- a/net-p2p/litecoin/Makefile
+++ b/net-p2p/litecoin/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= litecoin
-PORTVERSION= 0.8.5.1
+PORTVERSION= 0.8.6.1
CATEGORIES= net-p2p finance
MASTER_SITES= LOCAL/swills \
GH
@@ -14,14 +14,14 @@ LIB_DEPENDS= libboost_date_time.so:${PORTSDIR}/devel/boost-libs
USE_GITHUB= yes
GH_ACCOUNT= litecoin-project
-GH_COMMIT= 6cef39c
+GH_COMMIT= dab8fe6
GH_TAGNAME= v${PORTVERSION}
USE_OPENSSL= yes
USE_BDB= yes
WANT_BDB_VER= 48
-USE_GMAKE= yes
+USES= gmake
OPTIONS_DEFINE= GUI UPNP QRCODES DBUS
OPTIONS_DEFAULT= GUI QRCODES
@@ -72,6 +72,10 @@ QMAKE_USE_DBUS= 0
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 1000000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-endian
+.endif
+
do-configure:
.if ${PORT_OPTIONS:MGUI} && !defined(WITHOUT_X11)
cd ${BUILD_WRKSRC} && \
diff --git a/net-p2p/litecoin/distinfo b/net-p2p/litecoin/distinfo
index 44878e21dbec..d417bf458f89 100644
--- a/net-p2p/litecoin/distinfo
+++ b/net-p2p/litecoin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (litecoin-0.8.5.1.tar.gz) = 7588349de2b006153bde642468dbddd215986ca18ca7d5ef896092cab5488c49
-SIZE (litecoin-0.8.5.1.tar.gz) = 4783538
+SHA256 (litecoin-0.8.6.1.tar.gz) = ff11a4d5bd0cf9ddac0b1644d0819ec3d6827e5052addcbc871d288286188019
+SIZE (litecoin-0.8.6.1.tar.gz) = 4807148
diff --git a/net-p2p/litecoin/files/extra-patch-endian b/net-p2p/litecoin/files/extra-patch-endian
new file mode 100644
index 000000000000..8a016d89daad
--- /dev/null
+++ b/net-p2p/litecoin/files/extra-patch-endian
@@ -0,0 +1,47 @@
+--- src/scrypt.cpp.orig 2013-12-09 18:10:12.046606050 +0000
++++ src/scrypt.cpp 2013-12-09 18:10:25.898605023 +0000
+@@ -34,22 +34,6 @@
+ #include <string.h>
+ #include <openssl/sha.h>
+
+-static inline uint32_t be32dec(const void *pp)
+-{
+- const uint8_t *p = (uint8_t const *)pp;
+- return ((uint32_t)(p[3]) + ((uint32_t)(p[2]) << 8) +
+- ((uint32_t)(p[1]) << 16) + ((uint32_t)(p[0]) << 24));
+-}
+-
+-static inline void be32enc(void *pp, uint32_t x)
+-{
+- uint8_t *p = (uint8_t *)pp;
+- p[3] = x & 0xff;
+- p[2] = (x >> 8) & 0xff;
+- p[1] = (x >> 16) & 0xff;
+- p[0] = (x >> 24) & 0xff;
+-}
+-
+ typedef struct HMAC_SHA256Context {
+ SHA256_CTX ictx;
+ SHA256_CTX octx;
+--- src/scrypt.h.orig 2013-12-09 15:26:17.343282984 +0000
++++ src/scrypt.h 2013-12-09 15:45:11.032205545 +0000
+@@ -17,19 +17,4 @@
+ PBKDF2_SHA256(const uint8_t *passwd, size_t passwdlen, const uint8_t *salt,
+ size_t saltlen, uint64_t c, uint8_t *buf, size_t dkLen);
+
+-static inline uint32_t le32dec(const void *pp)
+-{
+- const uint8_t *p = (uint8_t const *)pp;
+- return ((uint32_t)(p[0]) + ((uint32_t)(p[1]) << 8) +
+- ((uint32_t)(p[2]) << 16) + ((uint32_t)(p[3]) << 24));
+-}
+-
+-static inline void le32enc(void *pp, uint32_t x)
+-{
+- uint8_t *p = (uint8_t *)pp;
+- p[0] = x & 0xff;
+- p[1] = (x >> 8) & 0xff;
+- p[2] = (x >> 16) & 0xff;
+- p[3] = (x >> 24) & 0xff;
+-}
+ #endif
diff --git a/net-p2p/litecoin/files/patch-src__serialize.h b/net-p2p/litecoin/files/patch-src__serialize.h
deleted file mode 100644
index a199c7f7f352..000000000000
--- a/net-p2p/litecoin/files/patch-src__serialize.h
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/serialize.h.orig 2013-09-21 15:05:20.000000000 +0000
-+++ src/serialize.h 2013-09-21 15:06:01.000000000 +0000
-@@ -895,19 +895,6 @@
- iterator insert(iterator it, const char& x=char()) { return vch.insert(it, x); }
- void insert(iterator it, size_type n, const char& x) { vch.insert(it, n, x); }
-
-- void insert(iterator it, const_iterator first, const_iterator last)
-- {
-- assert(last - first >= 0);
-- if (it == vch.begin() + nReadPos && (unsigned int)(last - first) <= nReadPos)
-- {
-- // special case for inserting at the front when there's room
-- nReadPos -= (last - first);
-- memcpy(&vch[nReadPos], &first[0], last - first);
-- }
-- else
-- vch.insert(it, first, last);
-- }
--
- void insert(iterator it, std::vector<char>::const_iterator first, std::vector<char>::const_iterator last)
- {
- assert(last - first >= 0);