aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2010-02-06 21:28:12 +0000
committerMax Khon <fjoe@FreeBSD.org>2010-02-06 21:28:12 +0000
commit14fb0a97f57efc412bdcc4571db24b0a1fa17eb4 (patch)
treee2e70275626f854ae7fb152d538c222157e4bbe0 /net-p2p
parent2f3ab82ac9369b057e657bb57a8896350905bc50 (diff)
downloadports-14fb0a97f57efc412bdcc4571db24b0a1fa17eb4.tar.gz
ports-14fb0a97f57efc412bdcc4571db24b0a1fa17eb4.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/linuxdcpp/Makefile2
-rw-r--r--net-p2p/linuxdcpp/files/patch-client-HashManager.cpp20
2 files changed, 21 insertions, 1 deletions
diff --git a/net-p2p/linuxdcpp/Makefile b/net-p2p/linuxdcpp/Makefile
index 6e3abe62ee28..00b85899fa32 100644
--- a/net-p2p/linuxdcpp/Makefile
+++ b/net-p2p/linuxdcpp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= linuxdcpp
PORTVERSION= 1.0.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-p2p
MASTER_SITES= ${MASTER_SITE_LOCAL} http://freebsd.nsu.ru/distfiles/
MASTER_SITE_SUBDIR= danfe
diff --git a/net-p2p/linuxdcpp/files/patch-client-HashManager.cpp b/net-p2p/linuxdcpp/files/patch-client-HashManager.cpp
new file mode 100644
index 000000000000..e62eb919fd48
--- /dev/null
+++ b/net-p2p/linuxdcpp/files/patch-client-HashManager.cpp
@@ -0,0 +1,20 @@
+--- client/HashManager.cpp.orig 2010-02-06 12:57:41.000000000 +0600
++++ client/HashManager.cpp 2010-02-06 12:58:04.000000000 +0600
+@@ -636,13 +636,13 @@
+ currentSize = max(static_cast<uint64_t>(currentSize - size_read), static_cast<uint64_t>(0));
+ }
+
+- if(size_left <= 0) {
+- break;
+- }
+-
+ munmap(buf, size_read);
+ pos += size_read;
+ size_left -= size_read;
++
++ if(size_left <= 0) {
++ break;
++ }
+ }
+ close(fd);
+ return true;