aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-09-11 14:57:58 +0000
committerRene Ladan <rene@FreeBSD.org>2021-09-30 21:23:30 +0000
commit620968a43a5f9bb3fa98ab20f257a4c0d864caa7 (patch)
tree09bef799707f4b6e715b912429bd3b73c1addf4c /net-p2p
parentb9a93c0bf4778b9ec327c1be6f819eb1ff90ec19 (diff)
downloadports-620968a43a5f9bb3fa98ab20f257a4c0d864caa7.tar.gz
ports-620968a43a5f9bb3fa98ab20f257a4c0d864caa7.zip
cleanup: drop support for EOL FreeBSD 11.X
Search criteria used: - 11.4 - OSREL* - OSVER* - *_FreeBSD_11 Input from: - adridg: devel/qca-legacy - jbeich: _WITH_DPRINTF, _WITH_GETLINE, GNU bfd workarounds - sunpoet: security/p5-*OpenSSL* Reviewed by: doceng, kde, multimedia, perl, python, ruby, rust Differential Revision: https://reviews.freebsd.org/D32008 Test Plan: make index
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/monero-cli/Makefile4
-rw-r--r--net-p2p/openethereum/Makefile2
-rw-r--r--net-p2p/qtum/Makefile14
3 files changed, 2 insertions, 18 deletions
diff --git a/net-p2p/monero-cli/Makefile b/net-p2p/monero-cli/Makefile
index a314905e11cf..e101575d8be8 100644
--- a/net-p2p/monero-cli/Makefile
+++ b/net-p2p/monero-cli/Makefile
@@ -60,8 +60,6 @@ DOXYGEN_CMAKE_BOOL= BUILD_DOCUMENTATION
# /usr/bin/ld -melf_amd64 -r -b binary -o blocksdat.o blocks.dat
# See Bug 226996 - net-p2p/monero-cli: fails to link with lld as the system linker
# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=226996
-.if ${OSVERSION} >= 1200000
-
.if ${ARCH} == aarch64
LD_EMULATION= aarch64elf
.elif ${ARCH} == amd64
@@ -76,8 +74,6 @@ LD_EMULATION= elf64ppc
CMAKE_ARGS+= -DLD_RAW_FLAGS:STRING=-m${LD_EMULATION}
-.endif
-
# keep in sync with all platforms where libunwind is available
.if ${ARCH} == aarch64 || ${ARCH} == amd64 || ${ARCH} == i386 || ${ARCH} == powerpc64 || ${ARCH} == powerpc64le
LIB_DEPENDS+= libunwind.so:devel/libunwind
diff --git a/net-p2p/openethereum/Makefile b/net-p2p/openethereum/Makefile
index eb3d0c54ee8e..aee63724cf24 100644
--- a/net-p2p/openethereum/Makefile
+++ b/net-p2p/openethereum/Makefile
@@ -19,8 +19,6 @@ PLIST_FILES= bin/${PORTNAME}
CARGO_FEATURES= final
CARGO_TEST= yes
-RUSTFLAGS+= -C link-arg=-fuse-ld=lld
-
CARGO_GIT_SUBDIR= rethutil:reth-util:crates/util
post-install:
diff --git a/net-p2p/qtum/Makefile b/net-p2p/qtum/Makefile
index 1dbc02928733..c2c7dffe44ae 100644
--- a/net-p2p/qtum/Makefile
+++ b/net-p2p/qtum/Makefile
@@ -27,7 +27,8 @@ USES= autoreconf bdb:5+ compiler:c++14-lang cpe gmake libtool pkgconfig qt:5 ss
GNU_CONFIGURE= yes
CONFIGURE_ENV+= BDB_CFLAGS="-I${BDB_INCLUDE_DIR}" \
BDB_LIBS="-L${BDB_LIB_DIR} -l${BDB_LIB_CXX_NAME}" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include"
# * Man pages have not been adjusted after cloning the Bitcoin code base.
# They are the old Bitcoin man pages, so do not install them.
# * --with-incompatible-bdb is required in order to use bdb-5.
@@ -62,15 +63,4 @@ CONFIGURE_ENV+= CRYPTO_CFLAGS="-I${OPENSSLINC}" \
SSL_LIBS="-lssl"
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200000
-# Force PIC on FreeBSD 11.x because otherwise linking fails:
-# /usr/bin/ld: qtum_cli-bitcoin-cli.o: relocation R_X86_64_32 against `a local
-# symbol' can not be used when making a shared object; recompile with -fPIC
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -fPIC -DPIC"
-post-patch:
- ${REINPLACE_CMD} -e 's/AC_SUBST(PIE_FLAGS)//' ${WRKSRC}/configure.ac
-.else
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include"
-.endif
-
.include <bsd.port.post.mk>