aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-02-06 19:04:25 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-02-06 19:04:25 +0000
commitf53943b6c7e3a52d88bf18bf33e62f4bfa92f5ef (patch)
tree71a8070899367b99b012893e3a870aba5e7e686c /net-p2p
parent2406aa43282f07321933d323036049e87f8187dd (diff)
downloadports-f53943b6c7e3a52d88bf18bf33e62f4bfa92f5ef.tar.gz
ports-f53943b6c7e3a52d88bf18bf33e62f4bfa92f5ef.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/linuxdcpp/Makefile15
-rw-r--r--net-p2p/linuxdcpp/distinfo6
-rw-r--r--net-p2p/linuxdcpp/files/patch-SConstruct51
-rw-r--r--net-p2p/linuxdcpp/files/patch-client_Text.cpp11
4 files changed, 47 insertions, 36 deletions
diff --git a/net-p2p/linuxdcpp/Makefile b/net-p2p/linuxdcpp/Makefile
index 13576475adf8..18b82cda6925 100644
--- a/net-p2p/linuxdcpp/Makefile
+++ b/net-p2p/linuxdcpp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= linuxdcpp
-PORTVERSION= 0.0.1.20070104 #0.0.1.YYYYMMDD
+PORTVERSION= 0.0.1.20070204 #0.0.1.YYYYMMDD
CATEGORIES= net-p2p
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://people.freebsd.org/~mezz/distfiles/
@@ -18,24 +18,19 @@ COMMENT= A port of the win32 DC++ direct connect client to POSIX-like systems
USE_XLIB= yes
USE_BZIP2= yes
USE_GNOME= libglade2
+USE_ICONV= yes
USE_SCONS= yes
USE_OPENSSL= yes
.if defined(WITH_DEBUG)
SCONS_ARGS= debug=1
-STRIP=
.else
SCONS_ARGS= release=1
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= does not compile on FreeBSD 4.x, due to lack of wide character in libc
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%CC%%|${CC}|g ; s|%%CXX%%|${CXX}|g ; \
- s|%%CXXFLAGS%%|${CXXFLAGS}|g' ${WRKSRC}/SConstruct
+ s|%%CXXFLAGS%%|${CXXFLAGS}|g ; s|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/SConstruct
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-p2p/linuxdcpp/distinfo b/net-p2p/linuxdcpp/distinfo
index 2de8efd85e63..0d1e71c66091 100644
--- a/net-p2p/linuxdcpp/distinfo
+++ b/net-p2p/linuxdcpp/distinfo
@@ -1,3 +1,3 @@
-MD5 (linuxdcpp-0.0.1.20070104.tar.bz2) = 53746052bdfaade59116e0ad6b30c592
-SHA256 (linuxdcpp-0.0.1.20070104.tar.bz2) = 5701ced266cf2ae13e165ccfcfab058b96bfe7c79c9878aa696458d0005d2c00
-SIZE (linuxdcpp-0.0.1.20070104.tar.bz2) = 347597
+MD5 (linuxdcpp-0.0.1.20070204.tar.bz2) = f3ad092a5757fd2e59a99eadfb1e9ad2
+SHA256 (linuxdcpp-0.0.1.20070204.tar.bz2) = 56f76b7f3fd69bf30737b400aa64a1647fb0caedd96cbca80e692c46bcca5304
+SIZE (linuxdcpp-0.0.1.20070204.tar.bz2) = 349400
diff --git a/net-p2p/linuxdcpp/files/patch-SConstruct b/net-p2p/linuxdcpp/files/patch-SConstruct
index dd4984d7c403..f28371517c6e 100644
--- a/net-p2p/linuxdcpp/files/patch-SConstruct
+++ b/net-p2p/linuxdcpp/files/patch-SConstruct
@@ -1,5 +1,5 @@
---- SConstruct.orig Mon Jan 1 12:17:39 2007
-+++ SConstruct Mon Jan 1 12:19:12 2007
+--- SConstruct.orig Mon Feb 5 01:15:08 2007
++++ SConstruct Mon Feb 5 01:17:03 2007
@@ -62,7 +62,7 @@
# Initialization
# ----------------------------------------------------------------------
@@ -9,29 +9,34 @@
conf = Configure(env,
custom_tests =
-@@ -128,11 +128,6 @@
- print '\tHeader file unistd.h not found'
- Exit(1)
+@@ -130,11 +130,6 @@
+ print '\tHeader file unistd.h not found'
+ Exit(1)
--if not conf.CheckLibWithHeader('pthread', 'pthread.h', 'c'):
-- print '\tpthread library not found'
-- print '\tNote: You might have the lib but not the headers'
-- Exit(1)
+- if not conf.CheckLibWithHeader('pthread', 'pthread.h', 'c'):
+- print '\tpthread library not found'
+- print '\tNote: You might have the lib but not the headers'
+- Exit(1)
-
- if not conf.CheckLibWithHeader('z', 'zlib.h', 'c'):
- print '\tz library (gzip/z compression) not found'
- print '\tNote: You might have the lib but not the headers'
-@@ -159,11 +154,11 @@
- env.Append(LINKFLAGS = ['-Wl,--as-needed'])
+ if not conf.CheckLibWithHeader('z', 'zlib.h', 'c'):
+ print '\tz library (gzip/z compression) not found'
+ print '\tNote: You might have the lib but not the headers'
+@@ -157,15 +152,15 @@
+ # Compile and link flags
+ # ----------------------------------------------------------------------
+
+- env.Append(CXXFLAGS = Split('-I. -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64'))
++ env.Append(CXXFLAGS = Split('-I. -I%%LOCALBASE%%/include -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64'))
+ env.Append(LINKFLAGS = ['-Wl,--as-needed'])
- if env.has_key('debug') and env['debug']:
-- env.Append(CXXFLAGS = Split('-g -ggdb -D_DEBUG -Wall'))
-+ env.Append(CXXFLAGS = Split('%%CXXFLAGS%% -g -ggdb -D_DEBUG -Wall'))
- env.Append(LINKFLAGS = Split('-g -ggdb -Wall'))
+ if env.has_key('debug') and env['debug']:
+- env.Append(CXXFLAGS = Split('-g -ggdb -D_DEBUG -Wall'))
++ env.Append(CXXFLAGS = Split('%%CXXFLAGS%% -g -ggdb -D_DEBUG -Wall'))
+ env.Append(LINKFLAGS = Split('-g -ggdb -Wall'))
- if env.has_key('release') and env['release']:
-- env.Append(CXXFLAGS = '-O3')
-+ env.Append(CXXFLAGS = '%%CXXFLAGS%%')
+ if env.has_key('release') and env['release']:
+- env.Append(CXXFLAGS = '-O3')
++ env.Append(CXXFLAGS = '%%CXXFLAGS%%')
- if env.has_key('profile') and env['profile']:
- env.Append(CXXFLAGS = '-pg')
+ if env.has_key('profile') and env['profile']:
+ env.Append(CXXFLAGS = '-pg')
diff --git a/net-p2p/linuxdcpp/files/patch-client_Text.cpp b/net-p2p/linuxdcpp/files/patch-client_Text.cpp
new file mode 100644
index 000000000000..bf460b55dd56
--- /dev/null
+++ b/net-p2p/linuxdcpp/files/patch-client_Text.cpp
@@ -0,0 +1,11 @@
+--- client/Text.cpp.orig Mon Feb 5 17:59:13 2007
++++ client/Text.cpp Mon Feb 5 17:59:21 2007
+@@ -309,7 +309,7 @@
+ char *outbuf = (char *)tmp.data();
+
+ while(inleft > 0) {
+- rv = iconv(cd, (char **)&inbuf, &inleft, &outbuf, &outleft);
++ rv = iconv(cd, &inbuf, &inleft, &outbuf, &outleft);
+ if(rv == (size_t)-1) {
+ size_t used = outbuf - tmp.data();
+ if(errno == E2BIG) {