aboutsummaryrefslogtreecommitdiff
path: root/net/6tunnel
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-02-16 12:53:36 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-02-16 12:53:36 +0000
commitcd28df40e9c5d39846820f6ecf06fd7bdc0c9d4e (patch)
treef7cf653f09de304f5f938d0c3f7c1d8be2cbf18f /net/6tunnel
parent2554fb56138d3faab507e9fcf2bda3523f5262cd (diff)
downloadports-cd28df40e9c5d39846820f6ecf06fd7bdc0c9d4e.tar.gz
ports-cd28df40e9c5d39846820f6ecf06fd7bdc0c9d4e.zip
- Update to 0.11rc1 from new master site
- Fix grammar in COMMENT
Notes
Notes: svn path=/head/; revision=129018
Diffstat (limited to 'net/6tunnel')
-rw-r--r--net/6tunnel/Makefile14
-rw-r--r--net/6tunnel/distinfo4
-rw-r--r--net/6tunnel/files/patch-aa34
-rw-r--r--net/6tunnel/files/patch-ab49
-rw-r--r--net/6tunnel/files/patch-configure11
-rw-r--r--net/6tunnel/pkg-descr2
6 files changed, 21 insertions, 93 deletions
diff --git a/net/6tunnel/Makefile b/net/6tunnel/Makefile
index a601f8447b03..88138535f436 100644
--- a/net/6tunnel/Makefile
+++ b/net/6tunnel/Makefile
@@ -6,18 +6,16 @@
#
PORTNAME= 6tunnel
-PORTVERSION= 0.09
+PORTVERSION= 0.11.r1
CATEGORIES= net ipv6
-MASTER_SITES= ftp://amba.bydg.pdi.net/pub/wojtekka/ \
- ftp://ftp.bsdfr.org/pub/projects/6tunnel/ \
- ftp://atlantis.bsd-fr.org/pub/ipv6/tools/ \
- http://rencade.raphit.net/~vt/
+MASTER_SITES= http://toxygen.net/6tunnel/
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}rc1
MAINTAINER= ports@FreeBSD.org
-COMMENT= TCP proxy for application that don't speak IPv6
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
+COMMENT= TCP proxy for applications that don't speak IPv6
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
+GNU_CONFIGURE= yes
ALL_TARGET= default
MAN1= 6tunnel.1
diff --git a/net/6tunnel/distinfo b/net/6tunnel/distinfo
index 995ebd8ce105..1253578a535d 100644
--- a/net/6tunnel/distinfo
+++ b/net/6tunnel/distinfo
@@ -1,2 +1,2 @@
-MD5 (6tunnel-0.09.tar.gz) = cd430e156f30369e13927e1abadcca58
-SIZE (6tunnel-0.09.tar.gz) = 7389
+MD5 (6tunnel-0.11rc1.tar.gz) = b325fa9d238e32195fbb3fc3646b0d28
+SIZE (6tunnel-0.11rc1.tar.gz) = 38126
diff --git a/net/6tunnel/files/patch-aa b/net/6tunnel/files/patch-aa
deleted file mode 100644
index bbd2e6bacd2c..000000000000
--- a/net/6tunnel/files/patch-aa
+++ /dev/null
@@ -1,34 +0,0 @@
---- Makefile.orig Sun Nov 19 16:12:17 2000
-+++ Makefile Fri Jan 5 17:00:06 2001
-@@ -1,4 +1,4 @@
--CC = gcc -O2 -Wall
-+CFLAGS += -Wall
- VER = 0.07
- RPM_ROOT = /home/wojtekka/rpm
-
-@@ -6,9 +6,9 @@
- @echo -e -- \\033[1m6tunnel\\033[0m make --
- @if [ -d /usr/local/v6/lib ]; then make KAME; else make generic; fi
- generic:
-- $(CC) 6tunnel.c -o 6tunnel
-+ $(CC) $(CFLAGS) 6tunnel.c -o 6tunnel
- KAME:
-- $(CC) 6tunnel.c -o 6tunnel -L/usr/local/v6/lib -linet6
-+ $(CC) $(CFLAGS) 6tunnel.c -o 6tunnel -L/usr/local/v6/lib -linet6
-
- install:
- @case $$(uname -s) in \
-@@ -21,10 +21,10 @@
- install 6tunnel /usr/local/bin
- install 6tunnel.1 /usr/local/man/man1
-
--install-bsd: default
-+install-bsd:
- strip 6tunnel
-- install 6tunnel /usr/local/bin
-- install 6tunnel.1 /usr/local/share/man/man1
-+ ${BSD_INSTALL_PROGRAM} 6tunnel ${PREFIX}/bin
-+ ${BSD_INSTALL_MAN} 6tunnel.1 ${PREFIX}/man/man1
-
- targz: clean
- cd ..; tar zcvf 6tunnel/6tunnel-$(VER).tar.gz --exclude 6tunnel/6tunnel-$(VER).tar.gz --exclude 6tunnel/older 6tunnel
diff --git a/net/6tunnel/files/patch-ab b/net/6tunnel/files/patch-ab
deleted file mode 100644
index 2f2c50b2c5b6..000000000000
--- a/net/6tunnel/files/patch-ab
+++ /dev/null
@@ -1,49 +0,0 @@
---- 6tunnel.c.orig Fri Oct 19 16:24:52 2001
-+++ 6tunnel.c Thu Jul 17 20:12:05 2003
-@@ -429,26 +429,26 @@
-
- void usage(char *a0)
- {
-- fprintf(stderr, "\
--usage: %s [-146dqvh] [-s sourcehost] [-l localhost] [-i pass]
-- [-I pass] [-m mapfile] [-L limit] [-A filename]
-- localport remotehost [remoteport]
--
-- -1 allow only one connection and quit
-- -4 preffer IPv4 endpoints
-- -6 bind to IPv6 address
-- -v be verbose
-- -d don't detach
-- -f force tunneling (even if remotehost isn't resolvable)
-- -s connect using specified address
-- -l bind to specified address
-- -i act like irc proxy and ask for password
-- -I send specified password to the irc server
-- -h print hex dump of packets
-- -m map specified IPv4 addresses to different IPv6 addresses (see manpage)
-- -L limit simultanous connections
-- -A create apache-like log file
--
-+ fprintf(stderr, "\n\
-+usage: %s [-146dqvh] [-s sourcehost] [-l localhost] [-i pass]\n\
-+ [-I pass] [-m mapfile] [-L limit] [-A filename]\n\
-+ localport remotehost [remoteport]\n\
-+ \n\
-+ -1 allow only one connection and quit\n\
-+ -4 preffer IPv4 endpoints\n\
-+ -6 bind to IPv6 address\n\
-+ -v be verbose\n\
-+ -d don't detach\n\
-+ -f force tunneling (even if remotehost isn't resolvable)\n\
-+ -s connect using specified address\n\
-+ -l bind to specified address\n\
-+ -i act like irc proxy and ask for password\n\
-+ -I send specified password to the irc server\n\
-+ -h print hex dump of packets\n\
-+ -m map specified IPv4 addresses to different IPv6 addresses (see manpage)\n\
-+ -L limit simultanous connections\n\
-+ -A create apache-like log file\n\
-+\
- ", a0);
-
- }
diff --git a/net/6tunnel/files/patch-configure b/net/6tunnel/files/patch-configure
new file mode 100644
index 000000000000..a6f2e79caedd
--- /dev/null
+++ b/net/6tunnel/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Wed Feb 16 13:47:48 2005
++++ configure Wed Feb 16 13:48:05 2005
+@@ -3188,6 +3188,8 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
++#include <sys/types.h>
++#include <sys/socket.h>
+ #include <netinet/in.h>
+ int
+ main ()
diff --git a/net/6tunnel/pkg-descr b/net/6tunnel/pkg-descr
index 4b026ee665e6..3d4bd9301be8 100644
--- a/net/6tunnel/pkg-descr
+++ b/net/6tunnel/pkg-descr
@@ -3,5 +3,7 @@ applications and vice versa. It can bind to any of your IPv4 (default) or
IPv6 addresses and forward all data to IPv4 or IPv6 (default) host.
It can be used for example as an ipv6-capable IRC proxy.
+WWW: http://toxygen.net/6tunnel/
+
- Vassili Tchersky
vt@bsd-fr.org