aboutsummaryrefslogtreecommitdiff
path: root/net/6tunnel
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2001-03-02 12:46:35 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2001-03-02 12:46:35 +0000
commit9ff055a21518431eb6bbfa61e768443759827102 (patch)
tree0cc1be3677d815421daa57c9f2c106d1d1c4bf04 /net/6tunnel
parent14fe1774e39b3bb2384b751d27cd8ac55d88128f (diff)
downloadports-9ff055a21518431eb6bbfa61e768443759827102.tar.gz
ports-9ff055a21518431eb6bbfa61e768443759827102.zip
Notes
Diffstat (limited to 'net/6tunnel')
-rw-r--r--net/6tunnel/Makefile23
-rw-r--r--net/6tunnel/distinfo1
-rw-r--r--net/6tunnel/files/patch-aa34
-rw-r--r--net/6tunnel/pkg-comment1
-rw-r--r--net/6tunnel/pkg-descr7
-rw-r--r--net/6tunnel/pkg-plist1
6 files changed, 67 insertions, 0 deletions
diff --git a/net/6tunnel/Makefile b/net/6tunnel/Makefile
new file mode 100644
index 000000000000..96c79c3d62d5
--- /dev/null
+++ b/net/6tunnel/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: 6tunnel
+# Date created: Sun Nov 19 12:51:37 CET 2000
+# Whom: Vassili Tchersky <vt@bsdjeunz.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= 6tunnel
+PORTVERSION= 0.07
+CATEGORIES= net ipv6
+MASTER_SITES= ftp://amba.bydg.pdi.net/pub/wojtekka/ \
+ ftp://ftp.bsdjeunz.org/pub/ipv6/tools/
+
+MAINTAINER= vt@bsdjeunz.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+ALL_TARGET= default
+
+MAN1= 6tunnel.1
+MANCOMPRESSED= no
+
+.include <bsd.port.mk>
diff --git a/net/6tunnel/distinfo b/net/6tunnel/distinfo
new file mode 100644
index 000000000000..234a58cf61dc
--- /dev/null
+++ b/net/6tunnel/distinfo
@@ -0,0 +1 @@
+MD5 (6tunnel-0.07.tar.gz) = 53bd1c5cf9f06c3e1b2029207f34ba61
diff --git a/net/6tunnel/files/patch-aa b/net/6tunnel/files/patch-aa
new file mode 100644
index 000000000000..0a8aa46ab2c1
--- /dev/null
+++ b/net/6tunnel/files/patch-aa
@@ -0,0 +1,34 @@
+--- Makefile.orig Sun Nov 19 16:12:17 2000
++++ Makefile Fri Jan 5 17:00:06 2001
+@@ -1,4 +1,4 @@
+-CC = gcc -O2 -Wall
++CFLAGS += -O2 -Wall
+ VER = 0.07
+ RPM_ROOT = /home/wojtekka/rpm
+
+@@ -6,9 +6,9 @@
+ @echo -e -- \\033[1m6tunnel\\033[0m make --
+ @if [ -d /usr/local/v6/lib ]; then make KAME; else make generic; fi
+ generic:
+- $(CC) 6tunnel.c -o 6tunnel
++ $(CC) $(CFLAGS) 6tunnel.c -o 6tunnel
+ KAME:
+- $(CC) 6tunnel.c -o 6tunnel -L/usr/local/v6/lib -linet6
++ $(CC) $(CFLAGS) 6tunnel.c -o 6tunnel -L/usr/local/v6/lib -linet6
+
+ install:
+ @case $$(uname -s) in \
+@@ -21,10 +21,10 @@
+ install 6tunnel /usr/local/bin
+ install 6tunnel.1 /usr/local/man/man1
+
+-install-bsd: default
++install-bsd:
+ strip 6tunnel
+- install 6tunnel /usr/local/bin
+- install 6tunnel.1 /usr/local/share/man/man1
++ ${BSD_INSTALL_PROGRAM} 6tunnel ${PREFIX}/bin
++ ${BSD_INSTALL_MAN} 6tunnel.1 ${PREFIX}/man/man1
+
+ targz: clean
+ cd ..; tar zcvf 6tunnel/6tunnel-$(VER).tar.gz --exclude 6tunnel/6tunnel-$(VER).tar.gz --exclude 6tunnel/older 6tunnel
diff --git a/net/6tunnel/pkg-comment b/net/6tunnel/pkg-comment
new file mode 100644
index 000000000000..38b6c49faeb7
--- /dev/null
+++ b/net/6tunnel/pkg-comment
@@ -0,0 +1 @@
+TCP proxy for application that don't speak IPv6
diff --git a/net/6tunnel/pkg-descr b/net/6tunnel/pkg-descr
new file mode 100644
index 000000000000..5182abc1b3a8
--- /dev/null
+++ b/net/6tunnel/pkg-descr
@@ -0,0 +1,7 @@
+6tunnel allows you to use services provided by IPv6 hosts with IPv4-only
+applications and vice versa. It can bind to any of your IPv4 (default) or
+IPv6 addresses and forward all data to IPv4 or IPv6 (default) host.
+It can be used for example as an ipv6-capable IRC proxy.
+
+- Vassili Tchersky
+vt@bsdjeunz.org
diff --git a/net/6tunnel/pkg-plist b/net/6tunnel/pkg-plist
new file mode 100644
index 000000000000..7f1da5ee2229
--- /dev/null
+++ b/net/6tunnel/pkg-plist
@@ -0,0 +1 @@
+bin/6tunnel