aboutsummaryrefslogtreecommitdiff
path: root/net/GeoIP
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-07-04 11:22:49 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-07-04 11:22:49 +0000
commit3c3ab07abe5e0098957547972e004c4a463b4bb7 (patch)
treef8a6f49072abd7ffb8f474d62f8fe1ff268b6814 /net/GeoIP
parent01941640e1c5b82efae58c1d057018388650e399 (diff)
Notes
Diffstat (limited to 'net/GeoIP')
-rw-r--r--net/GeoIP/Makefile6
-rw-r--r--net/GeoIP/files/geoipupdate.sh5
-rw-r--r--net/GeoIP/files/geoipupdate.sh.in2
3 files changed, 6 insertions, 7 deletions
diff --git a/net/GeoIP/Makefile b/net/GeoIP/Makefile
index a66ab0a3c961..b161c12e6d92 100644
--- a/net/GeoIP/Makefile
+++ b/net/GeoIP/Makefile
@@ -7,7 +7,7 @@
PORTNAME= GeoIP
PORTVERSION= 1.4.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net geography
MASTER_SITES= http://geolite.maxmind.com/download/geoip/api/c/
@@ -22,11 +22,13 @@ USE_LDCONFIG= yes
MAN1= geoiplookup.1 geoipupdate.1 geoiplookup6.1
+SUB_FILES= geoipupdate.sh
+
run-autotools:
@${REINPLACE_CMD} -e '/^LIBTOOL=/s^\$$(top_builddir)/libtool^${LIBTOOL}^g' \
${WRKSRC}/aclocal.m4
post-install:
- ${INSTALL_SCRIPT} ${FILESDIR}/geoipupdate.sh ${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKDIR}/geoipupdate.sh ${PREFIX}/bin/
.include <bsd.port.mk>
diff --git a/net/GeoIP/files/geoipupdate.sh b/net/GeoIP/files/geoipupdate.sh
deleted file mode 100644
index 36a9bd25c7cf..000000000000
--- a/net/GeoIP/files/geoipupdate.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-cd /tmp
-fetch http://geolite.maxmind.com/download/geoip/database/GeoLiteCountry/GeoIP.dat.gz
-gunzip GeoIP.dat.gz
-mv -f GeoIP.dat /usr/local/share/GeoIP
diff --git a/net/GeoIP/files/geoipupdate.sh.in b/net/GeoIP/files/geoipupdate.sh.in
new file mode 100644
index 000000000000..89145deaf6b3
--- /dev/null
+++ b/net/GeoIP/files/geoipupdate.sh.in
@@ -0,0 +1,2 @@
+#!/bin/sh
+fetch -o - http://geolite.maxmind.com/download/geoip/database/GeoLiteCountry/GeoIP.dat.gz | gunzip > %%DATADIR%%/GeoIP.dat