aboutsummaryrefslogtreecommitdiff
path: root/net/GeoIP
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-06-12 21:37:01 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-06-12 21:37:01 +0000
commitcb00e89e4a6d067a6d7fe97b1cdb636f41dcdfbd (patch)
treec865024eada1f17c5cfb6d20597e4c9c6a999cac /net/GeoIP
parentc9727b28399ace69c8d904892f3f784098f73c1f (diff)
downloadports-cb00e89e4a6d067a6d7fe97b1cdb636f41dcdfbd.tar.gz
ports-cb00e89e4a6d067a6d7fe97b1cdb636f41dcdfbd.zip
Notes
Diffstat (limited to 'net/GeoIP')
-rw-r--r--net/GeoIP/Makefile28
-rw-r--r--net/GeoIP/pkg-descr3
-rw-r--r--net/GeoIP/pkg-plist6
3 files changed, 18 insertions, 19 deletions
diff --git a/net/GeoIP/Makefile b/net/GeoIP/Makefile
index 483d0aaa1d9c..d5d1a1fe7707 100644
--- a/net/GeoIP/Makefile
+++ b/net/GeoIP/Makefile
@@ -1,29 +1,27 @@
# Created by: Yen-Ming Lee <leeym@leeym.com>
# $FreeBSD$
-PORTNAME= GeoIP
+PORTNAME= GeoIP
PORTVERSION= 1.4.8
-PORTREVISION= 4
-CATEGORIES= net geography
+PORTREVISION= 5
+CATEGORIES= net geography
MASTER_SITES= http://geolite.maxmind.com/download/geoip/api/c/
-MAINTAINER= adamw@FreeBSD.org
-COMMENT= Find the country that any IP address or hostname originates from
-
-CONFIGURE_ARGS= CC="${CC}" PATH="${PATH}" \
- CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Find the country that any IP address or hostname originates from
GNU_CONFIGURE= yes
-USES= libtool:oldver
+USES= libtool:oldver
USE_LDCONFIG= yes
-SUB_FILES= geoipupdate.sh
-
-run-autotools:
- @${REINPLACE_CMD} -e '/^LIBTOOL=/s^\$$(top_builddir)/libtool^${LIBTOOL}^g' \
- ${WRKSRC}/aclocal.m4
+SUB_FILES= geoipupdate.sh
post-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/geoipupdate.sh ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKDIR}/geoipupdate.sh ${STAGEDIR}${PREFIX}/bin
+ ${MV} ${STAGEDIR}${DATADIR}/GeoIP.dat \
+ ${STAGEDIR}${DATADIR}/GeoIP.dat.sample
+ ${MV} ${STAGEDIR}${PREFIX}/etc/GeoIP.conf.default \
+ ${STAGEDIR}${PREFIX}/etc/GeoIP.conf.sample
+ ${RM} ${STAGEDIR}${PREFIX}/etc/GeoIP.conf
.include <bsd.port.mk>
diff --git a/net/GeoIP/pkg-descr b/net/GeoIP/pkg-descr
index 7732aca84439..a73940541ea6 100644
--- a/net/GeoIP/pkg-descr
+++ b/net/GeoIP/pkg-descr
@@ -8,4 +8,7 @@ This module can be used to automatically select the geographically closest
mirror, to analyze your web server logs to determine the countries of your
visitors, for credit card fraud detection, and for software export controls.
+This port includes a helper script, geoipupdate.sh, to help you keep the
+library up-to-date.
+
WWW: http://www.maxmind.com/geoip/
diff --git a/net/GeoIP/pkg-plist b/net/GeoIP/pkg-plist
index 6eb139558402..8396d5f78238 100644
--- a/net/GeoIP/pkg-plist
+++ b/net/GeoIP/pkg-plist
@@ -2,9 +2,7 @@ bin/geoiplookup
bin/geoiplookup6
bin/geoipupdate
bin/geoipupdate.sh
-@unexec if cmp -s %D/etc/GeoIP.conf %D/etc/GeoIP.conf.default; then rm -f %D/etc/GeoIP.conf; fi
-etc/GeoIP.conf.default
-@exec if [ ! -f %D/etc/GeoIP.conf ]; then cp -p %D/%F %B/GeoIP.conf; fi
+@sample etc/GeoIP.conf.sample
include/GeoIP.h
include/GeoIPCity.h
include/GeoIPUpdate.h
@@ -16,7 +14,7 @@ lib/libGeoIPUpdate.a
lib/libGeoIPUpdate.la
lib/libGeoIPUpdate.so
lib/libGeoIPUpdate.so.0
-%%DATADIR%%/GeoIP.dat
+@sample %%DATADIR%%/GeoIP.dat.sample
man/man1/geoiplookup.1.gz
man/man1/geoiplookup6.1.gz
man/man1/geoipupdate.1.gz