aboutsummaryrefslogtreecommitdiff
path: root/net/GeoIP
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-03-27 11:58:26 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-03-27 11:58:26 +0000
commit58b6bf31768692e2a638f7d1ca1e7c52d02b9378 (patch)
treebc2c9530189b21523f988afa9d61d36c07b33088 /net/GeoIP
parent0849112fa8db34481d85c4f7cf046697f8d23da6 (diff)
- Remove memcpy/bcopy macro
- Bump PORTREVISION PR: ports/152548 Submitted by: Dmitry Marakasov <amdmi3@amdmi3.ru>
Notes
Notes: svn path=/head/; revision=271882
Diffstat (limited to 'net/GeoIP')
-rw-r--r--net/GeoIP/Makefile1
-rw-r--r--net/GeoIP/files/patch-libGeoIP-GeoIP.h13
2 files changed, 14 insertions, 0 deletions
diff --git a/net/GeoIP/Makefile b/net/GeoIP/Makefile
index 5af071f7b35a..a33d99684a11 100644
--- a/net/GeoIP/Makefile
+++ b/net/GeoIP/Makefile
@@ -7,6 +7,7 @@
PORTNAME= GeoIP
PORTVERSION= 1.4.6
+PORTREVISION= 1
CATEGORIES= net geography
MASTER_SITES= http://geolite.maxmind.com/download/geoip/api/c/
diff --git a/net/GeoIP/files/patch-libGeoIP-GeoIP.h b/net/GeoIP/files/patch-libGeoIP-GeoIP.h
new file mode 100644
index 000000000000..2f012313ffa6
--- /dev/null
+++ b/net/GeoIP/files/patch-libGeoIP-GeoIP.h
@@ -0,0 +1,13 @@
+--- libGeoIP/GeoIP.h.orig 2009-02-24 19:03:23.000000000 +0300
++++ libGeoIP/GeoIP.h 2010-11-24 19:21:26.000000000 +0300
+@@ -241,10 +241,6 @@
+ /* Get timezone from country and region code */
+ GEOIP_API const char * GeoIP_time_zone_by_country_and_region(const char *country_code, const char *region_code);
+
+-#ifdef BSD
+-#define memcpy(dest, src, n) bcopy(src, dest, n)
+-#endif
+-
+ #ifdef __cplusplus
+ }
+ #endif