aboutsummaryrefslogtreecommitdiff
path: root/net/GeoIP
diff options
context:
space:
mode:
authorSean Chittenden <seanc@FreeBSD.org>2003-01-15 17:48:22 +0000
committerSean Chittenden <seanc@FreeBSD.org>2003-01-15 17:48:22 +0000
commitba6b1feabef0264c1df7c90b1d4f5c44ebee1a87 (patch)
tree070323240a0711dc4bd0e061be6bdd50e204ba91 /net/GeoIP
parentbcaed97efe85ccf47c07504aa8f1e1a32970c8e7 (diff)
downloadports-ba6b1feabef0264c1df7c90b1d4f5c44ebee1a87.tar.gz
ports-ba6b1feabef0264c1df7c90b1d4f5c44ebee1a87.zip
Notes
Diffstat (limited to 'net/GeoIP')
-rw-r--r--net/GeoIP/Makefile2
-rw-r--r--net/GeoIP/distinfo2
-rw-r--r--net/GeoIP/files/patch-apps::geoipexport.c33
-rw-r--r--net/GeoIP/files/patch-libGeoIP::GeoIPBitReader.c11
-rw-r--r--net/GeoIP/files/patch-libGeoIP::Makefile41
5 files changed, 43 insertions, 46 deletions
diff --git a/net/GeoIP/Makefile b/net/GeoIP/Makefile
index 9e52f5f2499a..92f6267565ca 100644
--- a/net/GeoIP/Makefile
+++ b/net/GeoIP/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= GeoIP
-PORTVERSION= 1.1.3
+PORTVERSION= 1.1.4
CATEGORIES= net
MASTER_SITES= http://www.maxmind.com/download/geoip/api/c/
diff --git a/net/GeoIP/distinfo b/net/GeoIP/distinfo
index 13ec800a9410..a4501fc06dcd 100644
--- a/net/GeoIP/distinfo
+++ b/net/GeoIP/distinfo
@@ -1 +1 @@
-MD5 (GeoIP-1.1.3.tar.gz) = 166249ca3c774222511a7d20e060ac81
+MD5 (GeoIP-1.1.4.tar.gz) = 204a38ec98f3cc7102fefbeec2b52fac
diff --git a/net/GeoIP/files/patch-apps::geoipexport.c b/net/GeoIP/files/patch-apps::geoipexport.c
deleted file mode 100644
index 3307f2e7b8ae..000000000000
--- a/net/GeoIP/files/patch-apps::geoipexport.c
+++ /dev/null
@@ -1,33 +0,0 @@
---- apps/geoipexport.c.orig Tue Dec 17 13:35:21 2002
-+++ apps/geoipexport.c Thu Dec 26 20:41:20 2002
-@@ -37,7 +37,7 @@
-
- char * _num_to_addr (unsigned long num) {
- char * addr = malloc(15);
-- sprintf(addr, "%u.%u.%u.%u",
-+ sprintf(addr, "%u.%u.%u.%lu",
- (int)floor(num/16777216),
- ((int)floor(num/65536)) % 256,
- ((int)floor(num/256)) % 256,
-@@ -76,9 +76,9 @@
- int main (int argc, char *argv[]) {
- FILE *f;
- GeoIPBitReader *gibr;
-- int databaseType, record, val;
-- int exportType;
-- ulong beginIp = 0, endIp = 0;
-+ int databaseType, record, val = 0;
-+ int exportType = 0;
-+ unsigned long beginIp = 0, endIp = 0;
-
- if (argc < 4) {
- usage();
-@@ -127,7 +127,7 @@
- full_csv_export(databaseType, beginIp, endIp - 1, val, f);
- }
- beginIp = endIp;
-- printf("setting beginIp to %d\n",beginIp);
-+ printf("setting beginIp to %lu\n",beginIp);
- } else {
- /* record = netmask - 1 */
- endIp += (1 << (31 - record));
diff --git a/net/GeoIP/files/patch-libGeoIP::GeoIPBitReader.c b/net/GeoIP/files/patch-libGeoIP::GeoIPBitReader.c
deleted file mode 100644
index edddb7984667..000000000000
--- a/net/GeoIP/files/patch-libGeoIP::GeoIPBitReader.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- libGeoIP/GeoIPBitReader.c.orig Thu Dec 26 20:09:06 2002
-+++ libGeoIP/GeoIPBitReader.c Thu Dec 26 20:08:44 2002
-@@ -32,7 +32,7 @@
- }
-
- unsigned long GeoIPBitReader_read(GeoIPBitReader * gibr, short int numBits) {
-- ulong num = 0;
-+ unsigned long num = 0;
- int i, bit;
- int bytes_read;
-
diff --git a/net/GeoIP/files/patch-libGeoIP::Makefile b/net/GeoIP/files/patch-libGeoIP::Makefile
new file mode 100644
index 000000000000..4f98c9e0c03d
--- /dev/null
+++ b/net/GeoIP/files/patch-libGeoIP::Makefile
@@ -0,0 +1,41 @@
+--- libGeoIP/Makefile.am.orig Wed Jan 15 09:36:37 2003
++++ libGeoIP/Makefile.am Wed Jan 15 09:36:58 2003
+@@ -1,15 +1,15 @@
+ lib_LTLIBRARIES = libGeoIP.la libGeoIPUpdate.la libGeoIPBitReader.la
+
+-EXTRA_DIST = md5.h global.h GeoIPUpdate.h
++EXTRA_DIST = md5.h global.h
+
+ AM_CPPFLAGS = -DGEOIPDATADIR=\"$(pkgdatadir)\" -Wall
+
+ if WITH_CITY
+ libGeoIP_la_SOURCES = GeoIP.c GeoIPCity.c
+-include_HEADERS = GeoIP.h GeoIPCity.h GeoIPBitReader.h
++include_HEADERS = GeoIP.h GeoIPCity.h GeoIPBitReader.h GeoIPUpdate.h
+ else
+ libGeoIP_la_SOURCES = GeoIP.c
+-include_HEADERS = GeoIP.h GeoIPBitReader.h
++include_HEADERS = GeoIP.h GeoIPBitReader.h GeoIPUpdate.h
+ endif
+
+ libGeoIPUpdate_la_SOURCES = GeoIPUpdate.c md5.c
+--- libGeoIP/Makefile.in.orig Wed Jan 15 09:37:09 2003
++++ libGeoIP/Makefile.in Wed Jan 15 09:38:35 2003
+@@ -87,14 +87,14 @@
+ install_sh = @install_sh@
+ lib_LTLIBRARIES = libGeoIP.la libGeoIPUpdate.la libGeoIPBitReader.la
+
+-EXTRA_DIST = md5.h global.h GeoIPUpdate.h
++EXTRA_DIST = md5.h global.h
+
+ AM_CPPFLAGS = -DGEOIPDATADIR=\"$(pkgdatadir)\" -Wall
+
+ @WITH_CITY_TRUE@libGeoIP_la_SOURCES = GeoIP.c GeoIPCity.c
+ @WITH_CITY_FALSE@libGeoIP_la_SOURCES = GeoIP.c
+-@WITH_CITY_TRUE@include_HEADERS = GeoIP.h GeoIPCity.h GeoIPBitReader.h
+-@WITH_CITY_FALSE@include_HEADERS = GeoIP.h GeoIPBitReader.h
++@WITH_CITY_TRUE@include_HEADERS = GeoIP.h GeoIPCity.h GeoIPBitReader.h GeoIPUpdate.h
++@WITH_CITY_FALSE@include_HEADERS = GeoIP.h GeoIPBitReader.h GeoIPUpdate.h
+
+ libGeoIPUpdate_la_SOURCES = GeoIPUpdate.c md5.c
+ libGeoIPBitReader_la_SOURCES = GeoIPBitReader.c