aboutsummaryrefslogtreecommitdiff
path: root/net/Sockets/Makefile
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2010-07-16 16:37:42 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2010-07-16 16:37:42 +0000
commit8704ece7c56f5bc020013f4bb47e5b2e8e4568e6 (patch)
treeb3ddf292621f5d0daf31adfb4ef887c64265b1a4 /net/Sockets/Makefile
parent2658f3012cf102c58285f1fe896b769b10e3e6c9 (diff)
downloadports-8704ece7c56f5bc020013f4bb47e5b2e8e4568e6.tar.gz
ports-8704ece7c56f5bc020013f4bb47e5b2e8e4568e6.zip
Notes
Diffstat (limited to 'net/Sockets/Makefile')
-rw-r--r--net/Sockets/Makefile44
1 files changed, 20 insertions, 24 deletions
diff --git a/net/Sockets/Makefile b/net/Sockets/Makefile
index 5087106797b1..d6b9d8a37093 100644
--- a/net/Sockets/Makefile
+++ b/net/Sockets/Makefile
@@ -1,44 +1,40 @@
# New ports collection makefile for: C++ Sockets
-# Date created: Sat Jan 15 16:17:20 UTC 2005
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+# Date created: Tue Jun 29 16:00:00 UTC 2010
+# Whom: Andrea Venturoli <ml@netfence.it>
#
# $FreeBSD$
#
PORTNAME= Sockets
-PORTVERSION= 2.1.4
-CATEGORIES= net ipv6
-MASTER_SITES= http://www.alhem.net/Sockets/
+PORTVERSION= 2.3.9.2
+CATEGORIES= net
+MASTER_SITES= http://www.alhem.net/Sockets/ \
+ http://www.netfence.it/Sockets/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ml@netfence.it
COMMENT= A C++ wrapper for BSD-style sockets
-LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
+#execinfo is optional and currently not configured (would need to patch source's #ifdef LINUX)
+#LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
+#Not needed without execinfo or xml
+#CFLAGS+= -I${LOCALBASE}/include
+#LDFLAGS+= -L${LOCALBASE}/lib
+
+MAKE_JOBS_SAFE=yes
USE_GMAKE= yes
USE_OPENSSL= yes
-WITH_OPENSSL_BASE= yes
+USE_LDCONFIG= yes
+
+ALL_TARGET= all shared
+INSTALL_TARGET= install_shared
post-patch:
# PREFIX safeness
-# CXX safeness
-# CXXFLAGS safeness
+ @${CP} ${PATCHDIR}/Makefile.Defines.freebsd ${WRKSRC}
@${REINPLACE_CMD} -E \
- -e 's|-O2||' \
+ -e 's|linux-x86-32|freebsd|' \
-e 's|^PREFIX.+$$|PREFIX=${PREFIX}|' \
- -e 's|^INCLUDE.+$$|INCLUDE=-I. -I${OPENSSLINC}|' \
- -e 's|g\+\+|${CXX}|' \
${BUILD_WRKSRC}/${MAKEFILE}
-# fix StdLog.h location
- @${FIND} ${WRKSRC} -type f | \
- ${XARGS} -n 5 -x \
- ${REINPLACE_CMD} -E \
- -e 's|"StdLog.h"|<StdLog.h>|'
-
- @${REINPLACE_CMD} -e 's#pthread#(unsigned long)pthread#g' \
- ${WRKSRC}/Utility.cpp
.include <bsd.port.mk>