aboutsummaryrefslogtreecommitdiff
path: root/net/Sockets/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-16 05:04:44 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-16 05:04:44 +0000
commit758b6a8fe39c2ca45ab9d7e33bf98ac9f5979113 (patch)
tree76084517eebd0d15621db1b4840a05ef58fcb790 /net/Sockets/Makefile
parente7f5b677c78de8fec69cf98f450f817a239403f2 (diff)
downloadports-758b6a8fe39c2ca45ab9d7e33bf98ac9f5979113.tar.gz
ports-758b6a8fe39c2ca45ab9d7e33bf98ac9f5979113.zip
Notes
Diffstat (limited to 'net/Sockets/Makefile')
-rw-r--r--net/Sockets/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/net/Sockets/Makefile b/net/Sockets/Makefile
new file mode 100644
index 000000000000..6fce882d5d58
--- /dev/null
+++ b/net/Sockets/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: C++ Sockets
+# Date created: Sat Jan 15 16:17:20 UTC 2005
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sockets
+PORTVERSION= 1.7.1
+CATEGORIES= net ipv6
+MASTER_SITES= http://www.alhem.net/Sockets/
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= A C++ wrapper for BSD-style sockets
+
+USE_GMAKE= yes
+USE_OPENSSL= yes
+WITH_OPENSSL_BASE= yes
+MAKE_ENV= CXX="${CXX}"
+USE_REINPLACE= yes
+
+post-patch:
+# PREFIX safeness
+# CXX safeness
+# CXXFLAGS safeness
+ @${REINPLACE_CMD} -E \
+ -e 's|-O2||' \
+ -e 's|^PREFIX.+$$|PREFIX=${PREFIX}|' \
+ -e 's|^INCLUDE.+$$|INCLUDE=-I. -I${OPENSSLINC}|' \
+ -e 's|g\+\+|${CXX}|' \
+ ${BUILD_WRKSRC}/${MAKEFILE}
+# fix StdLog.h location
+ @${FIND} ${WRKSRC} -type f | \
+ ${XARGS} -n 5 -x \
+ ${REINPLACE_CMD} -E \
+ -e 's|"StdLog.h"|<StdLog.h>|'
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= FreeBSD prior to 500000 does not support uuid(3) required\
+ for building
+.endif
+
+.include <bsd.port.post.mk>