aboutsummaryrefslogtreecommitdiff
path: root/net/Sockets
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-09-25 06:32:55 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-09-25 06:32:55 +0000
commitc509d7c518f60f50c1fb021cd64122e5ab01e8ae (patch)
tree0b35d99632089beed27225302a2062878c95ca19 /net/Sockets
parent309207fba274545f5473ea2f278eb3fa70a47f9e (diff)
downloadports-c509d7c518f60f50c1fb021cd64122e5ab01e8ae.tar.gz
ports-c509d7c518f60f50c1fb021cd64122e5ab01e8ae.zip
Notes
Diffstat (limited to 'net/Sockets')
-rw-r--r--net/Sockets/Makefile2
-rw-r--r--net/Sockets/distinfo4
-rw-r--r--net/Sockets/files/patch-ListenSocket.h10
-rw-r--r--net/Sockets/files/patch-Makefile9
-rw-r--r--net/Sockets/files/patch-MinderHandler.cpp6
-rw-r--r--net/Sockets/files/patch-Sockets-config.cpp11
-rw-r--r--net/Sockets/pkg-plist6
7 files changed, 24 insertions, 24 deletions
diff --git a/net/Sockets/Makefile b/net/Sockets/Makefile
index 6272dc2ec53c..26ef85b74c2e 100644
--- a/net/Sockets/Makefile
+++ b/net/Sockets/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Sockets
-PORTVERSION= 1.8.1
+PORTVERSION= 1.8.7
CATEGORIES= net ipv6
MASTER_SITES= http://www.alhem.net/Sockets/
diff --git a/net/Sockets/distinfo b/net/Sockets/distinfo
index c6cb7b91d2b1..d1b8c530a582 100644
--- a/net/Sockets/distinfo
+++ b/net/Sockets/distinfo
@@ -1,2 +1,2 @@
-MD5 (Sockets-1.8.1.tar.gz) = 2792d7b81f4fcb2888e6cd6f94bafd0e
-SIZE (Sockets-1.8.1.tar.gz) = 55562
+MD5 (Sockets-1.8.7.tar.gz) = 361cc81cb5eaf5aa77a476de827aee80
+SIZE (Sockets-1.8.7.tar.gz) = 77760
diff --git a/net/Sockets/files/patch-ListenSocket.h b/net/Sockets/files/patch-ListenSocket.h
deleted file mode 100644
index 0c32e99b29b8..000000000000
--- a/net/Sockets/files/patch-ListenSocket.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- ListenSocket.h.orig Sun Apr 3 18:43:45 2005
-+++ ListenSocket.h Sun Apr 3 18:44:30 2005
-@@ -31,6 +31,7 @@
-
- #include "Socket.h"
-
-+#include <StdLog.h>
-
- template <class X>
- class ListenSocket : public Socket
diff --git a/net/Sockets/files/patch-Makefile b/net/Sockets/files/patch-Makefile
index 6b3be9c245d9..b43c5c0e39e6 100644
--- a/net/Sockets/files/patch-Makefile
+++ b/net/Sockets/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Sun Apr 3 18:39:23 2005
-+++ Makefile Sun Apr 3 18:41:20 2005
-@@ -69,12 +69,11 @@
+--- Makefile.orig Sun Sep 25 02:39:49 2005
++++ Makefile Sun Sep 25 02:40:28 2005
+@@ -75,13 +75,11 @@
ranlib $@
install: all
@@ -11,9 +11,10 @@
+ @${BSD_INSTALL_DATA} libSocketsEx.a $(PREFIX)/lib
@mkdir -p $(PREFIX)/include/Sockets
- cp -a *.h $(PREFIX)/include/Sockets
+- @mkdir -p $(PREFIX)/bin
- install Sockets-config $(PREFIX)/bin
+ @${BSD_INSTALL_DATA} *.h $(PREFIX)/include/Sockets
+ @${BSD_INSTALL_PROGRAM} Sockets-config $(PREFIX)/bin
clean:
- rm -f *.o *~ slask *.d $(PROGS) *.a
+ rm -f *.o *~ slask *.d $(PROGS) *.a */*~
diff --git a/net/Sockets/files/patch-MinderHandler.cpp b/net/Sockets/files/patch-MinderHandler.cpp
index cf080fa1c4e7..e0a6732bb40d 100644
--- a/net/Sockets/files/patch-MinderHandler.cpp
+++ b/net/Sockets/files/patch-MinderHandler.cpp
@@ -1,5 +1,5 @@
---- MinderHandler.cpp.orig Sun Apr 3 18:42:07 2005
-+++ MinderHandler.cpp Sun Apr 3 18:43:09 2005
+--- MinderHandler.cpp.orig Sun Sep 25 02:40:57 2005
++++ MinderHandler.cpp Sun Sep 25 02:41:49 2005
@@ -20,6 +20,10 @@
along with this program; if not, write to the Free Software
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
@@ -16,7 +16,7 @@
#ifdef _WIN32
msg += ":Win32";
+#elif defined __FreeBSD__
-+ msg += ":FreeBSD";
++ msg += ":FreeBSD";
#else
msg += ":Linux";
#endif
diff --git a/net/Sockets/files/patch-Sockets-config.cpp b/net/Sockets/files/patch-Sockets-config.cpp
index c53e3270e418..f6362cf7c538 100644
--- a/net/Sockets/files/patch-Sockets-config.cpp
+++ b/net/Sockets/files/patch-Sockets-config.cpp
@@ -1,7 +1,10 @@
---- Sockets-config.cpp.orig Sun Jan 16 02:23:14 2005
-+++ Sockets-config.cpp Sun Jan 16 02:26:07 2005
-@@ -3,6 +3,10 @@
- CFLAGS = -Wall -g -O2 $(INCLUDE) -MD -D_VERSION='"$(VERSION)"'
+--- Sockets-config.cpp.orig Sun Sep 25 02:42:19 2005
++++ Sockets-config.cpp Sun Sep 25 02:44:08 2005
+@@ -1,8 +1,12 @@
+ #include <stdio.h>
+ /*
+-CFLAGS = -Wall -g -O2 $(INCLUDE) -MD -D_VERSION='"$(VERSION)"'
++CFLAGS = -Wall -g $(INCLUDE) -MD -D_VERSION='"$(VERSION)"'
# manual autoconf ....
+#if (defined(__unix__) || defined(unix)) && !defined(USG)
diff --git a/net/Sockets/pkg-plist b/net/Sockets/pkg-plist
index 67a9b9edf78d..166f5d5e2e8b 100644
--- a/net/Sockets/pkg-plist
+++ b/net/Sockets/pkg-plist
@@ -2,15 +2,21 @@ bin/Sockets-config
include/Sockets/Base64.h
include/Sockets/CTcpSocket.h
include/Sockets/CircularBuffer.h
+include/Sockets/File.h
include/Sockets/HTTPSocket.h
include/Sockets/HttpDebugSocket.h
include/Sockets/HttpGetSocket.h
include/Sockets/HttpPostSocket.h
include/Sockets/HttpPutSocket.h
+include/Sockets/HttpdCookies.h
+include/Sockets/HttpdForm.h
+include/Sockets/HttpdSocket.h
include/Sockets/HttpsGetSocket.h
include/Sockets/HttpsSocket.h
include/Sockets/ICrypt.h
+include/Sockets/IFile.h
include/Sockets/ListenSocket.h
+include/Sockets/MemFile.h
include/Sockets/MinderHandler.h
include/Sockets/MinderSocket.h
include/Sockets/MinionSocket.h