aboutsummaryrefslogtreecommitdiff
path: root/net/abills/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-12-10 14:20:10 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-12-10 14:20:10 +0000
commit885e61e9e5e2bccde56a78eb4f564b6fec136c68 (patch)
tree70cdd9bf28bae288bf072a01c57c8cfd4b53b367 /net/abills/Makefile
parent92edbb967e114d9215894e985db8f8880d930d60 (diff)
Add abills 0.23b, billing system for dialup and VPN users.
PR: ports/78014 Submitted by: Michael Lednev <liettneff@bk.ru>
Notes
Notes: svn path=/head/; revision=150795
Diffstat (limited to 'net/abills/Makefile')
-rw-r--r--net/abills/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/net/abills/Makefile b/net/abills/Makefile
new file mode 100644
index 000000000000..11f086e2e26a
--- /dev/null
+++ b/net/abills/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: abills
+# Date created: 2 February 2005
+# Whom: Michael Lednev <liettneff@bk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= abills
+PORTVERSION= 0.23b
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= abills
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= liettneff@bk.ru
+COMMENT= Billing system for dialup and VPN users
+
+RUN_DEPENDS= radiusd:${PORTSDIR}/net/freeradius \
+ ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD4.pm:${PORTSDIR}/security/p5-Digest-MD4 \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ ${SITE_PERL}/${PERL_ARCH}/Crypt/DES.pm:${PORTSDIR}/security/p5-Crypt-DES
+
+USE_REINPLACE= yes
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+.if defined(WITH_GRAPHICS)
+RUN_DEPENDS+= ${SITE_PERL}/RRDp.pm:${PORTSDIR}/net/rrdtool
+.endif
+
+pre-everything::
+ @ ${ECHO} ""
+ @ ${ECHO} " Define WITH_GRAPHICS if you want traffic graphs (experimental)"
+ @ ${ECHO} ""
+
+post-extract:
+ @ ${FIND} ${WRKSRC} -type f -exec ${REINPLACE_CMD} -i '' -e 's,/usr/abills,${PREFIX}/abills,g' {} \;
+
+do-install:
+ @ ${CP} -R ${WRKSRC} ${PREFIX}
+
+post-install:
+ @ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>