aboutsummaryrefslogtreecommitdiff
path: root/net/akonadi-search/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 19:09:05 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 19:09:05 +0000
commit39fa5f95a7f2bf0a028e458c3104f66d433200e6 (patch)
treeb52ff8a578bde97936b79f311d6970fac2593475 /net/akonadi-search/Makefile
parent34e997ccb06a8f151001292998a5c99019fa9d5a (diff)
downloadports-39fa5f95a7f2bf0a028e458c3104f66d433200e6.tar.gz
ports-39fa5f95a7f2bf0a028e458c3104f66d433200e6.zip
Notes
Diffstat (limited to 'net/akonadi-search/Makefile')
-rw-r--r--net/akonadi-search/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/net/akonadi-search/Makefile b/net/akonadi-search/Makefile
new file mode 100644
index 000000000000..20d7291e142a
--- /dev/null
+++ b/net/akonadi-search/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= akonadi-search
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= net kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Libraries and daemons to implement searching in Akonadi
+
+LICENSE= LGPL21
+
+LIB_DEPENDS= libxapian.so:databases/xapian-core
+
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USE_KDE= auth codecs completion config configwidgets coreaddons \
+ crash ecm i18n itemmodels kcmutils package plasma-framework \
+ runner service widgetsaddons
+# pim components
+USE_KDE+= akonadi akonadimime calendarcore contacts mime
+USE_QT5= core dbus gui widgets xml \
+ buildtools_build qmake_build
+USE_LDCONFIG= yes
+
+DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+
+
+.include <bsd.port.mk>