aboutsummaryrefslogtreecommitdiff
path: root/net/anet/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-03-29 01:22:55 +0000
committerJohn Marino <marino@FreeBSD.org>2014-03-29 01:22:55 +0000
commit39fd6beb0996ea40b2d129f0dd5f034efa50fede (patch)
tree4d925a6df76663ba9111cb750432f8b23e465679 /net/anet/Makefile
parent8b1c9714975c2175c8c2da424bfafb3143af3a12 (diff)
downloadports-39fd6beb0996ea40b2d129f0dd5f034efa50fede.tar.gz
ports-39fd6beb0996ea40b2d129f0dd5f034efa50fede.zip
Notes
Diffstat (limited to 'net/anet/Makefile')
-rw-r--r--net/anet/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/net/anet/Makefile b/net/anet/Makefile
index 6e6e64736add..b39cc1416c97 100644
--- a/net/anet/Makefile
+++ b/net/anet/Makefile
@@ -3,7 +3,7 @@
PORTNAME= anet
PORTVERSION= 0.2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.codelabs.ch/download/
DISTNAME= libanet-${PORTVERSION}
@@ -20,7 +20,7 @@ ALL_TARGET= build_lib
MAKE_ARGS+= NUM_CPUS=${MAKE_JOBS_NUMBER} \
LIBRARY_KIND=static
-OPTIONS_DEFINE= TEST #DOCS
+OPTIONS_DEFINE= TEST DOCS
TEST_DESC= Run unit test suite before installation
.include <bsd.port.options.mk>
@@ -34,12 +34,12 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/gnat/ahven.gpr:${PORTSDIR}/devel/ahven
ALL_TARGET+= tests
.endif
-# DOCS disabled -- asciidoc generation missing source highlights
-#.if ${PORT_OPTIONS:MDOCS}
-#BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc
-#ALL_TARGET+= doc
-#USES+= gmake
-#.endif
+.if ${PORT_OPTIONS:MDOCS}
+BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc \
+ source-highlight:${PORTSDIR}/textproc/source-highlight
+ALL_TARGET+= doc
+USES+= gmake
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|"lo"|"lo0"|g' \
@@ -64,5 +64,9 @@ do-install:
${STAGEDIR}${PREFIX}/include/anet
${INSTALL_DATA} ${WRKSRC}/lib/static/* ${STAGEDIR}${PREFIX}/lib/anet
${INSTALL_DATA} ${WRKSRC}/gnat/anet.gpr ${STAGEDIR}${PREFIX}/lib/gnat
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR})
+.endif
.include <bsd.port.mk>