aboutsummaryrefslogtreecommitdiff
path: root/net/anet
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-07-12 13:58:57 +0000
committerJohn Marino <marino@FreeBSD.org>2014-07-12 13:58:57 +0000
commit38d1e1f3a31bb8a76b65119e5a071dd457fee724 (patch)
tree5edb357693e2be3a5029abaa139921b2c9cb56e6 /net/anet
parentf6fb4c99b2801c0c3fb4f1e8dee1d911d945a818 (diff)
downloadports-38d1e1f3a31bb8a76b65119e5a071dd457fee724.tar.gz
ports-38d1e1f3a31bb8a76b65119e5a071dd457fee724.zip
Notes
Diffstat (limited to 'net/anet')
-rw-r--r--net/anet/Makefile7
-rw-r--r--net/anet/pkg-plist10
2 files changed, 14 insertions, 3 deletions
diff --git a/net/anet/Makefile b/net/anet/Makefile
index 82ffe8d3f859..89c139d78e87 100644
--- a/net/anet/Makefile
+++ b/net/anet/Makefile
@@ -3,6 +3,7 @@
PORTNAME= anet
PORTVERSION= 0.3.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.codelabs.ch/download/
DISTNAME= libanet-${PORTVERSION}
@@ -55,9 +56,11 @@ do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/gnat \
${STAGEDIR}${PREFIX}/lib/anet \
${STAGEDIR}${PREFIX}/include/anet
- ${INSTALL_DATA} ${WRKSRC}/src/*.ad[bs] \
+ ${INSTALL_DATA} ${WRKSRC}/src/*.ad[bs] ${WRKSRC}/src/bsd/*.ad[bs] \
${STAGEDIR}${PREFIX}/include/anet
- ${INSTALL_DATA} ${WRKSRC}/lib/static/* ${STAGEDIR}${PREFIX}/lib/anet
+ ${INSTALL_DATA} ${WRKSRC}/lib/static/*.ali \
+ ${STAGEDIR}${PREFIX}/lib/anet
+ ${INSTALL_DATA} ${WRKSRC}/lib/static/*.a ${STAGEDIR}${PREFIX}/lib
${INSTALL_DATA} ${WRKSRC}/gnat/anet.gpr ${STAGEDIR}${PREFIX}/lib/gnat
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/net/anet/pkg-plist b/net/anet/pkg-plist
index 341318f4a6e2..12ead7f185a6 100644
--- a/net/anet/pkg-plist
+++ b/net/anet/pkg-plist
@@ -7,18 +7,26 @@ include/anet/anet-net_ifaces.adb
include/anet/anet-net_ifaces.ads
include/anet/anet-os.adb
include/anet/anet-os.ads
+include/anet/anet-os_constants.ads
include/anet/anet-receivers-datagram.adb
include/anet/anet-receivers-datagram.ads
include/anet/anet-receivers-stream.adb
include/anet/anet-receivers-stream.ads
include/anet/anet-receivers.adb
include/anet/anet-receivers.ads
+include/anet/anet-socket_families.ads
include/anet/anet-sockets-filters.adb
include/anet/anet-sockets-filters.ads
+include/anet/anet-sockets-inet-iface.adb
include/anet/anet-sockets-inet-iface.ads
include/anet/anet-sockets-inet.adb
include/anet/anet-sockets-inet.ads
+include/anet/anet-sockets-thin-inet.adb
+include/anet/anet-sockets-thin-inet.ads
+include/anet/anet-sockets-thin-netdev-requests.ads
include/anet/anet-sockets-thin-netdev.ads
+include/anet/anet-sockets-thin-sockaddr.ads
+include/anet/anet-sockets-thin-unix.ads
include/anet/anet-sockets-thin.ads
include/anet/anet-sockets-unix.adb
include/anet/anet-sockets-unix.ads
@@ -60,8 +68,8 @@ lib/anet/anet-types.ali
lib/anet/anet-udp.ali
lib/anet/anet-util.ali
lib/anet/anet.ali
-lib/anet/libanet.a
lib/gnat/anet.gpr
+lib/libanet.a
%%PORTDOCS%%%%DOCSDIR%%/html/asciidoc.css
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
%%PORTDOCS%%@dirrmtry %%DOCSDIR%%/html