aboutsummaryrefslogtreecommitdiff
path: root/net/anet
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-03-29 01:22:55 +0000
committerJohn Marino <marino@FreeBSD.org>2014-03-29 01:22:55 +0000
commit39fd6beb0996ea40b2d129f0dd5f034efa50fede (patch)
tree4d925a6df76663ba9111cb750432f8b23e465679 /net/anet
parent8b1c9714975c2175c8c2da424bfafb3143af3a12 (diff)
downloadports-39fd6beb0996ea40b2d129f0dd5f034efa50fede.tar.gz
ports-39fd6beb0996ea40b2d129f0dd5f034efa50fede.zip
Notes
Diffstat (limited to 'net/anet')
-rw-r--r--net/anet/Makefile20
-rw-r--r--net/anet/files/patch-src_anet-sockets-inet.adb19
-rw-r--r--net/anet/files/patch-src_anet-sockets.ads2
-rw-r--r--net/anet/pkg-plist4
4 files changed, 27 insertions, 18 deletions
diff --git a/net/anet/Makefile b/net/anet/Makefile
index 6e6e64736add..b39cc1416c97 100644
--- a/net/anet/Makefile
+++ b/net/anet/Makefile
@@ -3,7 +3,7 @@
PORTNAME= anet
PORTVERSION= 0.2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.codelabs.ch/download/
DISTNAME= libanet-${PORTVERSION}
@@ -20,7 +20,7 @@ ALL_TARGET= build_lib
MAKE_ARGS+= NUM_CPUS=${MAKE_JOBS_NUMBER} \
LIBRARY_KIND=static
-OPTIONS_DEFINE= TEST #DOCS
+OPTIONS_DEFINE= TEST DOCS
TEST_DESC= Run unit test suite before installation
.include <bsd.port.options.mk>
@@ -34,12 +34,12 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/gnat/ahven.gpr:${PORTSDIR}/devel/ahven
ALL_TARGET+= tests
.endif
-# DOCS disabled -- asciidoc generation missing source highlights
-#.if ${PORT_OPTIONS:MDOCS}
-#BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc
-#ALL_TARGET+= doc
-#USES+= gmake
-#.endif
+.if ${PORT_OPTIONS:MDOCS}
+BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc \
+ source-highlight:${PORTSDIR}/textproc/source-highlight
+ALL_TARGET+= doc
+USES+= gmake
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|"lo"|"lo0"|g' \
@@ -64,5 +64,9 @@ do-install:
${STAGEDIR}${PREFIX}/include/anet
${INSTALL_DATA} ${WRKSRC}/lib/static/* ${STAGEDIR}${PREFIX}/lib/anet
${INSTALL_DATA} ${WRKSRC}/gnat/anet.gpr ${STAGEDIR}${PREFIX}/lib/gnat
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR})
+.endif
.include <bsd.port.mk>
diff --git a/net/anet/files/patch-src_anet-sockets-inet.adb b/net/anet/files/patch-src_anet-sockets-inet.adb
index 7c39d9e73e03..db5bc60a0fe7 100644
--- a/net/anet/files/patch-src_anet-sockets-inet.adb
+++ b/net/anet/files/patch-src_anet-sockets-inet.adb
@@ -127,7 +127,7 @@
Sin_Family => Constants.Sys.AF_INET6,
Sin_Port => C.unsigned_short
(Byte_Swapping.Host_To_Network (Input => Port)),
-@@ -253,6 +261,51 @@ package body Anet.Sockets.Inet is
+@@ -253,6 +261,52 @@ package body Anet.Sockets.Inet is
-------------------------------------------------------------------------
@@ -157,7 +157,8 @@
+ Interfaces.C.Strings.Value (frame.all.ifa_name);
+ begin
+ if testname = String (Iface_Name) and then
-+ frame.all.ifa_addr.all.Sin_Family = Constants.Sys.AF_INET6 then
++ frame.all.ifa_addr.all.Sin_Family = Constants.Sys.AF_INET6
++ then
+ found := True;
+ IPv6_Address := frame.all.ifa_addr.all.Sin6_Addr;
+ end if;
@@ -179,7 +180,7 @@
procedure Init (Socket : in out UDPv4_Socket_Type)
is
begin
-@@ -301,15 +354,15 @@ package body Anet.Sockets.Inet is
+@@ -301,15 +355,15 @@ package body Anet.Sockets.Inet is
use type C.unsigned_short;
Mreq : Thin.IPv4_Mreq_Type;
@@ -198,7 +199,7 @@
Res := Thin.C_Setsockopt
(S => Socket.Sock_FD,
-@@ -335,10 +388,14 @@ package body Anet.Sockets.Inet is
+@@ -335,10 +389,14 @@ package body Anet.Sockets.Inet is
Mreq6 : Thin.IPv6_Mreq_Type;
Iface_Idx : Natural := 0;
@@ -214,7 +215,7 @@
end if;
Mreq6.IPv6mr_Multiaddr := Group;
-@@ -349,7 +406,7 @@ package body Anet.Sockets.Inet is
+@@ -349,7 +407,7 @@ package body Anet.Sockets.Inet is
Level => Constants.IPPROTO_IPV6,
Optname => Constants.IPV6_ADD_MEMBERSHIP,
Optval => Mreq6'Address,
@@ -223,7 +224,7 @@
if Res = C_Failure then
raise Socket_Error with "Unable to join multicast group "
-@@ -440,7 +497,8 @@ package body Anet.Sockets.Inet is
+@@ -440,7 +498,8 @@ package body Anet.Sockets.Inet is
Dst_Addr : IPv4_Addr_Type;
Dst_Port : Port_Type)
is
@@ -233,7 +234,7 @@
Dst : constant Thin.Sockaddr_In_Type := Create_Inet4
(Address => Dst_Addr,
Port => Dst_Port);
-@@ -450,7 +508,7 @@ package body Anet.Sockets.Inet is
+@@ -450,7 +509,7 @@ package body Anet.Sockets.Inet is
Len => Item'Length,
Flags => 0,
To => Dst'Address,
@@ -242,7 +243,7 @@
if Res = C_Failure then
raise Socket_Error with "Error sending data to "
-@@ -473,7 +531,8 @@ package body Anet.Sockets.Inet is
+@@ -473,7 +532,8 @@ package body Anet.Sockets.Inet is
Dst_Addr : IPv6_Addr_Type;
Dst_Port : Port_Type)
is
@@ -252,7 +253,7 @@
Dst : constant Thin.Sockaddr_In_Type := Create_Inet6
(Address => Dst_Addr,
Port => Dst_Port);
-@@ -483,7 +542,7 @@ package body Anet.Sockets.Inet is
+@@ -483,7 +543,7 @@ package body Anet.Sockets.Inet is
Len => Item'Length,
Flags => 0,
To => Dst'Address,
diff --git a/net/anet/files/patch-src_anet-sockets.ads b/net/anet/files/patch-src_anet-sockets.ads
index e041ae1b546e..34159bf87335 100644
--- a/net/anet/files/patch-src_anet-sockets.ads
+++ b/net/anet/files/patch-src_anet-sockets.ads
@@ -6,7 +6,7 @@
+ procedure Set_Multicast_Interface
+ (Socket : Socket_Type;
-+ IPAddr : IPv4_Addr_type);
++ IPAddr : IPv4_Addr_Type);
+ -- Set multicast interface socket option for IPv4
+
+ procedure Set_Multicast_Interface
diff --git a/net/anet/pkg-plist b/net/anet/pkg-plist
index 2b3dfeb5fcb0..2fe5842425c3 100644
--- a/net/anet/pkg-plist
+++ b/net/anet/pkg-plist
@@ -58,6 +58,10 @@ lib/anet/anet-util.ali
lib/anet/anet.ali
lib/anet/libanet.a
lib/gnat/anet.gpr
+%%PORTDOCS%%%%DOCSDIR%%/html/asciidoc.css
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%/html
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
@dirrmtry lib/gnat
@dirrm lib/anet
@dirrm include/anet