aboutsummaryrefslogtreecommitdiff
path: root/net/apache-soap/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-29 12:14:57 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-29 12:14:57 +0000
commitf1ae81b350721774238e4b9fc3af94483889a697 (patch)
tree979d1eb919060282186f598d56eb61405a0dc0bc /net/apache-soap/Makefile
parentd2aebd09b3baa0684e815d73bed08c7476835fc5 (diff)
Notes
Diffstat (limited to 'net/apache-soap/Makefile')
-rw-r--r--net/apache-soap/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/net/apache-soap/Makefile b/net/apache-soap/Makefile
new file mode 100644
index 000000000000..cfe293d550af
--- /dev/null
+++ b/net/apache-soap/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: Apache SOAP
+# Date created: Mon Nov 18 11:21:13 EST 2002
+# Whom: Brian Skrab <brian@quynh-and-brian.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= apache-soap
+PORTVERSION= 2.3.1
+CATEGORIES= net java devel
+MASTER_SITES= http://apache.inspire.net.nz/ws/soap/version-2.3.1/ \
+ http://cottage.quynh-and-brian.org/freebsd/ports/distfiles/
+DISTNAME= soap-bin-${PORTVERSION}
+
+MAINTAINER= brian@quynh-and-brian.org
+COMMENT= The Apache SOAP implementation in Java
+
+RUN_DEPENDS= ${LOCALBASE}/share/java/classes/mail.jar:${PORTSDIR}/java/javamail
+
+USE_JAVA= 1.2+
+
+WRKSRC= ${WRKDIR}/soap-2_3_1
+NO_BUILD= yes
+TARGET_DIR= ${PREFIX}/share/java/${PKGNAME}
+PLIST_SUB+= T=${TARGET_DIR:S/^${PREFIX}\///}
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/java/classes
+ ${MKDIR} ${TARGET_DIR}
+ ${CP} -R ${WRKSRC}/* ${TARGET_DIR}
+ ${LN} -sf ${TARGET_DIR}/lib/soap.jar ${PREFIX}/share/java/classes/soap.jar
+ ${LN} -sf ${TARGET_DIR}/docs ${PREFIX}/share/doc/${PORTNAME}
+
+.include <bsd.port.post.mk>