aboutsummaryrefslogtreecommitdiff
path: root/net/arping/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-08 12:09:49 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-08 12:09:49 +0000
commit311c97add12ee2ee94dab4acbb9dc5062040d772 (patch)
treeb04b0cdb0a1c0f66c7337735b89074c1b49c560c /net/arping/Makefile
parent39df19aecfd1b223878ba6acc9842aa5e6427442 (diff)
Notes
Diffstat (limited to 'net/arping/Makefile')
-rw-r--r--net/arping/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/net/arping/Makefile b/net/arping/Makefile
index 2ecc8fa80721..6b8115a85e76 100644
--- a/net/arping/Makefile
+++ b/net/arping/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= arping
-PORTVERSION= 1.06
+PORTVERSION= 1.07
CATEGORIES= net
MASTER_SITES= ftp://ftp.habets.pp.se/pub/synscan/ \
ftp://ftp.cerias.purdue.edu/pub/tools/unix/netutils/arping/
@@ -16,9 +16,19 @@ COMMENT= ARP level "ping" utility
BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
-ALL_TARGET= freebsd
+LDFLAGS+= -lpcap
+
MAN8= arping.8
+do-build:
+ cd ${WRKSRC} && \
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib \
+ -DUSE_NETIF=1 -DFREEBSD=1 -c `libnet-config --defines` \
+ `libnet-config --cflags` ${PORTNAME}.c && \
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib \
+ -DUSE_NETIF=1 -DFREEBSD=1 -o ${PORTNAME} ${PORTNAME}.o \
+ `libnet-config --libs` ${LDFLAGS}
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/arping ${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/arping.8 ${PREFIX}/man/man8