aboutsummaryrefslogtreecommitdiff
path: root/net/arping
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-04-17 03:32:46 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-04-17 03:32:46 +0000
commite7d3cf5fc789beee3af8752e0fda6929d5bc8587 (patch)
tree143908faecd6281c6c5ec373862237823d83b621 /net/arping
parent1faa4bae458df77a1ed5be8e626bdb5297cdc4fc (diff)
downloadports-e7d3cf5fc789beee3af8752e0fda6929d5bc8587.tar.gz
ports-e7d3cf5fc789beee3af8752e0fda6929d5bc8587.zip
Notes
Diffstat (limited to 'net/arping')
-rw-r--r--net/arping/Makefile12
-rw-r--r--net/arping/files/patch-arping.c20
-rw-r--r--net/arping/files/patch-freebsd.h11
3 files changed, 6 insertions, 37 deletions
diff --git a/net/arping/Makefile b/net/arping/Makefile
index 6d252be275c8..524f57fccbb6 100644
--- a/net/arping/Makefile
+++ b/net/arping/Makefile
@@ -7,29 +7,29 @@
PORTNAME= arping
PORTVERSION= 2.05
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ftp://ftp.habets.pp.se/pub/synscan/
MAINTAINER= gavin.atkinson@ury.york.ac.uk
COMMENT= ARP level "ping" utility
-BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
LDFLAGS+= -lpcap
MAN8= arping.8
PLIST_FILES= sbin/arping
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
do-build:
cd ${WRKSRC} && \
${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib \
- -DUSE_NETIF=1 -DFREEBSD=1 -c `${LIBNET_CONFIG} --defines` \
- `${LIBNET_CONFIG} --cflags` ${PORTNAME}.c && \
+ -c `${LIBNET_CONFIG} --defines` \
+ `${LIBNET_CONFIG} --cflags` ${PORTNAME}-2/${PORTNAME}.c && \
${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib \
- -DUSE_NETIF=1 -DFREEBSD=1 -o ${PORTNAME} ${PORTNAME}.o \
+ -o ${PORTNAME} ${PORTNAME}.o \
`${LIBNET_CONFIG} --libs` ${LDFLAGS}
do-install:
diff --git a/net/arping/files/patch-arping.c b/net/arping/files/patch-arping.c
deleted file mode 100644
index 2098e8fef641..000000000000
--- a/net/arping/files/patch-arping.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- arping.c.orig Mon Aug 8 07:21:57 2005
-+++ arping.c Mon Aug 8 07:22:23 2005
-@@ -258,7 +258,7 @@
- struct ethhdr *eth;
- struct arphdr *harp;
- struct iphdr *hip;
-- struct icmphdr *hicmp;
-+ struct icmphdr_ *hicmp;
- unsigned int c;
- unsigned char *cp;
- struct timeval recvtime;
-@@ -276,7 +276,7 @@
- // ping mac
- hip = (struct iphdr*)((char*)eth
- + sizeof(struct libnet_ethernet_hdr));
-- hicmp = (struct icmphdr*)((char*)hip + sizeof(struct iphdr));
-+ hicmp = (struct icmphdr_*)((char*)hip + sizeof(struct iphdr));
- if ((htons(hicmp->type) == ICMP_ECHOREPLY)
- && ((!memcmp(eth->h_source, eth_target, ETH_ALEN)
- || !memcmp(eth_target, eth_xmas, ETH_ALEN)))
diff --git a/net/arping/files/patch-freebsd.h b/net/arping/files/patch-freebsd.h
deleted file mode 100644
index ea55af8b4905..000000000000
--- a/net/arping/files/patch-freebsd.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- freebsd.h.orig Mon Aug 8 07:22:04 2005
-+++ freebsd.h Mon Aug 8 07:22:35 2005
-@@ -11,7 +11,7 @@
- __u16 h_proto;/* packet type ID field*/
- };
-
--struct icmphdr {
-+struct icmphdr_ {
- __u8 type;
- __u8 code;
- __u16 checksum;