aboutsummaryrefslogtreecommitdiff
path: root/net/arprelease
diff options
context:
space:
mode:
authorNeil Blakey-Milner <nbm@FreeBSD.org>2001-08-02 15:02:31 +0000
committerNeil Blakey-Milner <nbm@FreeBSD.org>2001-08-02 15:02:31 +0000
commit613aec541b515f716552e1f7d31d0ad12c868e92 (patch)
treeb93f92683b7513999adeb724c4f1580d86a98c27 /net/arprelease
parent4ece3e0cb07603e25a4a5a4f7e55238f22e9c89d (diff)
downloadports-613aec541b515f716552e1f7d31d0ad12c868e92.tar.gz
ports-613aec541b515f716552e1f7d31d0ad12c868e92.zip
Notes
Diffstat (limited to 'net/arprelease')
-rw-r--r--net/arprelease/Makefile29
-rw-r--r--net/arprelease/distinfo1
-rw-r--r--net/arprelease/pkg-comment1
-rw-r--r--net/arprelease/pkg-descr3
-rw-r--r--net/arprelease/pkg-plist1
5 files changed, 35 insertions, 0 deletions
diff --git a/net/arprelease/Makefile b/net/arprelease/Makefile
new file mode 100644
index 000000000000..53a8d2be6303
--- /dev/null
+++ b/net/arprelease/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: arprelease
+# Date created: 02 Aug 2001
+# Whom: nbm
+#
+# $FreeBSD$
+#
+
+PORTNAME= arprelease
+PORTVERSION= 1.0
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= arprelease
+
+MAINTAINER= nbm@FreeBSD.org
+
+BUILD_DEPENDS= libnet-config:${PORTSDIR}/net/libnet
+
+LIBNET_CONFIG= libnet-config
+
+do-build:
+ (cd ${WRKSRC} && \
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib \
+ -o arprelease arprelease.c \
+ `${LIBNET_CONFIG} --defines` `${LIBNET_CONFIG} --libs`)
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/arprelease ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/arprelease/distinfo b/net/arprelease/distinfo
new file mode 100644
index 000000000000..3f9f392216b3
--- /dev/null
+++ b/net/arprelease/distinfo
@@ -0,0 +1 @@
+MD5 (arprelease-1.0.tar.gz) = e9156537a8deb2a481333f7f7c31707f
diff --git a/net/arprelease/pkg-comment b/net/arprelease/pkg-comment
new file mode 100644
index 000000000000..c699b4db3812
--- /dev/null
+++ b/net/arprelease/pkg-comment
@@ -0,0 +1 @@
+Libnet tool to flush arp cache entries from devices (eg. routers)
diff --git a/net/arprelease/pkg-descr b/net/arprelease/pkg-descr
new file mode 100644
index 000000000000..9925d1b399d3
--- /dev/null
+++ b/net/arprelease/pkg-descr
@@ -0,0 +1,3 @@
+This program sends out a custom ARP REQUEST packet with the hardware and
+protocol address information of the sending host to flush the arp cache
+for a given IP on Cisco routers.
diff --git a/net/arprelease/pkg-plist b/net/arprelease/pkg-plist
new file mode 100644
index 000000000000..662ecb7565e9
--- /dev/null
+++ b/net/arprelease/pkg-plist
@@ -0,0 +1 @@
+bin/arprelease