aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk-addons
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2007-06-07 02:17:26 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2007-06-07 02:17:26 +0000
commitde5a1e12383b4e689bee0c59c0c9689caafcb112 (patch)
tree626bf0a77e202a13fccdcc8c2ba6385df609d50e /net/asterisk-addons
parentc9bae7fba177c398841aaad946f99993b4ec0ca1 (diff)
downloadports-de5a1e12383b4e689bee0c59c0c9689caafcb112.tar.gz
ports-de5a1e12383b4e689bee0c59c0c9689caafcb112.zip
Notes
Diffstat (limited to 'net/asterisk-addons')
-rw-r--r--net/asterisk-addons/Makefile37
-rw-r--r--net/asterisk-addons/distinfo6
-rw-r--r--net/asterisk-addons/files/patch-Makefile30
-rw-r--r--net/asterisk-addons/files/patch-asterisk-ooh323c-Makefile.in20
-rw-r--r--net/asterisk-addons/files/patch-asterisk-ooh323c-configure22
-rw-r--r--net/asterisk-addons/files/patch-format_mp3-Makefile8
-rw-r--r--net/asterisk-addons/pkg-descr4
-rw-r--r--net/asterisk-addons/pkg-plist11
8 files changed, 89 insertions, 49 deletions
diff --git a/net/asterisk-addons/Makefile b/net/asterisk-addons/Makefile
index 704a0c976fbd..83881fcc2867 100644
--- a/net/asterisk-addons/Makefile
+++ b/net/asterisk-addons/Makefile
@@ -6,34 +6,39 @@
#
PORTNAME= asterisk-addons
-PORTVERSION= 1.2.3
-PORTREVISION= 1
+PORTVERSION= 1.4.1
CATEGORIES= net
-MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
- http://ftp.digium.com/pub/asterisk/old-releases/ \
- ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
- ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
+MASTER_SITES= http://ftp.digium.com/pub/asterisk/releases/
MAINTAINER= fgast@only640k.org
-COMMENT= Additional modules for the Asterisk Open Source PBX
+COMMENT= GPL modules for the Asterisk Open Source PBX
BUILD_DEPENDS= asterisk:${PORTSDIR}/net/asterisk
RUN_DEPENDS= asterisk:${PORTSDIR}/net/asterisk
+OPTIONS= SAMPLE_CONFIG "Install sample configuration files" off
+
ONLY_FOR_ARCHS= i386
+USE_AUTOTOOLS= libtool:15
USE_MYSQL= yes
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
-CONF_SAMPLES= cdr_mysql.conf.sample res_mysql.conf.sample
-ASTETCDIR= ${PREFIX}/etc/asterisk
+.if ${OSVERSION} >= 700000
+BROKEN= Does not build on 7-CURRENT
+.endif
-post-patch:
- @${REINPLACE_CMD} 's,^CFLAGS+=-I../asterisk,CFLAGS+=-I${LOCALBASE}/include,' ${WRKSRC}/Makefile
+.if defined(WITH_SAMPLE_CONFIG)
+PLIST_SUB+= SAMPLE_CONFIG=""
+.else
+PLIST_SUB+= SAMPLE_CONFIG="@comment "
+.endif
post-install:
- ${MKDIR} ${ASTETCDIR}
-.for f in ${CONF_SAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/configs/$f ${ASTETCDIR}
-.endfor
+.if defined(WITH_SAMPLE_CONFIG)
+ @cd ${WRKSRC} && ${GMAKE} samples
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/asterisk-addons/distinfo b/net/asterisk-addons/distinfo
index 1553a3f59f86..5245c573e200 100644
--- a/net/asterisk-addons/distinfo
+++ b/net/asterisk-addons/distinfo
@@ -1,3 +1,3 @@
-MD5 (asterisk-addons-1.2.3.tar.gz) = 2089e119985508b5a4a1916e2242184d
-SHA256 (asterisk-addons-1.2.3.tar.gz) = 4eeb3f9f5ceb64b0742e8118ca7ba842330d28e7fd505a828730db0ee2997467
-SIZE (asterisk-addons-1.2.3.tar.gz) = 750973
+MD5 (asterisk-addons-1.4.1.tar.gz) = e776b23eac9552e3543fba9202dd7c7d
+SHA256 (asterisk-addons-1.4.1.tar.gz) = b67d9ebd54c193177323eb27ceb9651de02f1e4d3f22845ec800b7b5d425942b
+SIZE (asterisk-addons-1.4.1.tar.gz) = 999765
diff --git a/net/asterisk-addons/files/patch-Makefile b/net/asterisk-addons/files/patch-Makefile
index cfd4ba9c1c67..0806e54390f4 100644
--- a/net/asterisk-addons/files/patch-Makefile
+++ b/net/asterisk-addons/files/patch-Makefile
@@ -1,23 +1,11 @@
---- Makefile.orig Fri Dec 2 05:14:28 2005
-+++ Makefile Tue Mar 28 00:15:47 2006
-@@ -20,8 +20,8 @@
- CFLAGS+=-D_GNU_SOURCE
+--- Makefile.orig Mon Apr 2 22:05:57 2007
++++ Makefile Mon Apr 2 22:07:31 2007
+@@ -16,7 +16,7 @@
+ # Overwite config files on "make samples"
+ OVERWRITE:=y
- INSTALL=install
--INSTALL_PREFIX=
--ASTLIBDIR=$(INSTALL_PREFIX)/usr/lib/asterisk
-+INSTALL_PREFIX=$(PREFIX)
-+ASTLIBDIR=$(INSTALL_PREFIX)/lib/asterisk
- MODULES_DIR=$(ASTLIBDIR)/modules
+-CFLAGS+=-fPIC
++CFLAGS+=-fPIC -I/usr/local/include
- #
-@@ -56,7 +56,8 @@
- $(MAKE) -C format_mp3 all
-
- install: all
-- for x in $(MODS); do $(INSTALL) -m 755 $$x $(DESTDIR)$(MODULES_DIR) ; done
-+ mkdir -p $(DESTDIR)$(MODULES_DIR)
-+ for x in $(MODS); do $(BSD_INSTALL_PROGRAM) $$x $(DESTDIR)$(MODULES_DIR) ; done
-
- clean:
- rm -f *.so *.o .depend
+ # If the file .asteriskaddons.makeopts is present in your home directory, you can
+ # include all of your favorite menuselect options so that every time you download
diff --git a/net/asterisk-addons/files/patch-asterisk-ooh323c-Makefile.in b/net/asterisk-addons/files/patch-asterisk-ooh323c-Makefile.in
new file mode 100644
index 000000000000..1605c90ac306
--- /dev/null
+++ b/net/asterisk-addons/files/patch-asterisk-ooh323c-Makefile.in
@@ -0,0 +1,20 @@
+--- asterisk-ooh323c/Makefile.in.orig Wed May 17 12:50:02 2006
++++ asterisk-ooh323c/Makefile.in Mon Apr 2 22:38:02 2007
+@@ -93,7 +93,7 @@
+ libchan_h323_la_LDFLAGS = -L$(top_builddir)/ooh323c/src -version-info 1:1:0
+ libchan_h323_la_SOURCES = src/chan_h323.h src/chan_h323.c src/ooh323cDriver.h src/ooh323cDriver.c ooh323c/src/ooCmdChannel.h ooh323c/src/ooCmdChannel.c ooh323c/src/ooLogChan.h ooh323c/src/ooLogChan.c ooh323c/src/ooUtils.c ooh323c/src/ooUtils.h ooh323c/src/ooGkClient.h ooh323c/src/ooGkClient.c ooh323c/src/context.c ooh323c/src/ooCommon.h ooh323c/src/ooDateTime.h ooh323c/src/ooDateTime.c ooh323c/src/decode.c ooh323c/src/dlist.c ooh323c/src/encode.c ooh323c/src/errmgmt.c ooh323c/src/memheap.c ooh323c/src/memheap.h ooh323c/src/ooasn1.h ooh323c/src/ootrace.h ooh323c/src/ootrace.c ooh323c/src/oochannels.c ooh323c/src/oochannels.h ooh323c/src/ooh245.c ooh323c/src/ooh245.h ooh323c/src/oohdr.h ooh323c/src/ooper.h ooh323c/src/ooports.c ooh323c/src/ooports.h ooh323c/src/ooq931.c ooh323c/src/ooq931.h ooh323c/src/ooCapability.c ooh323c/src/ooCapability.h ooh323c/src/ooSocket.c ooh323c/src/ooSocket.h ooh323c/src/ootypes.h ooh323c/src/perutil.c ooh323c/src/eventHandler.c ooh323c/src/eventHandler.h ooh323c/src/ooCalls.c ooh323c/src/ooCalls.h ooh323c/src/ooStackCmds.c ooh323c/src/ooStackCmds.h ooh323c/src/ooh323.c ooh323c/src/ooh323.h ooh323c/src/ooh323ep.c ooh323c/src/ooh323ep.h ooh323c/src/printHandler.c ooh323c/src/printHandler.h ooh323c/src/rtctype.c ooh323c/src/rtctype.h ooh323c/src/ooTimer.c ooh323c/src/ooTimer.h ooh323c/src/h323/H235-SECURITY-MESSAGESDec.c ooh323c/src/h323/H235-SECURITY-MESSAGESEnc.c ooh323c/src/h323/H235-SECURITY-MESSAGES.h ooh323c/src/h323/H323-MESSAGES.c ooh323c/src/h323/H323-MESSAGESDec.c ooh323c/src/h323/H323-MESSAGESEnc.c ooh323c/src/h323/H323-MESSAGES.h ooh323c/src/h323/MULTIMEDIA-SYSTEM-CONTROL.c ooh323c/src/h323/MULTIMEDIA-SYSTEM-CONTROLDec.c ooh323c/src/h323/MULTIMEDIA-SYSTEM-CONTROLEnc.c ooh323c/src/h323/MULTIMEDIA-SYSTEM-CONTROL.h
+
+-INCLUDES = -I$(top_builddir)/ooh323c/src -I$(top_builddir)/ooh323c/src/h323
++INCLUDES = -I$(top_builddir)/ooh323c/src -I$(top_builddir)/ooh323c/src/h323 -I$(includedir)
+
+ libchan_h323_la_LIBADD = -lpthread
+
+@@ -1239,7 +1239,7 @@
+ $(MAKE) "CFLAGS = -g -DGNU -D_GNU_SOURCE -D_REENTRANT $(DEBUG_THREADS)" all
+
+ install:
+- cp .libs/libchan_h323.so.1.0.1 $(DESTDIR)/usr/lib/asterisk/modules/chan_ooh323.so
++ cp .libs/libchan_h323.so /usr/local/lib/asterisk/modules/chan_ooh323.so
+
+ sample:
+ cp h323.conf.sample $(DESTDIR)/etc/asterisk/ooh323.conf
diff --git a/net/asterisk-addons/files/patch-asterisk-ooh323c-configure b/net/asterisk-addons/files/patch-asterisk-ooh323c-configure
new file mode 100644
index 000000000000..c78dc8fb8854
--- /dev/null
+++ b/net/asterisk-addons/files/patch-asterisk-ooh323c-configure
@@ -0,0 +1,22 @@
+--- asterisk-ooh323c/configure.orig Sat Apr 28 13:40:24 2007
++++ asterisk-ooh323c/configure Sat Apr 28 13:40:58 2007
+@@ -9149,8 +9149,8 @@
+
+ fi
+
+-{ echo "$as_me:$LINENO: checking for /usr/include/asterisk/channel.h" >&5
+-echo $ECHO_N "checking for /usr/include/asterisk/channel.h... $ECHO_C" >&6; }
++{ echo "$as_me:$LINENO: checking for /usr/local/include/asterisk/channel.h" >&5
++echo $ECHO_N "checking for /usr/local/include/asterisk/channel.h... $ECHO_C" >&6; }
+ if test "${ac_cv_file__usr_include_asterisk_channel_h+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+@@ -9158,7 +9158,7 @@
+ { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+ echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+ { (exit 1); exit 1; }; }
+-if test -r "/usr/include/asterisk/channel.h"; then
++if test -r "/usr/local/include/asterisk/channel.h"; then
+ ac_cv_file__usr_include_asterisk_channel_h=yes
+ else
+ ac_cv_file__usr_include_asterisk_channel_h=no
diff --git a/net/asterisk-addons/files/patch-format_mp3-Makefile b/net/asterisk-addons/files/patch-format_mp3-Makefile
new file mode 100644
index 000000000000..b0b4ce26b740
--- /dev/null
+++ b/net/asterisk-addons/files/patch-format_mp3-Makefile
@@ -0,0 +1,8 @@
+--- format_mp3/Makefile.orig Mon Apr 2 22:26:03 2007
++++ format_mp3/Makefile Mon Apr 2 22:26:12 2007
+@@ -1,4 +1,4 @@
+-INSTALLTO=$(DESTDIR)/usr/lib/asterisk/modules
++INSTALLTO=/usr/local/lib/asterisk/modules
+ MODS=format_mp3.so
+ MP3OBJS=common.o dct64_i386.o decode_ntom.o layer3.o tabinit.o interface.o format_mp3.o
+
diff --git a/net/asterisk-addons/pkg-descr b/net/asterisk-addons/pkg-descr
index 797a19b3c61f..d2454dbd184f 100644
--- a/net/asterisk-addons/pkg-descr
+++ b/net/asterisk-addons/pkg-descr
@@ -1,5 +1,5 @@
This package contains additional modules for the Asterisk Open Source PBX
-which are, for one reason or another, not included in the normal base
-distribution. Many of these modules are experimental.
+which are, not included in the normal base distribution, becouse of licence
+incompatilities.
WWW: http://www.asteriskpbx.com
diff --git a/net/asterisk-addons/pkg-plist b/net/asterisk-addons/pkg-plist
index 09713ed4936e..f53cedf9e3fb 100644
--- a/net/asterisk-addons/pkg-plist
+++ b/net/asterisk-addons/pkg-plist
@@ -1,11 +1,8 @@
-@unexec if cmp -s %D/etc/asterisk/cdr_mysql.conf %D/etc/asterisk/cdr_mysql.conf.sample; then rm -f %D/etc/asterisk/cdr_mysql.conf; fi
-etc/asterisk/cdr_mysql.conf.sample
-@exec [-f %B/cdr_mysql.conf ] || cp %B/%f %B/cdr_mysql.conf
-@unexec if cmp -s %D/etc/asterisk/res_mysql.conf %D/etc/asterisk/res_mysql.conf.sample; then rm -f %D/etc/asterisk/res_mysql.conf; fi
-etc/asterisk/res_mysql.conf.sample
-@exec [-f %B/res_mysql.conf ] || cp $B/%f %B/res_mysql.conf
lib/asterisk/modules/app_addon_sql_mysql.so
lib/asterisk/modules/app_saycountpl.so
lib/asterisk/modules/cdr_addon_mysql.so
-lib/asterisk/modules/format_mp3.so
lib/asterisk/modules/res_config_mysql.so
+lib/asterisk/modules/format_mp3.so
+lib/asterisk/modules/chan_ooh323.so
+%%SAMPLE_CONFIG%%etc/asterisk/cdr_mysql.conf
+%%SAMPLE_CONFIG%%etc/asterisk/res_mysql.conf