aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk-oh323
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2008-08-22 02:11:32 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2008-08-22 02:11:32 +0000
commit4ce2ba14d1be3fb4156de280a05cbcdeff67fa5c (patch)
tree652c4bcbe1bdfd13883446e4f91f14faee9bb267 /net/asterisk-oh323
parentf9a2ddc2efffa20615460a1cbe772198ba036f3f (diff)
downloadports-4ce2ba14d1be3fb4156de280a05cbcdeff67fa5c.tar.gz
ports-4ce2ba14d1be3fb4156de280a05cbcdeff67fa5c.zip
Notes
Diffstat (limited to 'net/asterisk-oh323')
-rw-r--r--net/asterisk-oh323/Makefile1
-rw-r--r--net/asterisk-oh323/files/patch-asterisk-driver::chan_oh323.c26
2 files changed, 20 insertions, 7 deletions
diff --git a/net/asterisk-oh323/Makefile b/net/asterisk-oh323/Makefile
index eb4e4ca0cd30..be7931d9e591 100644
--- a/net/asterisk-oh323/Makefile
+++ b/net/asterisk-oh323/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk-oh323
PORTVERSION= 0.7.3.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.b2bua.org/chrome/site/
diff --git a/net/asterisk-oh323/files/patch-asterisk-driver::chan_oh323.c b/net/asterisk-oh323/files/patch-asterisk-driver::chan_oh323.c
index 9a659679a514..cdecc171e3c3 100644
--- a/net/asterisk-oh323/files/patch-asterisk-driver::chan_oh323.c
+++ b/net/asterisk-oh323/files/patch-asterisk-driver::chan_oh323.c
@@ -1,5 +1,8 @@
---- asterisk-driver/chan_oh323.c.orig 2008-03-20 16:49:39.000000000 +0200
-+++ asterisk-driver/chan_oh323.c 2008-03-20 18:29:13.000000000 +0200
+
+$FreeBSD$
+
+--- asterisk-driver/chan_oh323.c.orig
++++ asterisk-driver/chan_oh323.c
@@ -34,6 +34,7 @@
#include <string.h>
#include <sys/socket.h>
@@ -16,7 +19,16 @@
#include <netinet/ip.h>
#include <sys/signal.h>
-@@ -954,8 +956,8 @@
+@@ -83,6 +85,8 @@
+ #include "asterisk/threadstorage.h"
+ #include "asterisk/translate.h"
+
++#define CRASH abort()
++
+ #include "wrapper.hxx"
+ #include "oh323.h"
+
+@@ -954,8 +958,8 @@
static void oh323_format2codecset(int, int *, int);
static int context_from_alias(char *, char **);
static int context_from_prefix(char *, char **);
@@ -27,7 +39,7 @@
static struct oh323_ep *find_oh323_ep(char *epname, char *host, char *user);
void oh323_atexit(void);
unsigned int generate_uid(void);
-@@ -4110,7 +4112,7 @@
+@@ -4110,7 +4114,7 @@
/******************************************************************************/
/* Monitoring thread and queue call-back functions ****************************/
@@ -36,7 +48,7 @@
{
struct request_oh323 *e;
int res, i;
-@@ -4217,7 +4219,7 @@
+@@ -4217,7 +4221,7 @@
return(0);
}
@@ -45,7 +57,7 @@
{
struct chan_oh323_pvt *pvt = (struct chan_oh323_pvt *)data;
int index;
-@@ -4240,7 +4242,7 @@
+@@ -4240,7 +4244,7 @@
return(0);
}
@@ -54,7 +66,7 @@
{
char gkname[256];
-@@ -4443,7 +4445,7 @@
+@@ -4443,7 +4447,7 @@
return(-1);
}
}