aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk/Makefile
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2011-05-10 21:19:34 +0000
committerFlorian Smeets <flo@FreeBSD.org>2011-05-10 21:19:34 +0000
commitdc8be637687924bf10b03d7ce310e519d9c19501 (patch)
tree76e56deb317981cf32c6d42fb21a879e690c7546 /net/asterisk/Makefile
parentad1ed23b33160225a262740c2b51ec0c1c10e70f (diff)
downloadports-dc8be637687924bf10b03d7ce310e519d9c19501.tar.gz
ports-dc8be637687924bf10b03d7ce310e519d9c19501.zip
Notes
Diffstat (limited to 'net/asterisk/Makefile')
-rw-r--r--net/asterisk/Makefile26
1 files changed, 24 insertions, 2 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 2f55bf32fcb5..4bd13166fcd9 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 1.8.3.3
+PORTVERSION= 1.8.4
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -60,7 +60,9 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
ILBC "Enable iLBC codec" off \
SPANDSP "Enable Spandsp faxing support" off \
EXCHANGE "Enable Exchange calendar support" off \
- NEWG711 "Enable new G711 Codec" off
+ NEWG711 "Enable new G711 Codec" off \
+ SRTP "Enable SecureRTP support" off \
+ LUA "Enable LUA extensions support" off
ASTERISK_USER?= asterisk
ASTERISK_GROUP?= asterisk
@@ -257,6 +259,26 @@ PLIST_SUB+= WITH_EXCHANGE=""
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-menuselect-tree-g711-new-codec.diff
.endif
+.if !defined(WITH_SRTP)
+PLIST_SUB+= WITH_SRTP="@comment "
+CONFIGURE_ARGS+= --without-srtp
+.else
+PLIST_SUB+= WITH_SRTP=""
+BUILD_DEPENDS+= libsrtp>=1.4.4:${PORTSDIR}/net/libsrtp
+CONFIGURE_ARGS+= --with-srtp
+.endif
+
+.if defined(WITH_LUA)
+CONFIGURE_ARGS+= --with-lua
+CFLAGS+= -I${LUA_INCDIR}
+USE_LUA= yes
+LDFLAGS+= -L${LUA_LIBDIR}
+PLIST_SUB+= WITH_LUA=""
+.else
+CONFIGURE_ARGS+= --without-lua
+PLIST_SUB+= WITH_LUA="@comment "
+.endif
+
.if defined(WITH_MISC_PATCHES)
EXTRA_PATCHES+= ${PATCHDIR}/dtmf_debug.diff
EXTRA_PATCHES+= ${PATCHDIR}/feature_disconnect.diff