aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2004-04-30 05:21:08 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2004-04-30 05:21:08 +0000
commit962d6e05b40940170ea394def1103b4e065949bc (patch)
treee7bd91f082e901686aaa1a463f931bf3099c4f07 /net/asterisk/Makefile
parent77617709172415e13ef67e9e67856d4b669de3af (diff)
downloadports-962d6e05b40940170ea394def1103b4e065949bc.tar.gz
ports-962d6e05b40940170ea394def1103b4e065949bc.zip
Notes
Diffstat (limited to 'net/asterisk/Makefile')
-rw-r--r--net/asterisk/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 82db2899e80a..363d7a4f78b9 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 0.7.2
+PORTVERSION= 0.9.0
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -14,8 +14,6 @@ MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
MAINTAINER= sobomax@FreeBSD.org
COMMENT= An Open Source PBX and telephony toolkit
-FORBIDDEN= http://people.freebsd.org/~eik/portaudit/27c331d5-64c7-11d8-80e3-0020ed76ef5a.html
-
ONLY_FOR_ARCHS= i386
BUILD_DEPENDS= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client \
@@ -36,4 +34,14 @@ MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
OSVERSION=${OSVERSION} \
CXX="${CXX}"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_ZAPTEL) || exists(${LOCALBASE}/include/zaptel.h)
+BUILD_DEPENDS+= ${LOCALBASE}/include/zaptel.h:${PORTSDIR}/misc/zaptel
+RUN_DEPENDS+= ${LOCALBASE}/include/zaptel.h:${PORTSDIR}/misc/zaptel
+PLIST_SUB= ZAPTEL=""
+.else
+PLIST_SUB= ZAPTEL="@comment "
+.endif
+
+.include <bsd.port.post.mk>