aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2008-05-16 09:24:29 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2008-05-16 09:24:29 +0000
commit285e2c278ab94c27d91796679099a77878524cdf (patch)
treefdb5db734e5d21b486bc025816887cd269754368 /net/asterisk/Makefile
parent02c824f245a32f25ad2f366d67ec7d9f8f34c4ae (diff)
downloadports-285e2c278ab94c27d91796679099a77878524cdf.tar.gz
ports-285e2c278ab94c27d91796679099a77878524cdf.zip
Notes
Diffstat (limited to 'net/asterisk/Makefile')
-rw-r--r--net/asterisk/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index f972ca541c79..c1c8e5eaa5c1 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 1.4.18.1
-PORTREVISION= 1
+PORTVERSION= 1.4.19.2
CATEGORIES= net
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
http://ftp.digium.com/pub/asterisk/old-releases/
@@ -50,7 +49,8 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
FREETDS "Enable FreeTDS support" on \
JABBER "Enable Jabber and Gtalk support" on \
SQLITE "Enable SQLITE support" on \
- CODEC_PATCH "Apply codec negotiation patch" off
+ CODEC_PATCH "Apply codec negotiation patch" off \
+ MISC_PATCHES "Apply additional patches" off
.include <bsd.port.pre.mk>
@@ -159,13 +159,23 @@ LIB_DEPENDS+= sqlite:${PORTSDIR}/databases/sqlite2
.endif
.if defined(WITH_CODEC_PATCH)
-PATCHFILES= asterisk-1.4.18-codec-negotiation-20080313.diff.gz
+PATCHFILES= asterisk-1.4.19-codec-negotiation-20080408.diff.gz
PATCH_SITES= http://b2bua.org/chrome/site/
EXTRA_PATCHES+= ${PATCHDIR}/codecnego-patch-Makefile
.else
EXTRA_PATCHES+= ${PATCHDIR}/nocodecnego-patch-Makefile
.endif
+.if defined(WITH_MISC_PATCHES)
+EXTRA_PATCHES+= ${PATCHDIR}/dtmf_debug.diff
+EXTRA_PATCHES+= ${PATCHDIR}/feature_disconnect.diff
+EXTRA_PATCHES+= ${PATCHDIR}/sip_force_callid.diff
+.if defined(WITH_CODEC_PATCH)
+EXTRA_PATCHES+= ${PATCHDIR}/rtp_force_dtmf-codecnego.diff
+.else
+EXTRA_PATCHES+= ${PATCHDIR}/rtp_force_dtmf-nocodecnego.diff
+.endif
+.endif
post-patch:
${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample