aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2003-10-20 09:26:28 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2003-10-20 09:26:28 +0000
commit5d478a6316ec0e31af53a75e0f47971e9e434a5d (patch)
treee26deb4ca5024a37dc3c2199b3366ff7e670fba3 /net/asterisk/Makefile
parent53a4d5815135a9b4783f85917b5933066479f22e (diff)
downloadports-5d478a6316ec0e31af53a75e0f47971e9e434a5d.tar.gz
ports-5d478a6316ec0e31af53a75e0f47971e9e434a5d.zip
Notes
Diffstat (limited to 'net/asterisk/Makefile')
-rw-r--r--net/asterisk/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 89b4dbc958c9..3ecd86e63f8b 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 0.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -15,8 +15,11 @@ MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
MAINTAINER= sobomax@FreeBSD.org
COMMENT= An Open Source PBX and telephony toolkit
-BUILD_DEPENDS= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
-LIB_DEPENDS= speex.1:${PORTSDIR}/audio/speex
+BUILD_DEPENDS= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client \
+ ${NONEXISTENT}:${PORTSDIR}/devel/pwlib:build \
+ ${NONEXISTENT}:${PORTSDIR}/net/openh323:build
+LIB_DEPENDS= speex.2:${PORTSDIR}/audio/speex \
+ ldap.2:${PORTSDIR}/net/openldap20-client
RUN_DEPENDS= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
GNU_CONFIGURE= yes
@@ -24,6 +27,10 @@ CONFIGURE_WRKSRC= ${WRKSRC}/editline
USE_GMAKE= yes
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
- MKDIR="${MKDIR}"
+ MKDIR="${MKDIR}" \
+ PWLIBDIR=${WRKDIR}/../../../devel/pwlib/work/pwlib \
+ OPENH323DIR=${WRKDIR}/../../../net/openh323/work/openh323 \
+ OSVERSION=${OSVERSION} \
+ CXX="${CXX}"
.include <bsd.port.mk>