aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk10/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2007-04-16 08:40:15 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2007-04-16 08:40:15 +0000
commit19d165a76cfd7d6d232959e16084549577719832 (patch)
treedef94450a836d9ae6a174429c0e67f364859e7d5 /net/asterisk10/Makefile
parent56bfe515b51b1e69a0344db210bfa4ef0d60a3a9 (diff)
Notes
Diffstat (limited to 'net/asterisk10/Makefile')
-rw-r--r--net/asterisk10/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index 664a9fb2fef4..5c0fd913bed2 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -43,7 +43,8 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
POSTGRES "Enable PostgreSQL support" on \
RADIUS "Enable RADIUS accounting support" on \
SNMP "Enable SNMP support" on \
- H323 "Enable H.323 support" on
+ H323 "Enable H.323 support" on \
+ JABBER "Enable Jabber and Gtalk support" on
.include <bsd.port.pre.mk>
@@ -123,6 +124,15 @@ CONFIGURE_ARGS+= --with-netsnmp
LIB_DEPENDS+= netsnmp.10:${PORTSDIR}/net-mgmt/net-snmp
.endif
+.if defined(WITHOUT_JABBER)
+PLIST_SUB+= WITH_JABBER="@comment "
+CONFIGURE_ARGS+= --without-iksemel
+.else
+PLIST_SUB+= WITH_JABBER=""
+CONFIGURE_ARGS+= --with-iksemel
+LIB_DEPENDS+= iksemel.3:${PORTSDIR}/textproc/iksemel
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample