aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk10
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2009-05-19 07:15:38 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2009-05-19 07:15:38 +0000
commit0f560dc9207741ca86e884e7f72147a8e6a94c43 (patch)
tree9170b5e65542fe4f5ae68bdebf94568f6ddf22b9 /net/asterisk10
parent10c04370e7bf369d66c57a72a7d083cda57cf67c (diff)
downloadports-0f560dc9207741ca86e884e7f72147a8e6a94c43.tar.gz
ports-0f560dc9207741ca86e884e7f72147a8e6a94c43.zip
Notes
Diffstat (limited to 'net/asterisk10')
-rw-r--r--net/asterisk10/Makefile2
-rw-r--r--net/asterisk10/files/patch-vad_g72911
2 files changed, 12 insertions, 1 deletions
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index 1b41a4d3a73d..ee364a2eb12e 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asterisk
PORTVERSION= 1.4.24.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
diff --git a/net/asterisk10/files/patch-vad_g729 b/net/asterisk10/files/patch-vad_g729
new file mode 100644
index 000000000000..adee9d1e2491
--- /dev/null
+++ b/net/asterisk10/files/patch-vad_g729
@@ -0,0 +1,11 @@
+--- main/frame.c.orig 2009-05-14 12:43:39.000000000 +0300
++++ main/frame.c 2009-05-14 12:43:54.000000000 +0300
+@@ -266,7 +266,7 @@
+ /* Make sure we have enough data */
+ if (s->len < s->size) {
+ /* Or, if this is a G.729 frame with VAD on it, send it immediately anyway */
+- if (!((s->flags & AST_SMOOTHER_FLAG_G729) && (s->size % 10)))
++ if (!((s->flags & AST_SMOOTHER_FLAG_G729) && (s->len % 10)))
+ return NULL;
+ }
+ len = s->size;