aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk10
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2005-01-08 17:04:12 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2005-01-08 17:04:12 +0000
commitc27e73922b123decc36e0cb653f4abacae6a2f5c (patch)
tree9bf0b0c0c27efe1b565da6694727e0e7c2fe0542 /net/asterisk10
parent0edd7430b93d48ec51f65243adf9ec8d68151124 (diff)
downloadports-c27e73922b123decc36e0cb653f4abacae6a2f5c.tar.gz
ports-c27e73922b123decc36e0cb653f4abacae6a2f5c.zip
Notes
Diffstat (limited to 'net/asterisk10')
-rw-r--r--net/asterisk10/Makefile3
-rw-r--r--net/asterisk10/distinfo4
-rw-r--r--net/asterisk10/files/patch-channels::h323::Makefile21
-rw-r--r--net/asterisk10/files/patch-channels::h323::ast_h323.cpp37
4 files changed, 14 insertions, 51 deletions
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index 97b6dcea0d10..adfbab86b9dd 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 1.0.2
-PORTREVISION= 1
+PORTVERSION= 1.0.3
CATEGORIES= net
MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
diff --git a/net/asterisk10/distinfo b/net/asterisk10/distinfo
index 5fa2ddcf1403..a0719a9a3de2 100644
--- a/net/asterisk10/distinfo
+++ b/net/asterisk10/distinfo
@@ -1,2 +1,2 @@
-MD5 (asterisk-1.0.2.tar.gz) = 58b2c912b4e7c1f0438f06eb26c4b369
-SIZE (asterisk-1.0.2.tar.gz) = 9562949
+MD5 (asterisk-1.0.3.tar.gz) = 20a77d71efb670eb395314d52218fc7c
+SIZE (asterisk-1.0.3.tar.gz) = 9564612
diff --git a/net/asterisk10/files/patch-channels::h323::Makefile b/net/asterisk10/files/patch-channels::h323::Makefile
index bc34083e2ff3..779096bb2267 100644
--- a/net/asterisk10/files/patch-channels::h323::Makefile
+++ b/net/asterisk10/files/patch-channels::h323::Makefile
@@ -1,8 +1,8 @@
$FreeBSD$
---- channels/h323/Makefile.orig Tue Aug 31 16:32:11 2004
-+++ channels/h323/Makefile Sun Oct 10 15:25:42 2004
+--- channels/h323/Makefile.orig
++++ channels/h323/Makefile
@@ -53,7 +53,7 @@
LIBS+=-lpthread
endif
@@ -12,27 +12,28 @@ $FreeBSD$
endif
CFLAGS += -D_REENTRANT -D_GNU_SOURCE
CFLAGS += -DP_HAS_SEMAPHORES -DP_SSL -DP_PTHREADS
-@@ -74,19 +74,19 @@
-
+@@ -77,20 +77,20 @@
+ ar cr libchanh323.a ast_h323.o
ast_h323.o: ast_h323.cpp
- $(CXX) -g -c -fno-rtti -o $@ $(CFLAGS) $<
+ $(CXX) $(CXXFLAGS) -c -fno-rtti -o $@ $(CFLAGS) $<
- libchanh323.a: ast_h323.o
- ar cr libchanh323.a ast_h323.o
+ ifneq ($(wildcard .depend),)
+ include .depend
+ endif
chan_h323.so:
- $(CXX) -g -shared -Xlinker -x -o chan_h323.so chan_h323.o ast_h323.o -L$(PWLIBDIR)/lib -lpt_linux_x86_r -L$(OPENH323DIR)/lib -lh323_linux_x86_r -L/usr/lib $(CHANH323LIB)
-+ $(CXX) $(CXXFLAGS) -shared -Xlinker -x -o chan_h323.so chan_h323.o ast_h323.o -L$(PWLIBDIR)/lib -lpt_FreeBSD_x86_r_s -L$(OPENH323DIR)/lib -lh323_FreeBSD_x86_r -L/usr/lib $(CHANH323LIB)
++ $(CXX) $(CXXFLAGS) -shared -Xlinker -x -o chan_h323.so chan_h323.o ast_h323.o -L$(PWLIBDIR)/lib -lpt_FreeBSD_x86_r_s -L$(OPENH323DIR)/lib -lh323_FreeBSD_x86_r $(CHANH323LIB)
chan_h323_d.so: chan_h323.o ast_h323.o
- $(CXX) -shared -Xlinker -x -o chan_h323.so chan_h323.o ast_h323.o -L$(PWLIBDIR)/lib -lpt_linux_x86_d -L$(OPENH323DIR)/lib -lh323_linux_x86_d -L/usr/lib $(CHANH323LIB)
-+ $(CXX) $(CXXFLAGS) -shared -Xlinker -x -o chan_h323.so chan_h323.o ast_h323.o -L$(PWLIBDIR)/lib -lpt_FreeBSD_x86_d -L$(OPENH323DIR)/lib -lh323_FreeBSD_x86_d -L/usr/lib $(CHANH323LIB)
++ $(CXX) $(CXXFLAGS) -shared -Xlinker -x -o chan_h323.so chan_h323.o ast_h323.o -L$(PWLIBDIR)/lib -lpt_FreeBSD_x86_r_s -L$(OPENH323DIR)/lib -lh323_FreeBSD_x86_r $(CHANH323LIB)
chan_h323_s.so: chan_h323.o ast_h323.o
- $(CXX) -shared -Xlinker -x -o chan_h323.so chan_h323.o ast_h323.o -L$(PWLIBDIR)/lib -lpt_linux_x86_r_s -L$(OPENH323DIR)/lib -lh323_linux_x86_r_s -L/usr/lib $(CHANH323LIB)
-+ $(CXX) $(CXXFLAGS) -shared -Xlinker -x -o chan_h323.so chan_h323.o ast_h323.o -L$(PWLIBDIR)/lib -lpt_FreeBSD_x86_r_s -L$(OPENH323DIR)/lib -lh323_FreeBSD_x86_r_s -L/usr/lib $(CHANH323LIB)
++ $(CXX) $(CXXFLAGS) -shared -Xlinker -x -o chan_h323.so chan_h323.o ast_h323.o -L$(PWLIBDIR)/lib -lpt_FreeBSD_x86_r_s -L$(OPENH323DIR)/lib -lh323_FreeBSD_x86_r $(CHANH323LIB)
clean:
- rm -f *.o *.so core.* libchanh323.a
+ rm -f *.o *.so core.* libchanh323.a .depend
diff --git a/net/asterisk10/files/patch-channels::h323::ast_h323.cpp b/net/asterisk10/files/patch-channels::h323::ast_h323.cpp
deleted file mode 100644
index 6cfae1ec5d05..000000000000
--- a/net/asterisk10/files/patch-channels::h323::ast_h323.cpp
+++ /dev/null
@@ -1,37 +0,0 @@
-
-$FreeBSD$
-
---- channels/h323/ast_h323.cpp.orig
-+++ channels/h323/ast_h323.cpp
-@@ -722,7 +722,7 @@
- if (h323debug) {
- cout << " -- Sending user input tone (" << tone << ") to remote" << endl;
- }
-- on_send_digit(GetCallReference(), tone);
-+ on_send_digit(GetCallReference(), &tone);
- H323Connection::SendUserInputTone(tone, duration);
- }
-
-@@ -732,18 +732,20 @@
- if (h323debug) {
- cout << " -- Received user input tone (" << tone << ") from remote" << endl;
- }
-- on_send_digit(GetCallReference(), tone);
-+ on_send_digit(GetCallReference(), &tone);
- }
- H323Connection::OnUserInputTone(tone, duration, logicalChannel, rtpTimestamp);
- }
-
- void MyH323Connection::OnUserInputString(const PString &value)
- {
-+ char val;
- if (mode == H323_DTMF_RFC2833) {
- if (h323debug) {
- cout << " -- Received user input string (" << value << ") from remote." << endl;
- }
-- on_send_digit(GetCallReference(), value[0]);
-+ val = value[0];
-+ on_send_digit(GetCallReference(), &val);
- }
- }
-