aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk11
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2016-05-31 09:07:19 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2016-05-31 09:07:19 +0000
commit44419b2f2e189c13eba3ae60096b0a53b9a63605 (patch)
tree9b969a817d922a503d9a47db2b51570e56f31445 /net/asterisk11
parentf80efdd76ed8005ae0beffbd00d9aa6016ad3c52 (diff)
downloadports-44419b2f2e189c13eba3ae60096b0a53b9a63605.tar.gz
ports-44419b2f2e189c13eba3ae60096b0a53b9a63605.zip
Notes
Diffstat (limited to 'net/asterisk11')
-rw-r--r--net/asterisk11/Makefile2
-rw-r--r--net/asterisk11/files/patch-apps_app__queue.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/net/asterisk11/Makefile b/net/asterisk11/Makefile
index 9f1609ae3fe1..f102d4113197 100644
--- a/net/asterisk11/Makefile
+++ b/net/asterisk11/Makefile
@@ -2,7 +2,7 @@
PORTNAME= asterisk
PORTVERSION= 11.22.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/%SUBDIR%/:main,g729
MASTER_SITE_SUBDIR= asterisk/:main \
diff --git a/net/asterisk11/files/patch-apps_app__queue.c b/net/asterisk11/files/patch-apps_app__queue.c
new file mode 100644
index 000000000000..9eeef4a9b827
--- /dev/null
+++ b/net/asterisk11/files/patch-apps_app__queue.c
@@ -0,0 +1,11 @@
+--- apps/app_queue.c.orig 2016-03-29 19:25:17 UTC
++++ apps/app_queue.c
+@@ -3641,7 +3641,7 @@ static int can_ring_entry(struct queue_e
+ return 0;
+ }
+
+- if (call->member->in_call && call->lastqueue->wrapuptime) {
++ if (call->member->in_call && call->lastqueue && call->lastqueue->wrapuptime) {
+ ast_debug(1, "%s is in call, so not available (wrapuptime %d)\n",
+ call->interface, call->lastqueue->wrapuptime);
+ return 0;