aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk12/files/patch-utils::Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2006-01-17 22:27:45 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2006-01-17 22:27:45 +0000
commite61e1d66bd617141dc294a78d82e163554034060 (patch)
tree82d56db941093217a7c6bf1b3f6b2ba800639f4c /net/asterisk12/files/patch-utils::Makefile
parentcfb4ed733fa8c10b76f41592e5a4ea070e9ea37f (diff)
Update to 1.2.1.
Notes
Notes: svn path=/head/; revision=153765
Diffstat (limited to 'net/asterisk12/files/patch-utils::Makefile')
-rw-r--r--net/asterisk12/files/patch-utils::Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/net/asterisk12/files/patch-utils::Makefile b/net/asterisk12/files/patch-utils::Makefile
new file mode 100644
index 000000000000..f3164c0f478a
--- /dev/null
+++ b/net/asterisk12/files/patch-utils::Makefile
@@ -0,0 +1,34 @@
+
+$FreeBSD$
+
+--- utils/Makefile
++++ utils/Makefile
+@@ -17,16 +17,16 @@
+ CFLAGS+=-DNO_AST_MM
+
+ ifeq ($(findstring BSD,${OSARCH}),BSD)
+- CFLAGS+=-I$(CROSS_COMPILE_TARGET)/usr/local/include -L$(CROSS_COMPILE_TARGET)/usr/local/lib
++ CFLAGS+=-I$(CROSS_COMPILE_TARGET)$(LOCALBASE)/include -L$(CROSS_COMPILE_TARGET)$(LOCALBASE)/lib
+ endif
+
+ TARGET=stereorize streamplayer
+
+-ifneq ($(wildcard $(CROSS_COMPILE_TARGET)/usr/include/popt.h)$(wildcard -f $(CROSS_COMPILE_TARGET)/usr/local/include/popt.h),)
++ifneq ($(wildcard $(CROSS_COMPILE_TARGET)/usr/include/popt.h)$(wildcard -f $(CROSS_COMPILE_TARGET)$(LOCALBASE)/include/popt.h),)
+ TARGET+=smsq
+ endif
+
+-ifneq ($(wildcard $(CROSS_COMPILE_TARGET)/usr/include/newt.h)$(wildcard -f $(CROSS_COMPILE_TARGET)/usr/local/include/newt.h),)
++ifneq ($(wildcard $(CROSS_COMPILE_TARGET)/usr/include/newt.h)$(wildcard -f $(CROSS_COMPILE_TARGET)$(LOCALBASE)/include/newt.h),)
+ TARGET+=astman
+ endif
+
+@@ -40,7 +40,7 @@
+ install:
+ for x in $(TARGET); do \
+ if [ "$$x" != "none" ]; then \
+- $(INSTALL) -m 755 $$x $(DESTDIR)$(ASTSBINDIR)/$$x; \
++ $(BSD_INSTALL_PROGRAM) $$x $(DESTDIR)$(ASTSBINDIR)/$$x; \
+ fi; \
+ done
+