aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk14/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2007-07-27 02:41:10 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2007-07-27 02:41:10 +0000
commitcf24da0ea70fd8fd684751e4d3cdb248f7edbd41 (patch)
tree9e1a2e4a51502f58866aa4535ce099c594f279ed /net/asterisk14/Makefile
parent1350a1110b891d5eb68520bdb868b30ac8f7aac2 (diff)
Notes
Diffstat (limited to 'net/asterisk14/Makefile')
-rw-r--r--net/asterisk14/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/net/asterisk14/Makefile b/net/asterisk14/Makefile
index 732667320e8b..89af2f33a488 100644
--- a/net/asterisk14/Makefile
+++ b/net/asterisk14/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 1.4.8
+PORTVERSION= 1.4.9
CATEGORIES= net
MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
http://ftp.digium.com/pub/asterisk/old-releases/
@@ -45,7 +45,8 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
SNMP "Enable SNMP support" on \
H323 "Enable H.323 support" on \
FREETDS "Enable FreeTDS support" on \
- JABBER "Enable Jabber and Gtalk support" on
+ JABBER "Enable Jabber and Gtalk support" on \
+ SQLITE "Enable SQLITE support" on
.include <bsd.port.pre.mk>
@@ -144,6 +145,15 @@ CONFIGURE_ARGS+= --with-iksemel
LIB_DEPENDS+= iksemel.3:${PORTSDIR}/textproc/iksemel
.endif
+.if defined(WITHOUT_SQLITE)
+PLIST_SUB+= WITH_SQLITE="@comment "
+CONFIGURE_ARGS+= --without-sqlite
+.else
+PLIST_SUB+= WITH_SQLITE=""
+CONFIGURE_ARGS+= --with-sqlite
+LIB_DEPENDS+= sqlite:${PORTSDIR}/databases/sqlite2
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample