aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk14/files/patch-Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2007-04-16 08:40:15 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2007-04-16 08:40:15 +0000
commit19d165a76cfd7d6d232959e16084549577719832 (patch)
treedef94450a836d9ae6a174429c0e67f364859e7d5 /net/asterisk14/files/patch-Makefile
parent56bfe515b51b1e69a0344db210bfa4ef0d60a3a9 (diff)
Notes
Diffstat (limited to 'net/asterisk14/files/patch-Makefile')
-rw-r--r--net/asterisk14/files/patch-Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/net/asterisk14/files/patch-Makefile b/net/asterisk14/files/patch-Makefile
index 62dd952d9e74..f145cb58e89b 100644
--- a/net/asterisk14/files/patch-Makefile
+++ b/net/asterisk14/files/patch-Makefile
@@ -3,6 +3,15 @@ $FreeBSD$
--- Makefile.orig
+++ Makefile
+@@ -207,7 +207,7 @@
+
+ ifeq ($(OSARCH),FreeBSD)
+ # -V is understood by BSD Make, not by GNU make.
+- BSDVERSION=$(shell make -V OSVERSION -f /usr/share/mk/bsd.port.subdir.mk)
++ BSDVERSION=$(OSVERSION)
+ ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
+ AST_LIBS+=$(shell if test $(BSDVERSION) -lt 502102 ; then echo "-lc_r"; else echo "-pthread"; fi)
+ endif
@@ -371,15 +371,15 @@
# Should static HTTP be installed during make samples or even with its own target ala
# webvoicemail? There are portions here that *could* be customized but might also be