aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk14/files
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2004-12-13 13:35:02 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2004-12-13 13:35:02 +0000
commitf40fa78a35930d3c24c89f2c124b7c2957244e68 (patch)
treed7cf6828818a440ee9c86fdc72db932cb0e50d07 /net/asterisk14/files
parent420cf824d3eea3bc5d057bb795d4269ffc332a8a (diff)
downloadports-f40fa78a35930d3c24c89f2c124b7c2957244e68.tar.gz
ports-f40fa78a35930d3c24c89f2c124b7c2957244e68.zip
Notes
Diffstat (limited to 'net/asterisk14/files')
-rw-r--r--net/asterisk14/files/patch-Makefile55
-rw-r--r--net/asterisk14/files/patch-channels::Makefile18
-rw-r--r--net/asterisk14/files/patch-res::Makefile13
3 files changed, 55 insertions, 31 deletions
diff --git a/net/asterisk14/files/patch-Makefile b/net/asterisk14/files/patch-Makefile
index 43bf910fe669..77acd5fecf7d 100644
--- a/net/asterisk14/files/patch-Makefile
+++ b/net/asterisk14/files/patch-Makefile
@@ -1,9 +1,25 @@
$FreeBSD$
---- Makefile.orig Tue Sep 28 20:11:30 2004
-+++ Makefile Thu Oct 14 19:48:30 2004
-@@ -62,10 +62,10 @@
+--- Makefile.orig
++++ Makefile
+@@ -44,6 +44,15 @@
+ PROC=$(shell uname -m)
+ endif
+
++ifeq (${OSARCH},FreeBSD)
++ifeq ($(PROC),sparc64)
++PROC=ultrasparc
++OPTIONS+=$(shell if $(CC) -mtune=$(PROC) -S -o /dev/null -xc /dev/null >/dev/null 2>&1; then echo "-mtune=$(PROC)"; fi)
++OPTIONS+=$(shell if $(CC) -mcpu=v9 -S -o /dev/null -xc /dev/null >/dev/null 2>&1; then echo "-mcpu=v9"; fi)
++OPTIONS+=-fomit-frame-pointerendif
++endif
++endif
++
+ # Pentium Pro Optimize
+ #PROC=i686
+
+@@ -62,10 +71,10 @@
#K6OPT = -DK6OPT
#Tell gcc to optimize the asterisk's code
@@ -16,7 +32,7 @@ $FreeBSD$
# If you are running a radio application, define RADIO_RELAX so that the DTMF
# will be received more reliably
-@@ -90,7 +90,7 @@
+@@ -90,7 +99,7 @@
# Where to install asterisk after compiling
# Default -> leave empty
@@ -25,7 +41,7 @@ $FreeBSD$
# Staging directory
# Files are copied here temporarily during the install process
-@@ -110,23 +110,23 @@
+@@ -110,23 +119,23 @@
# Don't use together with -DBUSYDETECT_TONEONLY
BUSYDETECT+= #-DBUSYDETECT_COMPARE_TONE_AND_SILENCE
@@ -59,7 +75,7 @@ $FreeBSD$
CFLAGS+=$(OPTIMIZE)
ifneq ($(PROC),ultrasparc)
-@@ -137,11 +137,8 @@
+@@ -137,11 +146,8 @@
CFLAGS+=$(shell if [ -f /usr/include/osp/osp.h ]; then echo "-DOSP_SUPPORT -I/usr/include/osp" ; fi)
ifeq (${OSARCH},FreeBSD)
@@ -73,16 +89,19 @@ $FreeBSD$
endif # FreeBSD
ifeq (${OSARCH},NetBSD)
-@@ -157,7 +154,7 @@
+@@ -157,7 +163,10 @@
#CFLAGS+=-DOLD_DSP_ROUTINES
CFLAGS+=$(shell if [ -f /usr/include/linux/zaptel.h ]; then echo "-DZAPTEL_OPTIMIZATIONS"; fi)
-CFLAGS+=$(shell if [ -f /usr/local/include/zaptel.h ]; then echo "-DZAPTEL_OPTIMIZATIONS"; fi)
-+CFLAGS+=-I$(LOCALBASE)/include -DZAPTEL_OPTIMIZATIONS
++CFLAGS+=-I$(LOCALBASE)/include
++ifndef WITHOUT_ZAPTEL
++CFLAGS+=-DZAPTEL_OPTIMIZATIONS
++endif
LIBEDIT=editline/libedit.a
-@@ -219,7 +216,7 @@
+@@ -219,7 +228,7 @@
SOLINK=-shared -Xlinker -x
endif
@@ -91,7 +110,7 @@ $FreeBSD$
INSTALL=install
_all: all
-@@ -231,7 +228,7 @@
+@@ -231,7 +240,7 @@
@echo " + $(MAKE) install +"
@echo " +-------------------------------------------+"
@@ -100,7 +119,7 @@ $FreeBSD$
editline/config.h:
cd editline && unset CFLAGS LIBS && ./configure ; \
-@@ -240,13 +237,13 @@
+@@ -240,13 +249,13 @@
cd editline && unset CFLAGS LIBS && test -f config.h || ./configure
$(MAKE) -C editline libedit.a
@@ -121,7 +140,7 @@ $FreeBSD$
ifneq ($(wildcard .depend),)
include .depend
-@@ -268,13 +265,10 @@
+@@ -268,13 +277,10 @@
asterisk.o: asterisk.c build.h
@@ -138,7 +157,7 @@ $FreeBSD$
ifneq ($(strip $(ASTERISKVERSION)),)
build.h: .version
-@@ -292,8 +286,8 @@
+@@ -292,8 +298,8 @@
exit 1; \
fi
@@ -149,7 +168,7 @@ $FreeBSD$
muted: muted.o
$(CC) -o muted muted.o
-@@ -312,28 +306,28 @@
+@@ -312,28 +318,28 @@
$(MAKE) -C stdtime clean
datafiles: all
@@ -184,7 +203,7 @@ $FreeBSD$
else \
echo "No description for $$x"; \
exit 1; \
-@@ -341,18 +335,18 @@
+@@ -341,18 +347,18 @@
done
for x in sounds/vm-* sounds/transfer* sounds/pbx-* sounds/ss-* sounds/beep* sounds/dir-* sounds/conf-* sounds/agent-* sounds/invalid* sounds/tt-* sounds/auth-* sounds/privacy-* sounds/queue-*; do \
if grep -q "^%`basename $$x`%" sounds.txt; then \
@@ -208,7 +227,7 @@ $FreeBSD$
update:
@if [ -d CVS ]; then \
-@@ -364,111 +358,86 @@
+@@ -364,111 +370,86 @@
fi
bininstall: all
@@ -369,7 +388,7 @@ $FreeBSD$
:> $(DESTDIR)$(ASTSPOOLDIR)/voicemail/default/1234/unavail.gsm
for x in vm-theperson digits/1 digits/2 digits/3 digits/4 vm-isunavail; do \
cat $(DESTDIR)$(ASTVARLIBDIR)/sounds/$$x.gsm >> $(DESTDIR)$(ASTSPOOLDIR)/voicemail/default/1234/unavail.gsm ; \
-@@ -483,7 +452,7 @@
+@@ -483,7 +464,7 @@
@[ -d $(DESTDIR)$(HTTPDIR)/html ] || ( echo "No http directory" && exit 1 )
@[ -d $(DESTDIR)$(HTTPDIR)/cgi-bin ] || ( echo "No cgi-bin directory" && exit 1 )
install -m 4755 -o root -g root contrib/scripts/vmail.cgi $(DESTDIR)$(HTTPDIR)/cgi-bin/vmail.cgi
@@ -378,7 +397,7 @@ $FreeBSD$
for x in images/*.gif; do \
install -m 644 $$x $(DESTDIR)$(HTTPDIR)/html/_asterisk/; \
done
-@@ -503,10 +472,10 @@
+@@ -503,10 +484,10 @@
__rpm: _version
rm -rf /tmp/asterisk ; \
diff --git a/net/asterisk14/files/patch-channels::Makefile b/net/asterisk14/files/patch-channels::Makefile
index f10e4bcbf3eb..e82a0299756d 100644
--- a/net/asterisk14/files/patch-channels::Makefile
+++ b/net/asterisk14/files/patch-channels::Makefile
@@ -1,8 +1,8 @@
$FreeBSD$
---- channels/Makefile.orig Tue Aug 31 19:33:00 2004
-+++ channels/Makefile Sun Oct 10 16:18:05 2004
+--- channels/Makefile.orig
++++ channels/Makefile
@@ -57,10 +57,10 @@
endif
@@ -18,18 +18,20 @@ $FreeBSD$
endif
ifeq (${OSARCH},NetBSD)
PTLIB=-lpt_NetBSD_x86_r
-@@ -72,8 +72,8 @@
+@@ -72,8 +72,10 @@
endif
CHANNEL_LIBS+=$(shell [ -f /usr/include/linux/ixjuser.h ] && echo chan_phone.so)
-CHANNEL_LIBS+=$(shell [ -f /usr/local/include/ixjuser.h ] && echo chan_phone.so)
-CHANNEL_LIBS+=$(shell [ -f h323/libchanh323.a ] && echo chan_h323.so)
+CHANNEL_LIBS+=$(shell [ -f $(LOCALBASE)/include/ixjuser.h ] && echo chan_phone.so)
++ifndef WITHOUT_H323
+CHANNEL_LIBS+=chan_h323.so
++endif
CFLAGS+=-Wno-missing-prototypes -Wno-missing-declarations
CFLAGS+=$(shell [ ! -f /usr/include/linux/if_wanpipe.h ] && echo " -DOLD_SANGOMA_API")
-@@ -84,7 +84,7 @@
+@@ -84,7 +86,7 @@
ZAPPRI=$(shell [ -f /usr/lib/libpri.so.1 ] && echo "-lpri")
ZAPR2=$(shell [ -f /usr/lib/libmfcr2.so.1 ] && echo "-lmfcr2")
CFLAGS+=$(shell [ -f /usr/include/linux/zaptel.h ] && echo "-DIAX_TRUNKING")
@@ -38,7 +40,7 @@ $FreeBSD$
CHANNEL_LIBS+=$(shell [ -f /usr/include/vpbapi.h ] && echo "chan_vpb.so" )
CFLAGS+=$(shell [ -f /usr/include/vpbapi.h ] && echo " -DLINUX")
-@@ -107,7 +107,7 @@
+@@ -107,7 +109,7 @@
ZAPDIR=/usr/lib
CHANNEL_LIBS+=$(shell [ -f /usr/include/linux/zaptel.h ] && echo "chan_zap.so")
@@ -47,7 +49,7 @@ $FreeBSD$
CHANNEL_LIBS+=$(shell [ -f /usr/include/nbs.h ] && echo "chan_nbs.so" )
-@@ -156,6 +156,8 @@
+@@ -156,6 +158,8 @@
chan_oss.so: chan_oss.o
$(CC) $(SOLINK) -o $@ chan_oss.o -lossaudio
endif
@@ -56,7 +58,7 @@ $FreeBSD$
chan_iax2.so: chan_iax2.o iax2-parser.o iax2-provision.o
ifeq ($(USE_MYSQL_FRIENDS),1)
-@@ -175,7 +177,7 @@
+@@ -175,7 +179,7 @@
$(CC) -c $(CFLAGS) -o chan_zap.o chan_zap.c
chan_zap.so: chan_zap.o
@@ -65,7 +67,7 @@ $FreeBSD$
chan_sip.so: chan_sip.o
ifeq ($(USE_SIP_MYSQL_FRIENDS),1)
-@@ -199,15 +201,17 @@
+@@ -199,15 +203,17 @@
chan_vpb.so: chan_vpb.o
$(CXX) $(SOLINK) -o $@ $< -lvpb -lpthread -lm -ldl
diff --git a/net/asterisk14/files/patch-res::Makefile b/net/asterisk14/files/patch-res::Makefile
index 5700f04ea1ef..3377b4aa1c8e 100644
--- a/net/asterisk14/files/patch-res::Makefile
+++ b/net/asterisk14/files/patch-res::Makefile
@@ -1,18 +1,21 @@
$FreeBSD$
---- res/Makefile.orig Sat Jul 17 23:58:01 2004
-+++ res/Makefile Thu Oct 14 19:15:00 2004
-@@ -21,7 +21,7 @@
+--- res/Makefile.orig
++++ res/Makefile
+@@ -21,7 +21,10 @@
CFLAGS+=
CFLAGS+=$(shell [ -f /usr/include/linux/zaptel.h ] && echo " -DZAPATA_MOH")
-CFLAGS+=$(shell [ -f /usr/local/include/zaptel.h ] && echo " -DZAPATA_MOH")
-+CFLAGS+=-DZAPATA_MOH -I$(LOCALBASE)/include
++CFLAGS+=-I$(LOCALBASE)/include
++ifndef WITHOUT_ZAPTEL
++CFLAGS+=-DZAPATA_MOH
++endif
#
# Work around buggy RedHat 9.0
#
-@@ -34,7 +34,7 @@
+@@ -34,7 +37,7 @@
rm -f $(DESTDIR)$(ASTHEADERDIR)/parking.h
rm -f $(DESTDIR)$(MODULES_DIR)/app_agi.so
rm -f $(DESTDIR)$(MODULES_DIR)/res_parking.so