aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk16/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2003-10-17 11:22:52 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2003-10-17 11:22:52 +0000
commitf01a970a4ec80d0f3ed1b1bdb091b764dcbde9b2 (patch)
tree0aca8a0e8a5d8ec07e8780b50ba45ca50b749e1f /net/asterisk16/Makefile
parenta50ad34b6aeed8329502f312a934da08872c84cb (diff)
downloadports-f01a970a4ec80d0f3ed1b1bdb091b764dcbde9b2.tar.gz
ports-f01a970a4ec80d0f3ed1b1bdb091b764dcbde9b2.zip
Notes
Diffstat (limited to 'net/asterisk16/Makefile')
-rw-r--r--net/asterisk16/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
new file mode 100644
index 000000000000..870aaae229af
--- /dev/null
+++ b/net/asterisk16/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: asterisk
+# Date created: 17 October 2003
+# Whom: Maxim Sobolev <sobomax@portaone.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= asterisk
+PORTVERSION= 0.5.0
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
+ ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
+
+MAINTAINER= sobomax@FreeBSD.org
+COMMENT= An Open Source PBX and telephony toolkit
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
+RUN_DEPENDS= ${LOCALBASE}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql40-client
+
+GNU_CONFIGURE= yes
+CONFIGURE_WRKSRC= ${WRKSRC}/editline
+USE_GMAKE= yes
+MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ MKDIR="${MKDIR}"
+
+.include <bsd.port.mk>