aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk16
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2009-02-27 02:07:57 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2009-02-27 02:07:57 +0000
commit9b96913cbc2e3a3bffc7ebfe9be42edd914ad2d3 (patch)
tree20f9062e28f9796362417def024b719dd62544e4 /net/asterisk16
parentc9c69bb4748d38008e2c9012737ac36ce1a79ffa (diff)
downloadports-9b96913cbc2e3a3bffc7ebfe9be42edd914ad2d3.tar.gz
ports-9b96913cbc2e3a3bffc7ebfe9be42edd914ad2d3.zip
Notes
Diffstat (limited to 'net/asterisk16')
-rw-r--r--net/asterisk16/Makefile24
-rw-r--r--net/asterisk16/pkg-plist6
2 files changed, 24 insertions, 6 deletions
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index be0fef674fd3..a399002cbcdf 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -19,9 +19,7 @@ COMMENT= An Open Source PBX and telephony toolkit
BUILD_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
LIB_DEPENDS= speex.1:${PORTSDIR}/audio/speex \
- newt.51:${PORTSDIR}/devel/newt \
- gsm.1:${PORTSDIR}/audio/gsm \
- curl.5:${PORTSDIR}/ftp/curl
+ newt.51:${PORTSDIR}/devel/newt
RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
ONLY_FOR_ARCHS= i386 sparc64 amd64 powerpc
@@ -55,6 +53,8 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
FREETDS "Enable FreeTDS support" on \
JABBER "Enable Jabber and Gtalk support" on \
SQLITE "Enable SQLITE support" on \
+ GSM "Enable GSM codec" on \
+ CURL "Enable CURL support" on \
ILBC "Enable iLBC codec" off \
# CODEC_PATCH "Apply codec negotiation patch" off \
# MISC_PATCHES "Apply additional patches" off
@@ -174,6 +174,24 @@ PLIST_SUB+= WITH_ILBC=""
EXTRA_PATCHES+= ${PATCHDIR}/ilbc_enable.diff
.endif
+.if !defined(WITH_GSM)
+PLIST_SUB+= WITH_GSM="@comment "
+CONFIGURE_ARGS+= --without-gsm
+.else
+PLIST_SUB+= WITH_GSM=""
+CONFIGURE_ARGS+= --with-gsm
+LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
+.endif
+
+.if !defined(WITH_CURL)
+PLIST_SUB+= WITH_CURL="@comment "
+CONFIGURE_ARGS+= --without-curl
+.else
+PLIST_SUB+= WITH_CURL=""
+CONFIGURE_ARGS+= --with-curl
+LIB_DEPENDS+= curl.5:${PORTSDIR}/ftp/curl
+.endif
+
.if defined(WITH_CODEC_PATCH)
PATCHFILES= asterisk-1.4.22-codec-negotiation-20081110.diff.gz
PATCH_SITES= http://b2bua.org/chrome/site/
diff --git a/net/asterisk16/pkg-plist b/net/asterisk16/pkg-plist
index 3658e4976492..3b7533ac78b2 100644
--- a/net/asterisk16/pkg-plist
+++ b/net/asterisk16/pkg-plist
@@ -272,7 +272,7 @@ lib/asterisk/modules/func_version.so
lib/asterisk/modules/func_vmcount.so
lib/asterisk/modules/func_volume.so
lib/asterisk/modules/res_ael_share.so
-lib/asterisk/modules/res_config_curl.so
+%%WITH_CURL%%lib/asterisk/modules/res_config_curl.so
lib/asterisk/modules/res_config_ldap.so
%%WITH_SQLITE%%lib/asterisk/modules/res_config_sqlite.so
lib/asterisk/modules/res_limit.so
@@ -354,7 +354,7 @@ lib/asterisk/modules/codec_a_mu.so
lib/asterisk/modules/codec_adpcm.so
lib/asterisk/modules/codec_alaw.so
lib/asterisk/modules/codec_g726.so
-lib/asterisk/modules/codec_gsm.so
+%%WITH_GSM%%lib/asterisk/modules/codec_gsm.so
%%WITH_ILBC%%lib/asterisk/modules/codec_ilbc.so
lib/asterisk/modules/codec_lpc10.so
lib/asterisk/modules/codec_speex.so
@@ -377,7 +377,7 @@ lib/asterisk/modules/func_base64.so
lib/asterisk/modules/func_callerid.so
lib/asterisk/modules/func_cdr.so
lib/asterisk/modules/func_channel.so
-lib/asterisk/modules/func_curl.so
+%%WITH_CURL%%lib/asterisk/modules/func_curl.so
lib/asterisk/modules/func_cut.so
lib/asterisk/modules/func_db.so
lib/asterisk/modules/func_enum.so