aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk16
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2020-06-11 22:12:58 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2020-06-11 22:12:58 +0000
commit6f9db33445d38314e3178fbd20b999cf697fe67c (patch)
tree77bbe22cb941b7a9872cf0848e8346f4be221abc /net/asterisk16
parentb06bd300b41f92e2579fe81533733dfa5045cc6e (diff)
downloadports-6f9db33445d38314e3178fbd20b999cf697fe67c.tar.gz
ports-6f9db33445d38314e3178fbd20b999cf697fe67c.zip
Notes
Diffstat (limited to 'net/asterisk16')
-rw-r--r--net/asterisk16/Makefile7
-rw-r--r--net/asterisk16/distinfo6
-rw-r--r--net/asterisk16/files/0050-fix-race-parallel-build.patch59
-rw-r--r--net/asterisk16/files/patch-configure31
4 files changed, 5 insertions, 98 deletions
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index 102e59a81e68..2358102c66a5 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= asterisk
-PORTVERSION= 16.10.0
-PORTREVISION= 2
+PORTVERSION= 16.11.0
CATEGORIES= net
MASTER_SITES= https://downloads.asterisk.org/pub/telephony/%SUBDIR%/:DEFAULT,g729 \
http://www.pjsip.org/release/${PJSIP_VERSION}/:PJSIP
@@ -65,7 +64,7 @@ CONFLICTS_INSTALL= asterisk13
OPTIONS_DEFINE= ASTVERSION BACKTRACE CURL EXCHANGE FREETDS G729 LDAP LUA MACRO \
MP3PLAYER OOH323 OPTIMIZED_CFLAGS PJSIP PORTAUDIO RADIUS SNMP \
SPANDSP SRTP SYSINFO URIPARSER XMPP
-OPTIONS_DEFAULT= CURL FREETDS GSM LUA MACRO MP3PLAYER NEWT ODBC MYSQL PGSQL \
+OPTIONS_DEFAULT= CURL FREETDS GSM LUA MACRO MP3PLAYER NEWT ODBC OPUS MYSQL PGSQL \
PJSIP PORTAUDIO RADIUS SNMP SPANDSP SPEEX SQLITE2 SRTP URIPARSER \
VORBIS
@@ -246,8 +245,6 @@ post-extract-OPUS-on:
post-patch:
@${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/samples/musiconhold.conf.sample
- @${CP} ${FILESDIR}/0050-fix-race-parallel-build.patch \
- ${WRKSRC}/third-party/pjproject/patches/
.if exists(${FILESDIR}/.asterisk.makeopts)
${CP} ${FILESDIR}/.asterisk.makeopts ${WRKSRC}/menuselect.makeopts
.endif
diff --git a/net/asterisk16/distinfo b/net/asterisk16/distinfo
index 53ac96450af7..ed0cdf8b5044 100644
--- a/net/asterisk16/distinfo
+++ b/net/asterisk16/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1588265447
-SHA256 (asterisk/asterisk-16.10.0.tar.gz) = 8733f137b4b4e01d90bb796fa41d992e656b4cf1c28d2d7e81863a6839975702
-SIZE (asterisk/asterisk-16.10.0.tar.gz) = 27706766
+TIMESTAMP = 1591868315
+SHA256 (asterisk/asterisk-16.11.0.tar.gz) = 5db58aeee6cbc7604cd7059fe210f5fae0eae8aa1b13e5282984b9b9c12eaf36
+SIZE (asterisk/asterisk-16.11.0.tar.gz) = 27708591
SHA256 (asterisk/pjproject-2.9.tar.bz2) = d185ef7855c8ec07191dde92f54b65a7a4b7a6f7bf8c46f7af35ceeb1da2a636
SIZE (asterisk/pjproject-2.9.tar.bz2) = 5009546
SHA256 (asterisk/asterisk-core-sounds-en-g729-1.5.tar.gz) = 8b28a59cfa53b59c76e0a191704f0708e3d83acffab8c5e6f25dfc599f0123f9
diff --git a/net/asterisk16/files/0050-fix-race-parallel-build.patch b/net/asterisk16/files/0050-fix-race-parallel-build.patch
deleted file mode 100644
index da8ff8642cfb..000000000000
--- a/net/asterisk16/files/0050-fix-race-parallel-build.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-diff --git a/build/rules.mak b/build/rules.mak
-index 8fa98655e..912199c41 100644
---- a/build/rules.mak
-+++ b/build/rules.mak
-@@ -129,7 +129,7 @@ endif
- $(OBJDIR)/$(app).o: $(OBJDIRS) $(OBJS)
- $(CROSS_COMPILE)ld -r -o $@ $(OBJS)
-
--$(OBJDIR)/$(app).ko: $(OBJDIR)/$(app).o
-+$(OBJDIR)/$(app).ko: $(OBJDIR)/$(app).o | $(OBJDIRS)
- @echo Creating kbuild Makefile...
- @echo "# Our module name:" > $(OBJDIR)/Makefile
- @echo 'obj-m += $(app).o' >> $(OBJDIR)/Makefile
-@@ -154,27 +154,27 @@ $(OBJDIR)/$(app).ko: $(OBJDIR)/$(app).o
- ../lib/$(app).ko: $(LIB) $(OBJDIR)/$(app).ko
- cp $(OBJDIR)/$(app).ko ../lib
-
--$(OBJDIR)/%$(OBJEXT): $(SRCDIR)/%.m
-+$(OBJDIR)/%$(OBJEXT): $(SRCDIR)/%.m | $(OBJDIRS)
- $(CC) $($(APP)_CFLAGS) \
- $(CC_OUT)$(subst /,$(HOST_PSEP),$@) \
- $(subst /,$(HOST_PSEP),$<)
-
--$(OBJDIR)/%$(OBJEXT): $(SRCDIR)/%.c
-+$(OBJDIR)/%$(OBJEXT): $(SRCDIR)/%.c | $(OBJDIRS)
- $(CC) $($(APP)_CFLAGS) \
- $(CC_OUT)$(subst /,$(HOST_PSEP),$@) \
- $(subst /,$(HOST_PSEP),$<)
-
--$(OBJDIR)/%$(OBJEXT): $(SRCDIR)/%.S
-+$(OBJDIR)/%$(OBJEXT): $(SRCDIR)/%.S | $(OBJDIRS)
- $(CC) $($(APP)_CFLAGS) \
- $(CC_OUT)$(subst /,$(HOST_PSEP),$@) \
- $(subst /,$(HOST_PSEP),$<)
-
--$(OBJDIR)/%$(OBJEXT): $(SRCDIR)/%.cpp
-+$(OBJDIR)/%$(OBJEXT): $(SRCDIR)/%.cpp | $(OBJDIRS)
- $(CXX) $($(APP)_CXXFLAGS) \
- $(CC_OUT)$(subst /,$(HOST_PSEP),$@) \
- $(subst /,$(HOST_PSEP),$<)
-
--$(OBJDIR)/%$(OBJEXT): $(SRCDIR)/%.cc
-+$(OBJDIR)/%$(OBJEXT): $(SRCDIR)/%.cc | $(OBJDIRS)
- $(CXX) $($(APP)_CXXFLAGS) \
- $(CC_OUT)$(subst /,$(HOST_PSEP),$@) \
- $(subst /,$(HOST_PSEP),$<)
-diff --git a/pjsip/build/Makefile b/pjsip/build/Makefile
-index b85c7817a..20777909f 100644
---- a/pjsip/build/Makefile
-+++ b/pjsip/build/Makefile
-@@ -262,7 +262,7 @@ $(PJSUA_LIB_LIB) $(PJSUA_LIB_SONAME): $(PJSIP_LIB) $(PJSIP_SONAME) $(PJSIP_SIMPL
-
- pjsua2-lib: $(PJSUA2_LIB_LIB)
- $(PJSUA2_LIB_SONAME): $(PJSUA2_LIB_LIB)
--$(PJSUA2_LIB_LIB) $(PJSUA2_LIB_SONAME): $(PJSUA_LIB) $(PSJUA_LIB_SONAME) $(PJSIP_LIB) $(PJSIP_SONAME) $(PJSIP_SIMPLE_LIB) $(PJSIP_SIMPLE_SONAME) $(PJSIP_UA_LIB) $(PJSIP_UA_SONAME)
-+$(PJSUA2_LIB_LIB) $(PJSUA2_LIB_SONAME): $(PJSUA_LIB_LIB) $(PJSUA_LIB_SONAME) $(PJSIP_LIB) $(PJSIP_SONAME) $(PJSIP_SIMPLE_LIB) $(PJSIP_SIMPLE_SONAME) $(PJSIP_UA_LIB) $(PJSIP_UA_SONAME)
- $(MAKE) -f $(RULES_MAK) APP=PJSUA2_LIB app=pjsua2-lib $(subst /,$(HOST_PSEP),$(LIBDIR)/$@)
-
- pjsip-test: $(TEST_EXE)
diff --git a/net/asterisk16/files/patch-configure b/net/asterisk16/files/patch-configure
index 29911879c6f8..dcc4fd037873 100644
--- a/net/asterisk16/files/patch-configure
+++ b/net/asterisk16/files/patch-configure
@@ -9,37 +9,6 @@
;;
openbsd*)
ac_default_prefix=/usr/local
-@@ -9230,25 +9228,25 @@ $as_echo "configuring" >&6; }
-
- this_host=$(./config.sub $(./config.guess))
- if test "$build" != "$this_host" ; then
-- PJPROJECT_CONFIGURE_OPTS+=" --build=$build_alias"
-+ PJPROJECT_CONFIGURE_OPTS="${PJPROJECT_CONFIGURE_OPTS} --build=$build_alias"
- fi
- if test "$host" != "$this_host" ; then
-- PJPROJECT_CONFIGURE_OPTS+=" --host=$host_alias"
-+ PJPROJECT_CONFIGURE_OPTS="${PJPROJECT_CONFIGURE_OPTS} --host=$host_alias"
- fi
- # This was a copy of the autoconf generated code from the root ./configure.
- # Hopefully, when you read this, the code is still the same.
- if test "${with_ssl+set}" = set; then :
- case $with_ssl in
- n|no)
-- PJPROJECT_CONFIGURE_OPTS+=" --disable-ssl"
-+ PJPROJECT_CONFIGURE_OPTS="${PJPROJECT_CONFIGURE_OPTS} --disable-ssl"
- ;;
- y|ye|yes)
- # Not to mention SSL is the default in PJProject and means "autodetect".
- # In Asterisk, "./configure --with-ssl" means "must be present".
-- PJPROJECT_CONFIGURE_OPTS+=""
-+ #PJPROJECT_CONFIGURE_OPTS+=""
- ;;
- *)
-- PJPROJECT_CONFIGURE_OPTS+=" --with-ssl=${with_ssl}"
-+ PJPROJECT_CONFIGURE_OPTS="${PJPROJECT_CONFIGURE_OPTS} --with-ssl=${with_ssl}"
- ;;
- esac
- fi
@@ -20351,6 +20349,8 @@ $as_echo_n "checking for getifaddrs() support... " >&6
cat confdefs.h - <<_ACEOF >conftest.$ac_ext