aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2012-08-02 20:55:45 +0000
committerFlorian Smeets <flo@FreeBSD.org>2012-08-02 20:55:45 +0000
commit70cb68b667af4d2bdf206c5ac53bce3020f259a0 (patch)
treec01b3b0a9d3632af0dc2f2c885260fee554a8fbd /net/asterisk
parent522fb4b9b52a047148aaebf1b09dd7b2e09707fc (diff)
downloadports-70cb68b667af4d2bdf206c5ac53bce3020f259a0.tar.gz
ports-70cb68b667af4d2bdf206c5ac53bce3020f259a0.zip
Notes
Diffstat (limited to 'net/asterisk')
-rw-r--r--net/asterisk/Makefile3
-rw-r--r--net/asterisk/distinfo4
-rw-r--r--net/asterisk/files/patch-Makefile37
3 files changed, 22 insertions, 22 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index bc32e9b1d3cf..ba0ebc3cb0e8 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 1.8.14.1
-PORTREVISION= 2
+PORTVERSION= 1.8.15.0
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
diff --git a/net/asterisk/distinfo b/net/asterisk/distinfo
index feb58028f7d5..bfcd998b1874 100644
--- a/net/asterisk/distinfo
+++ b/net/asterisk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (asterisk-1.8.14.1.tar.gz) = 24e4ef2204905e8fe80f768ffb7a6e2410e43c599f5ee1b6aefd33ea0cb98a13
-SIZE (asterisk-1.8.14.1.tar.gz) = 25068289
+SHA256 (asterisk-1.8.15.0.tar.gz) = 32331f2a1bef79e31462abca2f8d2a23df01f0b927aa6c0d533023ef06fd2867
+SIZE (asterisk-1.8.15.0.tar.gz) = 25083527
diff --git a/net/asterisk/files/patch-Makefile b/net/asterisk/files/patch-Makefile
index 68340e451100..2392878bdc50 100644
--- a/net/asterisk/files/patch-Makefile
+++ b/net/asterisk/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2011-08-25 21:08:04.000000000 +0200
-+++ Makefile 2011-08-31 21:21:45.000000000 +0200
-@@ -122,7 +122,7 @@
+--- Makefile.orig 2012-06-13 16:27:57.000000000 +0200
++++ Makefile 2012-08-02 00:02:38.030569971 +0200
+@@ -121,7 +121,7 @@
OVERWRITE=y
# Include debug and macro symbols in the executables (-g) and profiling info (-pg)
@@ -9,16 +9,16 @@
# Asterisk.conf is located in ASTETCDIR or by using the -C flag
# when starting Asterisk
-@@ -235,7 +237,7 @@
- _ASTCFLAGS+=-march=i686
- endif
+@@ -188,7 +188,7 @@
+
+ ifeq ($(OSARCH),FreeBSD)
# -V is understood by BSD Make, not by GNU make.
- BSDVERSION=$(shell make -V OSVERSION -f /usr/share/mk/bsd.port.subdir.mk)
+ BSDVERSION=$(OSVERSION)
_ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
endif
-@@ -462,8 +464,13 @@
+@@ -415,8 +415,13 @@
$(INSTALL) -m 644 $$x "$(DESTDIR)$(ASTDATADIR)/static-http" ; \
done
$(INSTALL) -m 644 doc/core-en_US.xml "$(DESTDIR)$(ASTDATADIR)/static-http";
@@ -33,15 +33,16 @@
done
$(MAKE) -C sounds install
-@@ -523,6 +530,7 @@
- $(INSTALL) -d "$(DESTDIR)$(ASTSPOOLDIR)/dictate"
- $(INSTALL) -d "$(DESTDIR)$(ASTSPOOLDIR)/meetme"
- $(INSTALL) -d "$(DESTDIR)$(ASTSPOOLDIR)/monitor"
-+ $(INSTALL) -d "$(DESTDIR)$(ASTSPOOLDIR)/outgoing"
- $(INSTALL) -d "$(DESTDIR)$(ASTSPOOLDIR)/system"
- $(INSTALL) -d "$(DESTDIR)$(ASTSPOOLDIR)/tmp"
- $(INSTALL) -d "$(DESTDIR)$(ASTSPOOLDIR)/voicemail"
-@@ -604,7 +612,7 @@
+@@ -475,7 +480,7 @@
+ "$(ASTDATADIR)/documentation/thirdparty" "$(ASTDATADIR)/firmware" \
+ "$(ASTDATADIR)/firmware/iax" "$(ASTDATADIR)/images" "$(ASTDATADIR)/keys" \
+ "$(ASTDATADIR)/phoneprov" "$(ASTDATADIR)/static-http" "$(ASTDATADIR)/sounds" \
+- "$(ASTDATADIR)/moh" "$(ASTMANDIR)/man8" "$(AGI_DIR)" "$(ASTDBDIR)"
++ "$(ASTDATADIR)/moh" "$(ASTMANDIR)/man8" "$(AGI_DIR)" "$(ASTDBDIR)" "$(ASTSPOOLDIR)/outgoing"
+
+ installdirs:
+ @for i in $(INSTALLDIRS); do \
+@@ -542,7 +547,7 @@
@exit 1
endif
@@ -50,7 +51,7 @@
@if [ -x /usr/sbin/asterisk-post-install ]; then \
/usr/sbin/asterisk-post-install "$(DESTDIR)" . ; \
fi
-@@ -646,29 +654,18 @@
+@@ -584,29 +589,18 @@
else \
echo "Installing $$x" ; \
fi ; \
@@ -86,7 +87,7 @@
echo "Updating asterisk.conf" ; \
sed -e 's|^astetcdir.*$$|astetcdir => $(ASTETCDIR)|' \
-e 's|^astmoddir.*$$|astmoddir => $(MODULES_DIR)|' \
-@@ -682,6 +679,7 @@
+@@ -620,6 +614,7 @@
-e 's|^astlogdir.*$$|astlogdir => $(ASTLOGDIR)|' \
"$(DESTDIR)$(ASTCONFPATH)" > "$(DESTDIR)$(ASTCONFPATH).tmp" ; \
$(INSTALL) -m 644 "$(DESTDIR)$(ASTCONFPATH).tmp" "$(DESTDIR)$(ASTCONFPATH)" ; \