aboutsummaryrefslogtreecommitdiff
path: root/net/astmanproxy/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-15 16:36:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-15 16:36:18 +0000
commite91b20e86da9bedcf7b80a4991ea0efdd0b10f7a (patch)
tree0cf40856dbef66ae361c6126626158cdeafbfbfa /net/astmanproxy/Makefile
parent9b704e84e8b4773a4a044b7a464044b7d36269b8 (diff)
downloadports-e91b20e86da9bedcf7b80a4991ea0efdd0b10f7a.tar.gz
ports-e91b20e86da9bedcf7b80a4991ea0efdd0b10f7a.zip
Notes
Diffstat (limited to 'net/astmanproxy/Makefile')
-rw-r--r--net/astmanproxy/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/net/astmanproxy/Makefile b/net/astmanproxy/Makefile
new file mode 100644
index 000000000000..a92ae1f945fc
--- /dev/null
+++ b/net/astmanproxy/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: astmanproxy
+# Date created: 1 November 2007
+# Whom: ditesh@gathani.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= astmanproxy
+PORTVERSION= 1.21
+CATEGORIES= net
+MASTER_SITES= http://www.popvox.com/
+DISTFILES= astmanproxy-latest.tgz
+
+MAINTAINER= ditesh@gathani.org
+COMMENT= A multi-threaded proxy server for Asterisk
+
+USE_OPENSSL= yes
+USE_GMAKE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|^CONFDIR:.*|CONFDIR := ${PREFIX}/etc/asterisk|' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|^CONFDIR_REAL.*|CONFDIR_REAL := ${PREFIX}/etc/asterisk|' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|^PERMDIR:.*|PERMDIR:= ${PREFIX}/etc/asterisk|' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|^PERMDIR_REAL.*|PERMDIR_REAL := ${PREFIX}/etc/asterisk|' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|^LIBDIR.*|LIBDIR := ${PREFIX}/lib/asterisk|' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|^BINDIR.*|BINDIR := ${PREFIX}/sbin|' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|MKTEMP=.*|MKTEMP=/usr/bin/mktemp|' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|LOGDIR=/var/log/asterisk|LOGDIR=/var/log|' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|-ldl ||' ${WRKSRC}/Makefile
+
+post-install:
+ @${INSTALL_DATA} ${WRKSRC}/configs/astmanproxy.conf ${PREFIX}/etc/asterisk/astmanproxy.conf.sample
+ @[ -f ${PREFIX}/etc/asterisk/astmanproxy.conf ] || \
+ ${INSTALL_DATA} ${WRKSRC}/configs/astmanproxy.conf ${PREFIX}/etc/asterisk/astmanproxy.conf
+ @${INSTALL_DATA} ${WRKSRC}/configs/astmanproxy.users ${PREFIX}/etc/asterisk/astmanproxy.users.sample
+ @[ -f ${PREFIX}/etc/asterisk/astmanproxy.users ] || \
+ ${INSTALL_DATA} ${WRKSRC}/configs/astmanproxy.users ${PREFIX}/etc/asterisk/astmanproxy.users
+
+.include <bsd.port.mk>