aboutsummaryrefslogtreecommitdiff
path: root/net/avahi-qt3
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-04-15 22:02:20 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-04-15 22:02:20 +0000
commit38a6f3845d49d61c2a75f586b0a137a1fa0253fa (patch)
tree53f263b550443c87b0337dbc0066057ca008f03a /net/avahi-qt3
parent022a23321673bcc72642e2d3c5b65929924d0511 (diff)
downloadports-38a6f3845d49d61c2a75f586b0a137a1fa0253fa.tar.gz
ports-38a6f3845d49d61c2a75f586b0a137a1fa0253fa.zip
Notes
Diffstat (limited to 'net/avahi-qt3')
-rw-r--r--net/avahi-qt3/Makefile48
-rw-r--r--net/avahi-qt3/pkg-descr3
-rw-r--r--net/avahi-qt3/pkg-plist7
3 files changed, 58 insertions, 0 deletions
diff --git a/net/avahi-qt3/Makefile b/net/avahi-qt3/Makefile
new file mode 100644
index 000000000000..45e0bf2904b1
--- /dev/null
+++ b/net/avahi-qt3/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: avahi-qt3
+# Date created: 12 April 2007
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= net
+PKGNAMESUFFIX= -qt3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Qt 3 bindings to the Avahi mDNS system
+
+LIB_DEPENDS= avahi-common.3:${PORTSDIR}/net/avahi
+
+MASTERDIR= ${.CURDIR}/../avahi
+BUILD_WRKSRC= ${WRKSRC}/avahi-qt
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+AVAHI_SLAVE= yes
+
+USE_GNOME= gnomehack gnometarget ltverhack
+USE_QT_VER= 3
+CONFIGURE_ARGS= --disable-python \
+ --disable-mono \
+ --disable-monodoc \
+ --disable-gtk \
+ --enable-qt3 \
+ --disable-qt4 \
+ --localstatedir=/var \
+ --disable-doxygen-docs \
+ --disable-xml-docs \
+ --disable-doxygen-dot \
+ --with-dbus-system-address=unix:path=/var/run/dbus/system_bus_socket \
+ --with-distro=freebsd
+
+post-build:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} \
+ ${MAKE_FLAGS} Makefile ${MAKE_ARGS} avahi-qt3.pc
+
+post-install:
+ ${MKDIR} ${PREFIX}/libdata/pkgconfig
+ ${INSTALL_DATA} ${WRKSRC}/avahi-qt3.pc ${PREFIX}/libdata/pkgconfig
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/avahi-qt3/pkg-descr b/net/avahi-qt3/pkg-descr
new file mode 100644
index 000000000000..5ed735799b0e
--- /dev/null
+++ b/net/avahi-qt3/pkg-descr
@@ -0,0 +1,3 @@
+Qt 3 bindings to the avahi mDNS service discovery system.
+
+WWW: http://www.avahi.org/
diff --git a/net/avahi-qt3/pkg-plist b/net/avahi-qt3/pkg-plist
new file mode 100644
index 000000000000..3025b57c0c95
--- /dev/null
+++ b/net/avahi-qt3/pkg-plist
@@ -0,0 +1,7 @@
+include/avahi-qt3/qt-watch.h
+lib/libavahi-qt3.a
+lib/libavahi-qt3.la
+lib/libavahi-qt3.so
+lib/libavahi-qt3.so.1
+libdata/pkgconfig/avahi-qt3.pc
+@dirrm include/avahi-qt3