aboutsummaryrefslogtreecommitdiff
path: root/net/avahi-sharp
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
commit4acc6fb2a411b291c9c210d82bafe7c62e71c77d (patch)
treebc16420eb52d65511ceb520c00171d219210a473 /net/avahi-sharp
parent97dfcc1b41c5b4581b1d73128a866beec069c5bf (diff)
downloadports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.tar.gz
ports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.zip
Notes
Diffstat (limited to 'net/avahi-sharp')
-rw-r--r--net/avahi-sharp/Makefile26
1 files changed, 3 insertions, 23 deletions
diff --git a/net/avahi-sharp/Makefile b/net/avahi-sharp/Makefile
index c488e52cbea7..f4d9e8ea48ff 100644
--- a/net/avahi-sharp/Makefile
+++ b/net/avahi-sharp/Makefile
@@ -17,41 +17,21 @@ LIB_DEPENDS= avahi-core:${PORTSDIR}/net/avahi
BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono
RUN_DEPENDS= mono:${PORTSDIR}/lang/mono
-MASTERDIR= ${.CURDIR}/../avahi
+MASTERDIR= ${.CURDIR}/../avahi-app
BUILD_WRKSRC= ${WRKSRC}/avahi-sharp
INSTALL_WRKSRC= ${BUILD_WRKSRC}
DESCR= ${.CURDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
-AVAHI_SLAVE= yes
-
-USE_GNOME= gnomehack gnometarget
-CONFIGURE_ARGS= --with-distro=freebsd \
- --with-dbus-system-address=unix:path=/var/run/dbus/system_bus_socket \
- --disable-gtk \
- --disable-qt3 \
- --disable-qt4 \
- --disable-python \
- --enable-mono \
- --disable-monodoc \
- --disable-doxygen-doc \
- --disable-doxygen-dot \
- --localstatedir=/var
+AVAHI_SLAVE= sharp
+AVAHI_PKGCONFIG=avahi-sharp.pc
post-patch:
@${REINPLACE_CMD} 's|@CLIENT_DLNAME@|libavahi-client.so|g; \
s|@COMMON_DLNAME@|libavahi-common.so|g; \
s|@GLIB_DLNAME@|libavahi-glib.so|g' \
${BUILD_WRKSRC}/avahi-sharp.dll.config.in
- @${REINPLACE_CMD} 's|@prefix@|${PREFIX}|g; \
- s|@libdir@|$${prefix}/lib|g; \
- s|@PACKAGE_VERSION@|${PORTVERSION}|g' \
- ${WRKSRC}/avahi-sharp.pc.in
- @${CP} ${WRKSRC}/avahi-sharp.pc.in ${WRKSRC}/avahi-sharp.pc
@${CP} ${WRKSRC}/avahi-sharp/avahi-sharp.dll.config.in ${WRKSRC}/avahi-sharp/avahi-sharp.dll.config
-post-install:
- ${INSTALL_DATA} ${WRKSRC}/avahi-sharp.pc ${PREFIX}/libdata/pkgconfig/
-
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include "${MASTERDIR}/Makefile"