aboutsummaryrefslogtreecommitdiff
path: root/net/avahi
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
commit798e9bed2a389dce8a970e15b68176fd49f442db (patch)
tree9dc5597aab073298ec381964f72cd853b3dd366c /net/avahi
parent48b92584b0722f7f6ca412e6cfe16f1381e043cc (diff)
downloadports-798e9bed2a389dce8a970e15b68176fd49f442db.tar.gz
ports-798e9bed2a389dce8a970e15b68176fd49f442db.zip
Notes
Diffstat (limited to 'net/avahi')
-rw-r--r--net/avahi/Makefile13
-rw-r--r--net/avahi/files/patch-Makefile.in20
-rw-r--r--net/avahi/files/patch-avahi-core_socket.c34
-rw-r--r--net/avahi/files/patch-avahi-sharp_Makefile.in16
-rw-r--r--net/avahi/pkg-plist36
5 files changed, 74 insertions, 45 deletions
diff --git a/net/avahi/Makefile b/net/avahi/Makefile
index 5051ee392007..fae5fae41a31 100644
--- a/net/avahi/Makefile
+++ b/net/avahi/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-#
+# $MCom: ports/net/avahi/Makefile,v 1.15 2006/04/28 01:52:15 marcus Exp $
PORTNAME= avahi
PORTVERSION= 0.6.9
-PORTREVISION?= 3
-CATEGORIES= net dns
+PORTREVISION?= 4
+CATEGORIES?= net dns
MASTER_SITES= http://www.avahi.org/download/
MAINTAINER?= gnome@FreeBSD.org
@@ -21,7 +21,7 @@ LIB_DEPENDS?= expat.6:${PORTSDIR}/textproc/expat2 \
USE_GNOME?= gnomehack ltverhack glib20
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
CONFIGURE_ARGS?=--with-distro=freebsd \
--with-dbus-system-address=unix:path=/var/run/dbus/dbus.pipe \
@@ -32,13 +32,16 @@ CONFIGURE_ARGS?=--with-distro=freebsd \
--disable-monodoc \
--disable-doxygen-doc \
--disable-doxygen-dot \
- --localstatedir=/var
+ --localstatedir=/var \
+ --enable-compat-howl \
+ --enable-compat-libdns_sd
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
.if !defined(AVAHI_SLAVE)
+CONFLICTS= howl-[0-9]* mDNSResponder-[0-9]*
MAN1= avahi-browse-domains.1 avahi-browse.1 avahi-publish-address.1 \
avahi-publish-service.1 avahi-publish.1 avahi-resolve-address.1 \
diff --git a/net/avahi/files/patch-Makefile.in b/net/avahi/files/patch-Makefile.in
index 8467b3b3eca8..a117a3b11b5f 100644
--- a/net/avahi/files/patch-Makefile.in
+++ b/net/avahi/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Sun Jan 29 13:36:41 2006
-+++ Makefile.in Sun Jan 29 13:37:37 2006
+--- Makefile.in.orig Mon Jan 30 13:05:47 2006
++++ Makefile.in Mon Jan 30 13:07:36 2006
@@ -1037,6 +1037,8 @@
avahi-core.pc: avahi-core.pc.in
sed -e 's,@prefix\@,$(prefix),g' \
@@ -9,3 +9,19 @@
-e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' $< > $@
@HAVE_DBUS_TRUE@avahi-client.pc: avahi-client.pc.in
+@@ -1047,11 +1049,15 @@
+ @ENABLE_COMPAT_HOWL_TRUE@@HAVE_DBUS_TRUE@avahi-compat-howl.pc: avahi-compat-howl.pc.in
+ @ENABLE_COMPAT_HOWL_TRUE@@HAVE_DBUS_TRUE@ sed -e 's,@prefix\@,$(prefix),g' \
+ @ENABLE_COMPAT_HOWL_TRUE@@HAVE_DBUS_TRUE@ -e 's,@libdir\@,$(libdir),g' \
++@ENABLE_COMPAT_HOWL_TRUE@@HAVE_DBUS_TRUE@ -e 's,@PTHREAD_CFLAGS\@,$(PTHREAD_CFLAGS),g' \
++@ENABLE_COMPAT_HOWL_TRUE@@HAVE_DBUS_TRUE@ -e 's,@PTHREAD_LIBS\@,$(PTHREAD_LIBS),g' \
+ @ENABLE_COMPAT_HOWL_TRUE@@HAVE_DBUS_TRUE@ -e 's,@HOWL_COMPAT_VERSION\@,$(HOWL_COMPAT_VERSION),g' $< > $@
+
+ @ENABLE_COMPAT_LIBDNS_SD_TRUE@@HAVE_DBUS_TRUE@avahi-compat-libdns_sd.pc: avahi-compat-libdns_sd.pc.in
+ @ENABLE_COMPAT_LIBDNS_SD_TRUE@@HAVE_DBUS_TRUE@ sed -e 's,@prefix\@,$(prefix),g' \
+ @ENABLE_COMPAT_LIBDNS_SD_TRUE@@HAVE_DBUS_TRUE@ -e 's,@libdir\@,$(libdir),g' \
++@ENABLE_COMPAT_LIBDNS_SD_TRUE@@HAVE_DBUS_TRUE@ -e 's,@PTHREAD_CFLAGS\@,$(PTHREAD_CFLAGS),g' \
++@ENABLE_COMPAT_LIBDNS_SD_TRUE@@HAVE_DBUS_TRUE@ -e 's,@PTHREAD_LIBS\@,$(PTHREAD_LIBS),g' \
+ @ENABLE_COMPAT_LIBDNS_SD_TRUE@@HAVE_DBUS_TRUE@ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' $< > $@
+
+ @HAVE_DBUS_TRUE@@HAVE_MONO_TRUE@avahi-sharp.pc: avahi-sharp.pc.in
diff --git a/net/avahi/files/patch-avahi-core_socket.c b/net/avahi/files/patch-avahi-core_socket.c
index 783d41c02f35..dc19ed3795be 100644
--- a/net/avahi/files/patch-avahi-core_socket.c
+++ b/net/avahi/files/patch-avahi-core_socket.c
@@ -1,38 +1,28 @@
---- avahi-core/socket.c.orig Sun Apr 23 19:20:31 2006
-+++ avahi-core/socket.c Sun Apr 23 20:16:46 2006
+--- avahi-core/socket.c.orig Thu Feb 9 20:45:09 2006
++++ avahi-core/socket.c Mon Apr 24 17:14:18 2006
@@ -468,7 +468,7 @@ int avahi_send_dns_packet_ipv4(int fd, A
size_t cmsg_data[( CMSG_SPACE(sizeof(struct in_pktinfo)) / sizeof(size_t)) + 1];
#elif defined(IP_SENDSRCADDR)
struct cmsghdr *cmsg;
- size_t cmsg_data[( CMSG_SPACE(sizeof(struct in_addr)) / sizeof(size_t)) + 1];
-+ char cmsg_data[CMSG_SPACE(sizeof(struct in_addr))];
++ uint8_t cmsg_data[CMSG_SPACE(sizeof(struct in_addr))];
#endif
assert(fd >= 0);
-@@ -491,8 +491,8 @@ int avahi_send_dns_packet_ipv4(int fd, A
- msg.msg_iov = &io;
- msg.msg_iovlen = 1;
- msg.msg_flags = 0;
-- msg.msg_control = NULL;
-- msg.msg_controllen = 0;
-+ msg.msg_control = cmsg_data;
-+ msg.msg_controllen = sizeof(cmsg_data);
-
- #ifdef IP_PKTINFO
- if (interface > 0 || src_address) {
-@@ -518,18 +518,15 @@ int avahi_send_dns_packet_ipv4(int fd, A
+@@ -518,18 +518,17 @@ int avahi_send_dns_packet_ipv4(int fd, A
#elif defined(IP_SENDSRCADDR)
if (src_address) {
struct in_addr *addr;
+
++ msg.msg_control = cmsg_data;
++ msg.msg_controllen = sizeof(cmsg_data);
+ cmsg = CMSG_FIRSTHDR(&msg);
- memset(cmsg_data, 0, sizeof(cmsg_data));
- cmsg = (struct cmsghdr*) cmsg_data;
-- cmsg->cmsg_len = CMSG_LEN(sizeof(struct in_addr));
+ cmsg->cmsg_len = CMSG_LEN(sizeof(struct in_addr));
cmsg->cmsg_level = IPPROTO_IP;
cmsg->cmsg_type = IP_SENDSRCADDR;
-+ cmsg->cmsg_len = CMSG_LEN(sizeof(struct in_addr));
addr = (struct in_addr *)CMSG_DATA(cmsg);
addr->s_addr = src_address->address;
@@ -42,30 +32,30 @@
}
#elif defined(IP_MULTICAST_IF)
{
-@@ -551,7 +548,7 @@ int avahi_send_dns_packet_ipv6(int fd, A
+@@ -551,7 +550,7 @@ int avahi_send_dns_packet_ipv6(int fd, A
struct msghdr msg;
struct iovec io;
struct cmsghdr *cmsg;
- size_t cmsg_data[(CMSG_SPACE(sizeof(struct in6_pktinfo))/sizeof(size_t)) + 1];
-+ char cmsg_data[CMSG_SPACE(sizeof(struct in6_pktinfo))];
++ uint8_t cmsg_data[CMSG_SPACE(sizeof(struct in6_pktinfo))];
assert(fd >= 0);
assert(p);
-@@ -576,9 +573,11 @@ int avahi_send_dns_packet_ipv6(int fd, A
+@@ -576,9 +575,11 @@ int avahi_send_dns_packet_ipv6(int fd, A
if (interface > 0 || src_address) {
struct in6_pktinfo *pkti;
+
+ msg.msg_control = cmsg_data;
+ msg.msg_controllen = sizeof(cmsg_data);
-+ cmsg = CMSG_FIRSTHDR(&msg);
++ cmsg = CMSG_FIRSTHDR(&msg);
- memset(cmsg_data, 0, sizeof(cmsg_data));
- cmsg = (struct cmsghdr*) cmsg_data;
cmsg->cmsg_len = CMSG_LEN(sizeof(struct in6_pktinfo));
cmsg->cmsg_level = IPPROTO_IPV6;
cmsg->cmsg_type = IPV6_PKTINFO;
-@@ -591,8 +590,6 @@ int avahi_send_dns_packet_ipv6(int fd, A
+@@ -591,8 +592,6 @@ int avahi_send_dns_packet_ipv6(int fd, A
if (src_address)
memcpy(&pkti->ipi6_addr, src_address->address, sizeof(src_address->address));
diff --git a/net/avahi/files/patch-avahi-sharp_Makefile.in b/net/avahi/files/patch-avahi-sharp_Makefile.in
deleted file mode 100644
index 45c44adbea75..000000000000
--- a/net/avahi/files/patch-avahi-sharp_Makefile.in
+++ /dev/null
@@ -1,16 +0,0 @@
---- avahi-sharp/Makefile.in.orig Tue Feb 7 23:04:12 2006
-+++ avahi-sharp/Makefile.in Tue Feb 7 23:25:30 2006
-@@ -573,10 +573,10 @@
- $(ASSEMBLY): $(AVAHISOURCES)
- mcs -keyfile:$(srcdir)/avahi.snk -target:library -out:$@ -debug $(AVAHISOURCES) -r:Mono.Posix
-
- $(ASSEMBLY).config: $(ASSEMBLY).config.in
-- $(srcdir)/gencfg.sh $(top_builddir)/avahi-client/libavahi-client.la \
-- $(top_builddir)/avahi-common/libavahi-common.la \
-- $(top_builddir)/avahi-glib/libavahi-glib.la < $< > $@
-+# $(srcdir)/gencfg.sh $(top_builddir)/avahi-client/libavahi-client.la \
-+# $(top_builddir)/avahi-common/libavahi-common.la \
-+# $(top_builddir)/avahi-glib/libavahi-glib.la < $< > $@
-
- @HAVE_DBUS_TRUE@@HAVE_MONO_TRUE@all: $(ASSEMBLY) $(ASSEMBLY).config
-
diff --git a/net/avahi/pkg-plist b/net/avahi/pkg-plist
index 62470d47895c..52fb63b9b0e2 100644
--- a/net/avahi/pkg-plist
+++ b/net/avahi/pkg-plist
@@ -32,6 +32,26 @@ include/avahi-common/strlst.h
include/avahi-common/thread-watch.h
include/avahi-common/timeval.h
include/avahi-common/watch.h
+include/avahi-compat-howl/corby/buffer.h
+include/avahi-compat-howl/corby/channel.h
+include/avahi-compat-howl/corby/corby.h
+include/avahi-compat-howl/corby/message.h
+include/avahi-compat-howl/corby/object.h
+include/avahi-compat-howl/corby/orb.h
+include/avahi-compat-howl/discovery/discovery.h
+include/avahi-compat-howl/discovery/text_record.h
+include/avahi-compat-howl/howl.h
+include/avahi-compat-howl/rendezvous/rendezvous.h
+include/avahi-compat-howl/rendezvous/text_record.h
+include/avahi-compat-howl/salt/address.h
+include/avahi-compat-howl/salt/debug.h
+include/avahi-compat-howl/salt/interface.h
+include/avahi-compat-howl/salt/platform.h
+include/avahi-compat-howl/salt/salt.h
+include/avahi-compat-howl/salt/signal.h
+include/avahi-compat-howl/salt/socket.h
+include/avahi-compat-howl/salt/time.h
+include/avahi-compat-libdns_sd/dns_sd.h
include/avahi-core/core.h
include/avahi-core/log.h
include/avahi-core/lookup.h
@@ -55,7 +75,17 @@ lib/libavahi-glib.a
lib/libavahi-glib.la
lib/libavahi-glib.so
lib/libavahi-glib.so.1
+lib/libdns_sd.a
+lib/libdns_sd.la
+lib/libdns_sd.so
+lib/libdns_sd.so.1
+lib/libhowl.a
+lib/libhowl.la
+lib/libhowl.so
+lib/libhowl.so.0
libdata/pkgconfig/avahi-client.pc
+libdata/pkgconfig/avahi-compat-howl.pc
+libdata/pkgconfig/avahi-compat-libdns_sd.pc
libdata/pkgconfig/avahi-core.pc
libdata/pkgconfig/avahi-glib.pc
sbin/avahi-daemon
@@ -77,6 +107,12 @@ sbin/avahi-dnsconfd
@dirrm %%DATADIR%%
@dirrm include/avahi-glib
@dirrm include/avahi-core
+@dirrm include/avahi-compat-libdns_sd
+@dirrm include/avahi-compat-howl/salt
+@dirrm include/avahi-compat-howl/rendezvous
+@dirrm include/avahi-compat-howl/discovery
+@dirrm include/avahi-compat-howl/corby
+@dirrm include/avahi-compat-howl
@dirrm include/avahi-common
@dirrm include/avahi-client
@dirrm etc/avahi/services