aboutsummaryrefslogtreecommitdiff
path: root/net/avahi
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-06-23 17:55:55 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-06-23 17:55:55 +0000
commit61d55715f62cae94c061e7f512bc43f0fa2a90b2 (patch)
tree80a21d5254e8618128dc0c6a6383f09918022aa8 /net/avahi
parentf93ff365de7fce2e52028c1c414c0ca82595fd17 (diff)
downloadports-61d55715f62cae94c061e7f512bc43f0fa2a90b2.tar.gz
ports-61d55715f62cae94c061e7f512bc43f0fa2a90b2.zip
Notes
Diffstat (limited to 'net/avahi')
-rw-r--r--net/avahi/Makefile4
-rw-r--r--net/avahi/distinfo6
-rw-r--r--net/avahi/files/patch-avahi-core_fdutil.c10
-rw-r--r--net/avahi/files/patch-configure14
4 files changed, 26 insertions, 8 deletions
diff --git a/net/avahi/Makefile b/net/avahi/Makefile
index 6b7932eeee58..84f4212f736d 100644
--- a/net/avahi/Makefile
+++ b/net/avahi/Makefile
@@ -6,7 +6,7 @@
# $MCom: ports/net/avahi/Makefile,v 1.19 2006/10/12 16:44:41 marcus Exp $
PORTNAME= avahi
-PORTVERSION= 0.6.19
+PORTVERSION= 0.6.20
PORTREVISION?= 0
CATEGORIES?= net dns
MASTER_SITES= http://www.avahi.org/download/
@@ -15,7 +15,7 @@ MAINTAINER?= gnome@FreeBSD.org
COMMENT?= Service discovery on a local network
LIB_DEPENDS?= expat.6:${PORTSDIR}/textproc/expat2 \
- daemon.2:${PORTSDIR}/devel/libdaemon \
+ daemon.0:${PORTSDIR}/devel/libdaemon \
dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
gdbm.3:${PORTSDIR}/databases/gdbm
diff --git a/net/avahi/distinfo b/net/avahi/distinfo
index 43035bdc4cae..b17ca775e383 100644
--- a/net/avahi/distinfo
+++ b/net/avahi/distinfo
@@ -1,3 +1,3 @@
-MD5 (avahi-0.6.19.tar.gz) = a06782435d1c994ecd00a66e95a5d9d4
-SHA256 (avahi-0.6.19.tar.gz) = a742dceda38f242f5eac72f2c3bc1bda76adf497d6913e88a9cbc624bf2dd68a
-SIZE (avahi-0.6.19.tar.gz) = 973381
+MD5 (avahi-0.6.20.tar.gz) = 6acdff79afa2631f765f3bbbc3e25a74
+SHA256 (avahi-0.6.20.tar.gz) = 89ae5fd08018679b80cee201e1c1350d86db73bdcf6718aabb4bd3ea86f93ec9
+SIZE (avahi-0.6.20.tar.gz) = 974209
diff --git a/net/avahi/files/patch-avahi-core_fdutil.c b/net/avahi/files/patch-avahi-core_fdutil.c
new file mode 100644
index 000000000000..9ca63b133b59
--- /dev/null
+++ b/net/avahi/files/patch-avahi-core_fdutil.c
@@ -0,0 +1,10 @@
+--- avahi-core/fdutil.c.orig Sat Jun 23 02:09:02 2007
++++ avahi-core/fdutil.c Sat Jun 23 02:09:37 2007
+@@ -23,6 +23,7 @@
+ #include <config.h>
+ #endif
+
++#include <sys/select.h>
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <assert.h>
diff --git a/net/avahi/files/patch-configure b/net/avahi/files/patch-configure
index ab78027c62fc..141c9403f76b 100644
--- a/net/avahi/files/patch-configure
+++ b/net/avahi/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Sun Sep 3 12:31:45 2006
-+++ configure Sun Sep 3 12:32:34 2006
-@@ -20559,6 +20559,7 @@ echo $ECHO_N "checking whether to check
+--- configure.orig Sat Jun 23 02:05:47 2007
++++ configure Sat Jun 23 02:13:52 2007
+@@ -20338,6 +20338,7 @@ echo $ECHO_N "checking whether to check
check_inconsistencies=yes
case "${host_cpu}-${host_os}" in
*-darwin*) check_inconsistencies=no ;;
@@ -8,3 +8,11 @@
esac
if test x"$GCC" != xyes -o "x$check_inconsistencies" != xyes ; then
{ echo "$as_me:$LINENO: result: no" >&5
+@@ -22442,6 +22443,7 @@ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ $ac_includes_default
++#include <sys/socket.h>
+ int
+ main ()
+ {