aboutsummaryrefslogtreecommitdiff
path: root/net/avahi
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
commit4acc6fb2a411b291c9c210d82bafe7c62e71c77d (patch)
treebc16420eb52d65511ceb520c00171d219210a473 /net/avahi
parent97dfcc1b41c5b4581b1d73128a866beec069c5bf (diff)
downloadports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.tar.gz
ports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.zip
Notes
Diffstat (limited to 'net/avahi')
-rw-r--r--net/avahi/Makefile110
-rw-r--r--net/avahi/distinfo3
-rw-r--r--net/avahi/files/patch-Makefile.in50
-rw-r--r--net/avahi/files/patch-avahi-client.pc.in10
-rw-r--r--net/avahi/files/patch-avahi-common_dbus-watch-glue.c14
-rw-r--r--net/avahi/files/patch-avahi-compat-howl.pc.in10
-rw-r--r--net/avahi/files/patch-avahi-compat-libdns_sd.pc.in10
-rw-r--r--net/avahi/files/patch-avahi-core.pc.in10
-rw-r--r--net/avahi/files/patch-avahi-daemon_main.c14
-rw-r--r--net/avahi/files/patch-avahi-glib.pc.in10
-rw-r--r--net/avahi/files/patch-avahi-qt3.pc.in10
-rw-r--r--net/avahi/files/patch-avahi-qt_Makefile.in36
-rw-r--r--net/avahi/files/patch-configure18
-rw-r--r--net/avahi/files/patch-initscript_freebsd_avahi-daemon.sh.in17
-rw-r--r--net/avahi/files/patch-initscript_freebsd_avahi-dnsconfd.sh.in17
-rw-r--r--net/avahi/files/patch-man_Makefile.in11
-rw-r--r--net/avahi/pkg-install36
-rw-r--r--net/avahi/pkg-plist133
18 files changed, 36 insertions, 483 deletions
diff --git a/net/avahi/Makefile b/net/avahi/Makefile
index 5a509b3cb7eb..e90d5a8c6ab0 100644
--- a/net/avahi/Makefile
+++ b/net/avahi/Makefile
@@ -3,101 +3,63 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/net/avahi/Makefile,v 1.19 2006/10/12 16:44:41 marcus Exp $
+# $MCom: ports/net/avahi/Makefile,v 1.26 2007/09/09 22:45:27 mezz Exp $
+#
PORTNAME= avahi
PORTVERSION= 0.6.21
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= net dns
-MASTER_SITES= http://www.avahi.org/download/
-
-MAINTAINER?= gnome@FreeBSD.org
-COMMENT?= Service discovery on a local network
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
-LIB_DEPENDS?= expat.6:${PORTSDIR}/textproc/expat2 \
- daemon.0:${PORTSDIR}/devel/libdaemon \
- dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- gdbm.3:${PORTSDIR}/databases/gdbm
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= The "meta-port" for the Avahi service discovery suite
-USE_GNOME?= gnomehack ltverhack glib20
-USE_GNOME_SUBR=yes
-USE_RC_SUBR= yes
-USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
-USE_LDCONFIG= yes
-USE_GETOPT_LONG=yes
-CONFIGURE_ARGS?=--with-distro=freebsd \
- --with-dbus-system-address=unix:path=/var/run/dbus/system_bus_socket \
- --disable-qt3 \
- --disable-qt4 \
- --disable-python \
- --disable-mono \
- --disable-monodoc \
- --disable-doxygen-doc \
- --disable-doxygen-dot \
- --localstatedir=/var \
- --enable-compat-howl \
- --disable-autoipd
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DHAVE_KQUEUE" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
+RUN_DEPENDS= avahi-resolve:${PORTSDIR}/net/avahi-app \
+ avahi-app>=0.6.20_2:${PORTSDIR}/net/avahi-app
-.if !defined(AVAHI_SLAVE)
-CONFLICTS= howl-[0-9]*
+OPTIONS= AUTOIPD "IPv4LL network address configuration daemon" off \
+ GTK "Gtk+ tools and bindings" off \
+ LIBDNS "mDNSResponder compatibility" off \
+ MONO "Mono bindings" off \
+ QT3 "Qt 3 bindings" off \
+ QT4 "Qt 4 bindings" off \
+ PYTHON "Python bindings and tools" off
-MAN1= avahi-browse.1 avahi-publish.1 avahi-resolve.1 avahi-set-host-name.1
-MAN5= avahi-daemon.conf.5 avahi.service.5 avahi.hosts.5
-MAN8= avahi-daemon.8 avahi-dnsconfd.8 avahi-dnsconfd.action.8
+NO_BUILD= yes
-MLINKS= avahi-browse.1 avahi-browse-domains.1 \
- avahi-publish.1 avahi-publish-address.1 \
- avahi-publish.1 avahi-publish-service.1 \
- avahi-resolve.1 avahi-resolve-address.1 \
- avahi-resolve.1 avahi-resolve-host-name.1
+.include <bsd.port.pre.mk>
-OPTIONS= GTK2 "Build a GTK+ 2 browser utility and other tools" off \
- LIBDNS "Enable mDNSResponder compatibility" off
+.if defined(WITH_AUTOIPD)
+RUN_DEPENDS+= avahi-autoipd:${PORTSDIR}/net/avahi-autoipd
.endif
-.include <bsd.port.pre.mk>
+.if defined(WITH_GTK)
+RUN_DEPENDS+= avahi-discover-standalone:${PORTSDIR}/net/avahi-gtk
+.endif
-.if !defined(AVAHI_SLAVE)
.if defined(WITH_LIBDNS)
-CONFIGURE_ARGS+=--enable-compat-libdns_sd
-PLIST_SUB+= LIBDNS=""
-CONFLICTS+= mDNSResponder-[0-9]*
-PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+libdns
-.else
-CONFIGURE_ARGS+=--disable-compat-libdns_sd
-PLIST_SUB+= LIBDNS="@comment "
+RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/avahi-compat-libdns_sd.pc:${PORTSDIR}/net/avahi-libdns
.endif
-.if defined(WITH_GTK2)
-USE_GNOME+= libglade2
-PLIST_SUB+= GTK=""
-MAN1+= bssh.1
-MLINKS+= bssh.1 bvnc.1
-.else
-CONFIGURE_ARGS+=--disable-gtk
-PLIST_SUB+= GTK="@comment "
+.if defined(WITH_MONO)
+RUN_DEPENDS+= ${LOCALBASE}/lib/mono/avahi-sharp/avahi-sharp.dll:${PORTSDIR}/net/avahi-sharp
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|-ldl||g ; s|netdev|network|g' \
- ${WRKSRC}/configure \
- ${WRKSRC}/avahi-client/Makefile.in \
- ${WRKSRC}/avahi-daemon/Makefile.in
- @${REINPLACE_CMD} -e 's|%%RC_SUBR%%|${RC_SUBR}| ; \
- s|%%GNOME_SUBR%%|${GNOME_SUBR}|' \
- ${WRKSRC}/initscript/freebsd/avahi-dnsconfd.sh.in \
- ${WRKSRC}/initscript/freebsd/avahi-daemon.sh.in
+.if defined(WITH_QT3)
+RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/avahi-qt3.pc:${PORTSDIR}/net/avahi-qt3
+.endif
-post-install:
-.if !defined(PACKAGE_BUILDING)
- @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.if defined(WITH_QT4)
+RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/avahi-qt4.pc:${PORTSDIR}/net/avahi-qt4
.endif
+.if defined(WITH_PYTHON)
+RUN_DEPENDS+= avahi-bookmarks:${PORTSDIR}/net/py-avahi
.endif
+do-install:
+
.include <bsd.port.post.mk>
diff --git a/net/avahi/distinfo b/net/avahi/distinfo
deleted file mode 100644
index 2600f64c27fe..000000000000
--- a/net/avahi/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (avahi-0.6.21.tar.gz) = 9cc68f79c50c9dd9e419990c3c9b05b9
-SHA256 (avahi-0.6.21.tar.gz) = d817c35f43011861476eab02eea14edd123b2bc58b4408d9d9b69b0c39252561
-SIZE (avahi-0.6.21.tar.gz) = 976841
diff --git a/net/avahi/files/patch-Makefile.in b/net/avahi/files/patch-Makefile.in
deleted file mode 100644
index 9c28621038bd..000000000000
--- a/net/avahi/files/patch-Makefile.in
+++ /dev/null
@@ -1,50 +0,0 @@
---- Makefile.in.orig Wed Oct 11 01:31:58 2006
-+++ Makefile.in Wed Oct 11 01:34:55 2006
-@@ -1057,21 +1056,29 @@ uninstall-info: uninstall-info-recursive
- avahi-core.pc: avahi-core.pc.in
- sed -e 's,@prefix\@,$(prefix),g' \
- -e 's,@libdir\@,$(libdir),g' \
-+ -e 's,@PTHREAD_LIBS\@,$(PTHREAD_LIBS),g' \
-+ -e 's,@PTHREAD_CFLAGS\@,$(PTHREAD_CFLAGS),g' \
- -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' $< > $@
-
- @HAVE_DBUS_TRUE@avahi-client.pc: avahi-client.pc.in
- @HAVE_DBUS_TRUE@ sed -e 's,@prefix\@,$(prefix),g' \
- @HAVE_DBUS_TRUE@ -e 's,@libdir\@,$(libdir),g' \
-+@HAVE_DBUS_TRUE@ -e 's,@PTHREAD_CFLAGS\@,$(PTHREAD_CFLAGS),g' \
-+@HAVE_DBUS_TRUE@ -e 's,@PTHREAD_LIBS\@,$(PTHREAD_LIBS),g' \
- @HAVE_DBUS_TRUE@ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' $< > $@
-
- @ENABLE_COMPAT_HOWL_TRUE@@HAVE_DBUS_TRUE@avahi-compat-howl.pc: avahi-compat-howl.pc.in
- @ENABLE_COMPAT_HOWL_TRUE@@HAVE_DBUS_TRUE@ sed -e 's,@prefix\@,$(prefix),g' \
- @ENABLE_COMPAT_HOWL_TRUE@@HAVE_DBUS_TRUE@ -e 's,@libdir\@,$(libdir),g' \
-+@ENABLE_COMPAT_HOWL_TRUE@@HAVE_DBUS_TRUE@ -e 's,@PTHREAD_CFLAGS\@,$(PTHREAD_CFLAGS),g' \
-+@ENABLE_COMPAT_HOWL_TRUE@@HAVE_DBUS_TRUE@ -e 's,@PTHREAD_LIBS\@,$(PTHREAD_LIBS),g' \
- @ENABLE_COMPAT_HOWL_TRUE@@HAVE_DBUS_TRUE@ -e 's,@HOWL_COMPAT_VERSION\@,$(HOWL_COMPAT_VERSION),g' $< > $@
-
- @ENABLE_COMPAT_LIBDNS_SD_TRUE@@HAVE_DBUS_TRUE@avahi-compat-libdns_sd.pc: avahi-compat-libdns_sd.pc.in
- @ENABLE_COMPAT_LIBDNS_SD_TRUE@@HAVE_DBUS_TRUE@ sed -e 's,@prefix\@,$(prefix),g' \
- @ENABLE_COMPAT_LIBDNS_SD_TRUE@@HAVE_DBUS_TRUE@ -e 's,@libdir\@,$(libdir),g' \
-+@ENABLE_COMPAT_LIBDNS_SD_TRUE@@HAVE_DBUS_TRUE@ -e 's,@PTHREAD_CFLAGS\@,$(PTHREAD_CFLAGS),g' \
-+@ENABLE_COMPAT_LIBDNS_SD_TRUE@@HAVE_DBUS_TRUE@ -e 's,@PTHREAD_LIBS\@,$(PTHREAD_LIBS),g' \
- @ENABLE_COMPAT_LIBDNS_SD_TRUE@@HAVE_DBUS_TRUE@ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' $< > $@
-
- @HAVE_DBUS_TRUE@@HAVE_MONO_TRUE@avahi-sharp.pc: avahi-sharp.pc.in
-@@ -1096,6 +1104,8 @@
- @HAVE_GLIB_TRUE@avahi-glib.pc: avahi-glib.pc.in
- @HAVE_GLIB_TRUE@ sed -e 's,@prefix\@,$(prefix),g' \
- @HAVE_GLIB_TRUE@ -e 's,@libdir\@,$(libdir),g' \
-+@HAVE_GLIB_TRUE@ -e 's,@PTHREAD_CFLAGS\@,$(PTHREAD_CFLAGS),g' \
-+@HAVE_GLIB_TRUE@ -e 's,@PTHREAD_LIBS\@,$(PTHREAD_LIBS),g' \
- @HAVE_GLIB_TRUE@ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' $< > $@
-
- @HAVE_DBUS_TRUE@@HAVE_GTK_TRUE@avahi-ui.pc: avahi-ui.pc.in
-@@ -1106,6 +1116,8 @@
- @HAVE_QT3_TRUE@avahi-qt3.pc: avahi-qt3.pc.in
- @HAVE_QT3_TRUE@ sed -e 's,@prefix\@,$(prefix),g' \
- @HAVE_QT3_TRUE@ -e 's,@libdir\@,$(libdir),g' \
-+@HAVE_QT3_TRUE@ -e 's,@PTHREAD_CFLAGS\@,$(PTHREAD_CFLAGS),g' \
-+@HAVE_QT3_TRUE@ -e 's,@PTHREAD_LIBS\@,$(PTHREAD_LIBS),g' \
- @HAVE_QT3_TRUE@ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' $< > $@
-
- @HAVE_QT4_TRUE@avahi-qt4.pc: avahi-qt4.pc.in
diff --git a/net/avahi/files/patch-avahi-client.pc.in b/net/avahi/files/patch-avahi-client.pc.in
deleted file mode 100644
index e980e52e0fe2..000000000000
--- a/net/avahi/files/patch-avahi-client.pc.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- avahi-client.pc.in.orig Mon May 15 02:28:25 2006
-+++ avahi-client.pc.in Mon May 15 02:30:08 2006
-@@ -6,5 +6,5 @@
- Name: avahi-client
- Description: Avahi Multicast DNS Responder (Client Support)
- Version: @PACKAGE_VERSION@
--Libs: -L${libdir} -lavahi-common -lavahi-client
--Cflags: -D_REENTRANT -I${includedir}
-+Libs: -L${libdir} -lavahi-common -lavahi-client @PTHREAD_LIBS@
-+Cflags: -D_REENTRANT @PTHREAD_CFLAGS@ -I${includedir}
diff --git a/net/avahi/files/patch-avahi-common_dbus-watch-glue.c b/net/avahi/files/patch-avahi-common_dbus-watch-glue.c
deleted file mode 100644
index 1e148af8564c..000000000000
--- a/net/avahi/files/patch-avahi-common_dbus-watch-glue.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- avahi-common/dbus-watch-glue.c.orig 2007-08-26 00:46:45.000000000 -0400
-+++ avahi-common/dbus-watch-glue.c 2007-08-26 00:47:12.000000000 -0400
-@@ -134,7 +134,11 @@ static dbus_bool_t update_watch(const Av
-
- if (!(avahi_watch = poll_api->watch_new(
- poll_api,
-+#if (DBUS_VERSION_MAJOR == 1 && DBUS_VERSION_MINOR == 1 && DBUS_VERSION_MICRO >= 1) || (DBUS_VERSION_MAJOR == 1 && DBUS_VERSION_MAJOR > 1) || (DBUS_VERSION_MAJOR > 1)
- dbus_watch_get_unix_fd(dbus_watch),
-+#else
-+ dbus_watch_get_fd(dbus_watch),
-+#endif
- translate_dbus_to_avahi(dbus_watch_get_flags(dbus_watch)),
- watch_callback,
- dbus_watch)))
diff --git a/net/avahi/files/patch-avahi-compat-howl.pc.in b/net/avahi/files/patch-avahi-compat-howl.pc.in
deleted file mode 100644
index f101cc1da5e3..000000000000
--- a/net/avahi/files/patch-avahi-compat-howl.pc.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- avahi-compat-howl.pc.in.orig Sun Jan 29 13:32:39 2006
-+++ avahi-compat-howl.pc.in Sun Jan 29 13:32:56 2006
-@@ -6,5 +6,5 @@
- Name: avahi-compat-howl
- Description: Avahi Multicast DNS Responder (HOWL Compatibility)
- Version: @HOWL_COMPAT_VERSION@
--Libs: -L${libdir} -lhowl
--Cflags: -D_REENTRANT -I${includedir}
-+Libs: -L${libdir} -lhowl @PTHREAD_LIBS@
-+Cflags: -D_REENTRANT @PTHREAD_CFLAGS@ -I${includedir}
diff --git a/net/avahi/files/patch-avahi-compat-libdns_sd.pc.in b/net/avahi/files/patch-avahi-compat-libdns_sd.pc.in
deleted file mode 100644
index 8487c1b5a298..000000000000
--- a/net/avahi/files/patch-avahi-compat-libdns_sd.pc.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- avahi-compat-libdns_sd.pc.in.orig Sun Jan 29 13:33:21 2006
-+++ avahi-compat-libdns_sd.pc.in Sun Jan 29 13:33:40 2006
-@@ -6,5 +6,5 @@
- Name: avahi-compat-libdns_sd
- Description: Avahi Multicast DNS Responder (libdns_sd Compatibility)
- Version: @PACKAGE_VERSION@
--Libs: -L${libdir} -ldns_sd
--Cflags: -D_REENTRANT -I${includedir}
-+Libs: -L${libdir} -ldns_sd @PTHREAD_LIBS@
-+Cflags: -D_REENTRANT @PTHREAD_CFLAGS@ -I${includedir}
diff --git a/net/avahi/files/patch-avahi-core.pc.in b/net/avahi/files/patch-avahi-core.pc.in
deleted file mode 100644
index fdde41be9c53..000000000000
--- a/net/avahi/files/patch-avahi-core.pc.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- avahi-core.pc.in.orig Sun Jan 29 13:31:30 2006
-+++ avahi-core.pc.in Sun Jan 29 13:31:48 2006
-@@ -6,5 +6,5 @@
- Name: avahi-core
- Description: Avahi Multicast DNS Responder (Embeddable Stack)
- Version: @PACKAGE_VERSION@
--Libs: -L${libdir} -lavahi-common -lavahi-core
--Cflags: -D_REENTRANT -I${includedir}
-+Libs: -L${libdir} -lavahi-common -lavahi-core @PTHREAD_LIBS@
-+Cflags: -D_REENTRANT @PTHREAD_CFLAGS@ -I${includedir}
diff --git a/net/avahi/files/patch-avahi-daemon_main.c b/net/avahi/files/patch-avahi-daemon_main.c
deleted file mode 100644
index c95ab399fe7e..000000000000
--- a/net/avahi/files/patch-avahi-daemon_main.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- avahi-daemon/main.c.orig 2007-08-26 00:48:40.000000000 -0400
-+++ avahi-daemon/main.c 2007-08-26 00:49:04.000000000 -0400
-@@ -317,6 +317,11 @@ static void update_browse_domains(void)
- int n;
- char **p;
-
-+ if (!resolv_conf_search_domains) {
-+ avahi_server_set_browse_domains(avahi_server, NULL);
-+ return;
-+ }
-+
- l = avahi_string_list_copy(config.server_config.browse_domains);
-
- for (p = resolv_conf_search_domains, n = 0; *p && n < BROWSE_DOMAINS_MAX; p++, n++) {
diff --git a/net/avahi/files/patch-avahi-glib.pc.in b/net/avahi/files/patch-avahi-glib.pc.in
deleted file mode 100644
index e2633c32db44..000000000000
--- a/net/avahi/files/patch-avahi-glib.pc.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- avahi-glib.pc.in.orig Mon May 15 02:31:01 2006
-+++ avahi-glib.pc.in Mon May 15 02:31:25 2006
-@@ -7,5 +7,5 @@
- Description: Avahi Multicast DNS Responder (GLib Support)
- Version: @PACKAGE_VERSION@
- Requires: glib-2.0
--Libs: -L${libdir} -lavahi-glib
--Cflags: -D_REENTRANT -I${includedir}
-+Libs: -L${libdir} -lavahi-glib @PTHREAD_LIBS@
-+Cflags: -D_REENTRANT @PTHREAD_CFLAGS@ -I${includedir}
diff --git a/net/avahi/files/patch-avahi-qt3.pc.in b/net/avahi/files/patch-avahi-qt3.pc.in
deleted file mode 100644
index 8174f25846d8..000000000000
--- a/net/avahi/files/patch-avahi-qt3.pc.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- avahi-qt3.pc.in.orig Thu Apr 12 00:18:53 2007
-+++ avahi-qt3.pc.in Thu Apr 12 00:19:20 2007
-@@ -7,5 +7,5 @@ Name: avahi-qt3
- Description: Avahi Multicast DNS Responder (QT3 Support)
- Version: @PACKAGE_VERSION@
- Requires.private: qt-mt >= 3.0.0
--Libs: -L${libdir} -lavahi-qt3
--Cflags: -D_REENTRANT -I${includedir}
-+Libs: -L${libdir} -lavahi-qt3 @PTHREAD_LIBS@
-+Cflags: -D_REENTRANT @PTHREAD_CFLAGS@ -I${includedir}
diff --git a/net/avahi/files/patch-avahi-qt_Makefile.in b/net/avahi/files/patch-avahi-qt_Makefile.in
deleted file mode 100644
index 5788e2399dd5..000000000000
--- a/net/avahi/files/patch-avahi-qt_Makefile.in
+++ /dev/null
@@ -1,36 +0,0 @@
---- avahi-qt/Makefile.in.orig Thu Apr 12 00:16:01 2007
-+++ avahi-qt/Makefile.in Thu Apr 12 00:17:25 2007
-@@ -90,7 +90,6 @@ libLTLIBRARIES_INSTALL = $(INSTALL)
- LTLIBRARIES = $(lib_LTLIBRARIES)
- am__DEPENDENCIES_1 =
- @HAVE_QT3_TRUE@libavahi_qt3_la_DEPENDENCIES = \
--@HAVE_QT3_TRUE@ ../avahi-common/libavahi-common.la \
- @HAVE_QT3_TRUE@ $(am__DEPENDENCIES_1)
- am__libavahi_qt3_la_SOURCES_DIST = qt-watch.cpp
- @HAVE_QT3_TRUE@am_libavahi_qt3_la_OBJECTS = \
-@@ -98,7 +97,6 @@ am__libavahi_qt3_la_SOURCES_DIST = qt-wa
- libavahi_qt3_la_OBJECTS = $(am_libavahi_qt3_la_OBJECTS)
- @HAVE_QT3_TRUE@am_libavahi_qt3_la_rpath = -rpath $(libdir)
- @HAVE_QT4_TRUE@libavahi_qt4_la_DEPENDENCIES = \
--@HAVE_QT4_TRUE@ ../avahi-common/libavahi-common.la \
- @HAVE_QT4_TRUE@ $(am__DEPENDENCIES_1)
- am__libavahi_qt4_la_SOURCES_DIST = qt-watch.cpp
- @HAVE_QT4_TRUE@am_libavahi_qt4_la_OBJECTS = \
-@@ -418,7 +416,7 @@ BUILT_SOURCES = $(am__append_2) $(am__ap
- @HAVE_QT3_TRUE@ qt-watch.cpp
-
- @HAVE_QT3_TRUE@libavahi_qt3_la_CPPFLAGS = $(AM_CFLAGS) $(QT3_CFLAGS)
--@HAVE_QT3_TRUE@libavahi_qt3_la_LIBADD = $(AM_LDADD) ../avahi-common/libavahi-common.la $(QT3_LIBS)
-+@HAVE_QT3_TRUE@libavahi_qt3_la_LIBADD = $(AM_LDADD) -lavahi-common $(QT3_LIBS)
- @HAVE_QT3_TRUE@libavahi_qt3_la_LDFLAGS = $(AM_LDFLAGS) -export-dynamic -version-info $(LIBAVAHI_QT3_VERSION_INFO)
- @HAVE_QT4_TRUE@avahiqt4includedir = $(includedir)/avahi-qt4
- @HAVE_QT4_TRUE@avahiqt4include_HEADERS = \
-@@ -428,7 +426,7 @@ BUILT_SOURCES = $(am__append_2) $(am__ap
- @HAVE_QT4_TRUE@ qt-watch.cpp
-
- @HAVE_QT4_TRUE@libavahi_qt4_la_CPPFLAGS = $(AM_CFLAGS) $(QT4_CFLAGS) -DQT4
--@HAVE_QT4_TRUE@libavahi_qt4_la_LIBADD = $(AM_LDADD) ../avahi-common/libavahi-common.la $(QT4_LIBS)
-+@HAVE_QT4_TRUE@libavahi_qt4_la_LIBADD = $(AM_LDADD) -lavahi-common $(QT4_LIBS)
- @HAVE_QT4_TRUE@libavahi_qt4_la_LDFLAGS = $(AM_LDFLAGS) -export-dynamic -version-info $(LIBAVAHI_QT4_VERSION_INFO)
- CLEANFILES = $(BUILT_SOURCES)
- all: $(BUILT_SOURCES)
diff --git a/net/avahi/files/patch-configure b/net/avahi/files/patch-configure
deleted file mode 100644
index 141c9403f76b..000000000000
--- a/net/avahi/files/patch-configure
+++ /dev/null
@@ -1,18 +0,0 @@
---- configure.orig Sat Jun 23 02:05:47 2007
-+++ configure Sat Jun 23 02:13:52 2007
-@@ -20338,6 +20338,7 @@ echo $ECHO_N "checking whether to check
- check_inconsistencies=yes
- case "${host_cpu}-${host_os}" in
- *-darwin*) check_inconsistencies=no ;;
-+ *-freebsd*) check_inconsistencies=no ;;
- esac
- if test x"$GCC" != xyes -o "x$check_inconsistencies" != xyes ; then
- { echo "$as_me:$LINENO: result: no" >&5
-@@ -22442,6 +22443,7 @@ cat confdefs.h >>conftest.$ac_ext
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
- $ac_includes_default
-+#include <sys/socket.h>
- int
- main ()
- {
diff --git a/net/avahi/files/patch-initscript_freebsd_avahi-daemon.sh.in b/net/avahi/files/patch-initscript_freebsd_avahi-daemon.sh.in
deleted file mode 100644
index 564577bf0b9e..000000000000
--- a/net/avahi/files/patch-initscript_freebsd_avahi-daemon.sh.in
+++ /dev/null
@@ -1,17 +0,0 @@
---- initscript/freebsd/avahi-daemon.sh.in.orig Sun Nov 5 12:35:16 2006
-+++ initscript/freebsd/avahi-daemon.sh.in Sun Nov 5 12:36:51 2006
-@@ -9,10 +9,12 @@
- # Avahi's mDNSResponder, a Zeroconf (Bonjour) service advertisement daemon.
- #
-
--avahi_daemon_enable=${avahi_daemon_enable-"NO"}
- avahi_daemon_flags=${avahi_daemon_flags-"-D"}
-
--. /etc/rc.subr
-+. %%RC_SUBR%%
-+. %%GNOME_SUBR%%
-+
-+avahi_daemon_enable=${avahi_daemon_enable-${gnome_enable}}
-
- name=avahi_daemon
- rcvar=`set_rcvar`
diff --git a/net/avahi/files/patch-initscript_freebsd_avahi-dnsconfd.sh.in b/net/avahi/files/patch-initscript_freebsd_avahi-dnsconfd.sh.in
deleted file mode 100644
index 1e7939466c58..000000000000
--- a/net/avahi/files/patch-initscript_freebsd_avahi-dnsconfd.sh.in
+++ /dev/null
@@ -1,17 +0,0 @@
---- initscript/freebsd/avahi-dnsconfd.sh.in.orig Sun Nov 5 12:35:20 2006
-+++ initscript/freebsd/avahi-dnsconfd.sh.in Sun Nov 5 12:36:24 2006
-@@ -12,10 +12,12 @@
- # DNS servers in a DHCP-like fashion with mDNS.
- #
-
--avahi_dnsconfd_enable=${avahi_dnsconfd_enable-"NO"}
- avahi_dnsconfd_flags=${avahi_dnsconfd_flags-"-D"}
-
--. /etc/rc.subr
-+. %%RC_SUBR%%
-+. %%GNOME_SUBR%%
-+
-+avahi_dnsconfd_enable=${avahi_dnsconfd_enable-${gnome_enable}}
-
- name=avahi_dnsconfd
- rcvar=`set_rcvar`
diff --git a/net/avahi/files/patch-man_Makefile.in b/net/avahi/files/patch-man_Makefile.in
deleted file mode 100644
index b46557af681a..000000000000
--- a/net/avahi/files/patch-man_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- man/Makefile.in.orig Sat Jun 9 14:04:44 2007
-+++ man/Makefile.in Sat Jun 9 14:05:41 2007
-@@ -861,7 +861,7 @@ uninstall-man: uninstall-man1 uninstall-
- @HAVE_DBUS_TRUE@ $(LN_S) avahi-browse.1 avahi-browse-domains.1 && \
- @HAVE_DBUS_TRUE@ $(LN_S) avahi-publish.1 avahi-publish-address.1 && \
- @HAVE_DBUS_TRUE@ $(LN_S) avahi-publish.1 avahi-publish-service.1 && \
--@HAVE_DBUS_TRUE@ $(LN_S) bssh.1 bvnc.1
-+@HAVE_DBUS_TRUE@@HAVE_GTK_TRUE@ $(LN_S) bssh.1 bvnc.1
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
diff --git a/net/avahi/pkg-install b/net/avahi/pkg-install
deleted file mode 100644
index 9bbd14bce237..000000000000
--- a/net/avahi/pkg-install
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/bin/sh
-
-case $2 in
-POST-INSTALL)
- USER=avahi
- GROUP=${USER}
- UID=558
- GID=${UID}
- PW=/usr/sbin/pw
-
- if ${PW} group show "${GROUP}" 2>/dev/null; then
- echo "You already have a group \"${GROUP}\", so I will use it."
- else
- if ${PW} groupadd ${GROUP} -g ${GID}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- exit 1
- fi
- fi
-
- if ${PW} user show "${USER}" 2>/dev/null; then
- echo "You already have a user \"${USER}\", so I will use it."
- else
- if ${PW} useradd ${USER} -u ${UID} -g ${GROUP} -h - \
- -d "/nonexistent" -s /sbin/nologin -c "Avahi Daemon User"
- then
- echo "Added user \"${USER}\"."
- else
- echo "Adding user \"${USER}\" failed..."
- exit 1
- fi
- fi
- exit 0
- ;;
-esac
diff --git a/net/avahi/pkg-plist b/net/avahi/pkg-plist
deleted file mode 100644
index 25d108d0a72a..000000000000
--- a/net/avahi/pkg-plist
+++ /dev/null
@@ -1,133 +0,0 @@
-bin/avahi-browse
-bin/avahi-browse-domains
-%%GTK%%bin/avahi-discover-standalone
-bin/avahi-publish
-bin/avahi-publish-address
-bin/avahi-publish-service
-bin/avahi-resolve
-bin/avahi-resolve-address
-bin/avahi-resolve-host-name
-bin/avahi-set-host-name
-%%GTK%%bin/bssh
-%%GTK%%bin/bvnc
-etc/avahi/avahi-daemon.conf
-etc/avahi/avahi-dnsconfd.action
-etc/avahi/hosts
-etc/avahi/services/sftp-ssh.service
-etc/avahi/services/ssh.service
-etc/dbus-1/system.d/avahi-dbus.conf
-etc/rc.d/avahi-daemon.sh
-etc/rc.d/avahi-dnsconfd.sh
-include/avahi-client/client.h
-include/avahi-client/lookup.h
-include/avahi-client/publish.h
-include/avahi-common/address.h
-include/avahi-common/alternative.h
-include/avahi-common/cdecl.h
-include/avahi-common/defs.h
-include/avahi-common/domain.h
-include/avahi-common/error.h
-include/avahi-common/gccmacro.h
-include/avahi-common/llist.h
-include/avahi-common/malloc.h
-include/avahi-common/rlist.h
-include/avahi-common/simple-watch.h
-include/avahi-common/strlst.h
-include/avahi-common/thread-watch.h
-include/avahi-common/timeval.h
-include/avahi-common/watch.h
-include/avahi-compat-howl/corby/buffer.h
-include/avahi-compat-howl/corby/channel.h
-include/avahi-compat-howl/corby/corby.h
-include/avahi-compat-howl/corby/message.h
-include/avahi-compat-howl/corby/object.h
-include/avahi-compat-howl/corby/orb.h
-include/avahi-compat-howl/discovery/discovery.h
-include/avahi-compat-howl/discovery/text_record.h
-include/avahi-compat-howl/howl.h
-include/avahi-compat-howl/rendezvous/rendezvous.h
-include/avahi-compat-howl/rendezvous/text_record.h
-include/avahi-compat-howl/salt/address.h
-include/avahi-compat-howl/salt/debug.h
-include/avahi-compat-howl/salt/interface.h
-include/avahi-compat-howl/salt/platform.h
-include/avahi-compat-howl/salt/salt.h
-include/avahi-compat-howl/salt/signal.h
-include/avahi-compat-howl/salt/socket.h
-include/avahi-compat-howl/salt/time.h
-%%LIBDNS%%include/avahi-compat-libdns_sd/dns_sd.h
-include/avahi-core/core.h
-include/avahi-core/log.h
-include/avahi-core/lookup.h
-include/avahi-core/publish.h
-include/avahi-core/rr.h
-include/avahi-glib/glib-malloc.h
-include/avahi-glib/glib-watch.h
-%%GTK%%include/avahi-ui/avahi-ui.h
-lib/libavahi-client.a
-lib/libavahi-client.la
-lib/libavahi-client.so
-lib/libavahi-client.so.3
-lib/libavahi-common.a
-lib/libavahi-common.la
-lib/libavahi-common.so
-lib/libavahi-common.so.3
-lib/libavahi-core.a
-lib/libavahi-core.la
-lib/libavahi-core.so
-lib/libavahi-core.so.5
-lib/libavahi-glib.a
-lib/libavahi-glib.la
-lib/libavahi-glib.so
-lib/libavahi-glib.so.1
-%%GTK%%lib/libavahi-ui.a
-%%GTK%%lib/libavahi-ui.la
-%%GTK%%lib/libavahi-ui.so
-%%GTK%%lib/libavahi-ui.so.0
-%%LIBDNS%%lib/libdns_sd.a
-%%LIBDNS%%lib/libdns_sd.la
-%%LIBDNS%%lib/libdns_sd.so
-%%LIBDNS%%lib/libdns_sd.so.1
-lib/libhowl.a
-lib/libhowl.la
-lib/libhowl.so
-lib/libhowl.so.0
-libdata/pkgconfig/avahi-client.pc
-libdata/pkgconfig/avahi-compat-howl.pc
-%%LIBDNS%%libdata/pkgconfig/avahi-compat-libdns_sd.pc
-libdata/pkgconfig/avahi-core.pc
-libdata/pkgconfig/avahi-glib.pc
-%%GTK%%libdata/pkgconfig/avahi-ui.pc
-sbin/avahi-daemon
-sbin/avahi-dnsconfd
-%%GTK%%share/applications/bssh.desktop
-%%GTK%%share/applications/bvnc.desktop
-%%DATADIR%%/avahi-service.dtd
-%%GTK%%%%DATADIR%%/interfaces/avahi-discover.glade
-%%DATADIR%%/introspection/AddressResolver.introspect
-%%DATADIR%%/introspection/DomainBrowser.introspect
-%%DATADIR%%/introspection/EntryGroup.introspect
-%%DATADIR%%/introspection/HostNameResolver.introspect
-%%DATADIR%%/introspection/RecordBrowser.introspect
-%%DATADIR%%/introspection/Server.introspect
-%%DATADIR%%/introspection/ServiceBrowser.introspect
-%%DATADIR%%/introspection/ServiceResolver.introspect
-%%DATADIR%%/introspection/ServiceTypeBrowser.introspect
-%%DATADIR%%/service-types
-@dirrm %%DATADIR%%/introspection
-%%GTK%%@dirrm %%DATADIR%%/interfaces
-@dirrm %%DATADIR%%
-@dirrmtry share/applications
-%%GTK%%@dirrm include/avahi-ui
-@dirrm include/avahi-glib
-@dirrm include/avahi-core
-%%LIBDNS%%@dirrm include/avahi-compat-libdns_sd
-@dirrm include/avahi-compat-howl/salt
-@dirrm include/avahi-compat-howl/rendezvous
-@dirrm include/avahi-compat-howl/discovery
-@dirrm include/avahi-compat-howl/corby
-@dirrm include/avahi-compat-howl
-@dirrm include/avahi-common
-@dirrm include/avahi-client
-@dirrm etc/avahi/services
-@dirrm etc/avahi