aboutsummaryrefslogtreecommitdiff
path: root/net/avahi
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2006-02-19 07:04:48 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2006-02-19 07:04:48 +0000
commit3f88c858b13f4267f690c2a20415ea6c479909b9 (patch)
tree98c4b862d7326c627ffc38293413cd5413698367 /net/avahi
parent4737682cb3eae33141e50bcfd1cf030ab7049f78 (diff)
downloadports-3f88c858b13f4267f690c2a20415ea6c479909b9.tar.gz
ports-3f88c858b13f4267f690c2a20415ea6c479909b9.zip
Notes
Diffstat (limited to 'net/avahi')
-rw-r--r--net/avahi/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/net/avahi/Makefile b/net/avahi/Makefile
index 0eab7b6b0240..a375637c8063 100644
--- a/net/avahi/Makefile
+++ b/net/avahi/Makefile
@@ -7,23 +7,23 @@
PORTNAME= avahi
PORTVERSION= 0.6.5
-PORTREVISION= 2
-CATEGORIES= net dns
+PORTREVISION?= 2
+CATEGORIES?= net dns
MASTER_SITES= http://www.avahi.org/download/
-MAINTAINER= gnome@FreeBSD.org
-COMMENT= Service discovery on a local network
+MAINTAINER?= gnome@FreeBSD.org
+COMMENT?= Service discovery on a local network
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
+LIB_DEPENDS?= expat.6:${PORTSDIR}/textproc/expat2 \
daemon.2:${PORTSDIR}/devel/libdaemon \
dbus-1.2:${PORTSDIR}/devel/dbus \
gdbm.3:${PORTSDIR}/databases/gdbm
-USE_GNOME= gnomehack ltverhack glib20
+USE_GNOME?= gnomehack ltverhack glib20
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --with-distro=freebsd \
+CONFIGURE_ARGS?=--with-distro=freebsd \
--with-dbus-system-address=unix:path=/var/run/dbus \
--disable-qt3 \
--disable-qt4 \
@@ -38,6 +38,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
+.if !defined(AVAHI_SLAVE)
USE_RC_SUBR= yes
MAN1= avahi-browse-domains.1 avahi-browse.1 avahi-publish-address.1 \
@@ -47,9 +48,11 @@ MAN5= avahi-daemon.conf.5 avahi.service.5
MAN8= avahi-daemon.8 avahi-dnsconfd.8 avahi-dnsconfd.action.8
OPTIONS= GTK2 "Build a GTK+ 2 browser utility" off
+.endif
.include <bsd.port.pre.mk>
+.if !defined(AVAHI_SLAVE)
.if ${OSVERSION} < 500000
IGNORE= does not work on FreeBSD 4.X
.endif
@@ -67,4 +70,6 @@ post-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.endif
+.endif
+
.include <bsd.port.post.mk>