aboutsummaryrefslogtreecommitdiff
path: root/net/b2bua
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2006-07-18 21:52:28 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2006-07-18 21:52:28 +0000
commit940359dcbcc7799f58e49ba73a3750c5060b3358 (patch)
tree36ea10be688a6e39d37070797d4c01d61a9ca399 /net/b2bua
parent44e2fd5a0f3bce5f5d29041ac673fd6ea9e48dde (diff)
downloadports-940359dcbcc7799f58e49ba73a3750c5060b3358.tar.gz
ports-940359dcbcc7799f58e49ba73a3750c5060b3358.zip
Notes
Diffstat (limited to 'net/b2bua')
-rw-r--r--net/b2bua/files/patch-contrib::libcext_lgpl::Makefile14
-rw-r--r--net/b2bua/files/patch-contrib::libcext_lgpl::netdb_r.h21
2 files changed, 35 insertions, 0 deletions
diff --git a/net/b2bua/files/patch-contrib::libcext_lgpl::Makefile b/net/b2bua/files/patch-contrib::libcext_lgpl::Makefile
new file mode 100644
index 000000000000..b3f6b82371fd
--- /dev/null
+++ b/net/b2bua/files/patch-contrib::libcext_lgpl::Makefile
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- contrib/libcext_lgpl/Makefile
++++ contrib/libcext_lgpl/Makefile
+@@ -12,7 +12,7 @@
+ # Darwin
+
+ AR=libtool -static -o
+-OBJS = poll.o pthread_adds.o gethostby_r.o getnetby_r.o getprotoby_r.o getpw_r.o getservby_r.o
++OBJS = getpw_r.o
+
+ HEADERS = poll.h pthread_adds.h
+ else
diff --git a/net/b2bua/files/patch-contrib::libcext_lgpl::netdb_r.h b/net/b2bua/files/patch-contrib::libcext_lgpl::netdb_r.h
new file mode 100644
index 000000000000..96c215960a96
--- /dev/null
+++ b/net/b2bua/files/patch-contrib::libcext_lgpl::netdb_r.h
@@ -0,0 +1,21 @@
+
+$FreeBSD$
+
+--- contrib/libcext_lgpl/netdb_r.h
++++ contrib/libcext_lgpl/netdb_r.h
+@@ -2,6 +2,7 @@
+ extern "C" {
+ #endif
+
++#if !defined(__FreeBSD__)
+ struct hostent *
+ gethostbyaddr_r (const char *addr, int length, int type,
+ struct hostent *result, char *buffer, int buflen,
+@@ -15,6 +16,7 @@
+ struct hostent *
+ gethostent_r (struct hostent *result, char *buffer, int buflen,
+ int *h_errnop);
++#endif
+
+ #ifdef __cplusplus
+ }