aboutsummaryrefslogtreecommitdiff
path: root/net/b2bua
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2003-01-31 12:08:58 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2003-01-31 12:08:58 +0000
commit8cc26e8d9db3e6ab5dc047cb4d72927948d24605 (patch)
tree5b6cbc85169ec072d3978a1e3577313488b0e2ad /net/b2bua
parent1e89a01429e07b8c2f8720621e5738ae61df9b3c (diff)
downloadports-8cc26e8d9db3e6ab5dc047cb4d72927948d24605.tar.gz
ports-8cc26e8d9db3e6ab5dc047cb4d72927948d24605.zip
Notes
Diffstat (limited to 'net/b2bua')
-rw-r--r--net/b2bua/Makefile22
-rw-r--r--net/b2bua/files/patch-util::threads::vthread-linux.cxx18
2 files changed, 25 insertions, 15 deletions
diff --git a/net/b2bua/Makefile b/net/b2bua/Makefile
index 15baa0fc552c..5d83032a857a 100644
--- a/net/b2bua/Makefile
+++ b/net/b2bua/Makefile
@@ -7,33 +7,25 @@
PORTNAME= b2bua
PORTVERSION= 1.4.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.vovida.org/downloads/b2bua/
MAINTAINER= sobomax@FreeBSD.org
-LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
- lthread:${PORTSDIR}/devel/linuxthreads
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
USE_GMAKE= yes
ALL_TARGET= b2bua
-CFLAGS+= -I${LOCALBASE}/include/pthread/linuxthreads \
- -I${LOCALBASE}/include/libxml2 \
+CFLAGS+= -I${LOCALBASE}/include/libxml2 \
-I${LOCALBASE}/include/libxml2/libxml \
-I${LOCALBASE}/include -Wno-deprecated
-PTHREAD_LDFLAGS= -L${LOCALBASE}/lib -llthread -llgcc_r
-MAKE_ENV= PTHREAD_LDFLAGS="${PTHREAD_LDFLAGS}" \
- PTHREAD_LIBNAME=""
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500035
-PTHREAD_LDFLAGS+= -llstdc++ -llsupc++
-.endif
+MAKE_ENV= PTHREAD_LDFLAGS="${PTHREAD_LIBS}" \
+ PTHREAD_LIBNAME="${PTHREAD_LIBNAME}"
.if !exists(/usr/include/getopt.h)
LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-PTHREAD_LDFLAGS+= -lgnugetopt
+PTHREAD_LIBNAME+= gnugetopt
.endif
do-install:
@@ -46,4 +38,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/sip/b2b/b2bConfig.xml \
${PREFIX}/etc/b2bConfig.xml.sample
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/b2bua/files/patch-util::threads::vthread-linux.cxx b/net/b2bua/files/patch-util::threads::vthread-linux.cxx
new file mode 100644
index 000000000000..47add5110f42
--- /dev/null
+++ b/net/b2bua/files/patch-util::threads::vthread-linux.cxx
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- util/threads/vthread-linux.cxx 2003/01/31 09:50:14 1.1
++++ util/threads/vthread-linux.cxx 2003/01/31 09:52:19
+@@ -191,6 +191,12 @@
+ pthread_attr_setscope(&myAttributes, PTHREAD_SCOPE_SYSTEM);
+ #endif
+
++#if defined (__FreeBSD__)
++ // Default FreeBSD thread stack size (64KB) is not sufficient for the
++ // b2bua bloatware
++ pthread_attr_setstacksize (&myAttributes, 1024*1024);
++#endif
++
+ // spawn the thread
+ return ( pthread_create( &myId, &myAttributes, startFunc, startArgs ) );
+ }