aboutsummaryrefslogtreecommitdiff
path: root/net/balance
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2000-12-30 08:15:18 +0000
committerKevin Lo <kevlo@FreeBSD.org>2000-12-30 08:15:18 +0000
commitf3331cf9a6fddb207781d3b7c35df2b4d1b9003b (patch)
treee1518dd7872058612cbf15649dba2b4d2ac66fc0 /net/balance
parent989eb9a1c98b199f5c347101af6a9a6b23c13da2 (diff)
downloadports-f3331cf9a6fddb207781d3b7c35df2b4d1b9003b.tar.gz
ports-f3331cf9a6fddb207781d3b7c35df2b4d1b9003b.zip
Notes
Diffstat (limited to 'net/balance')
-rw-r--r--net/balance/Makefile2
-rw-r--r--net/balance/distinfo2
-rw-r--r--net/balance/files/patch-aa35
3 files changed, 37 insertions, 2 deletions
diff --git a/net/balance/Makefile b/net/balance/Makefile
index 471e6f5e0b82..da68fa3a4eca 100644
--- a/net/balance/Makefile
+++ b/net/balance/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= balance
-PORTVERSION= 2.16
+PORTVERSION= 2.24
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= balance
diff --git a/net/balance/distinfo b/net/balance/distinfo
index 3ca0cd14e71f..a17f21901dc0 100644
--- a/net/balance/distinfo
+++ b/net/balance/distinfo
@@ -1 +1 @@
-MD5 (balance-2.16.tar.gz) = 230bf1e87c75f0a008f4f7285a298f1f
+MD5 (balance-2.24.tar.gz) = 49fb4e1ef536d04dea94b963081abdf8
diff --git a/net/balance/files/patch-aa b/net/balance/files/patch-aa
new file mode 100644
index 000000000000..bff83c0db933
--- /dev/null
+++ b/net/balance/files/patch-aa
@@ -0,0 +1,35 @@
+--- Makefile.orig Fri Dec 29 12:20:10 2000
++++ Makefile Fri Dec 29 12:20:39 2000
+@@ -1,11 +1,11 @@
+ # $Id: Makefile,v 1.6 2000/07/23 10:03:11 tommy Exp $
+
+-CFLAGS=-g -I.
++# CFLAGS=-g -I.
+
+ # uncomment for Solaris:
+ # LIBRARIES=-lsocket -lnsl
+
+-CC=gcc
++# CC=gcc
+
+ balance: balance.c
+ $(CC) $(CFLAGS) -o balance balance.c $(LIBRARIES)
+--- balance.c.orig Fri Dec 29 12:14:00 2000
++++ balance.c Fri Dec 29 12:14:21 2000
+@@ -19,6 +19,7 @@
+ // 'channel 2 overload' problem fixed, thanks to Ed "KuroiNeko"
+ //
+
++#include <sys/types.h>
+ #include <stdio.h>
+ #include <strings.h>
+ #include <ctype.h>
+@@ -27,7 +28,7 @@
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <signal.h>
+-#include <malloc.h>
++#include <stdlib.h>
+
+ #ifdef __FreeBSD__
+ #define MYBSD 1